R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 05-15-2011, 01:27 AM   #691
Tech Master
 
Join Date: Feb 2009
Posts: 1,920
Trader Rating: 1 (100%+)
Default

Quote:
Originally Posted by Mr. MR4 View Post
Hi,

I will be attending the last Round of the ETS in July in Andernach, using the Cirtix and SP 13.5 V3 motor.

What gearing should I start off with and what temperatures should I be reaching in 1/10 TC?

Thanks
Karl
last year we were at 4.0 gear ratio temps to 80 are normal in the 0 timing class but at this ratio you should be ok on almost any track
sidecarphil1 is offline   Reply With Quote
Old 05-24-2011, 04:40 PM   #692
Tech Regular
 
Join Date: May 2011
Location: Orange County, CA
Posts: 389
Trader Rating: 27 (100%+)
Default

Hey guys,

For those of you who run the Cirtix ESC/17.5 motor, how does it compare to a Novak Ballistic 17.5 motor? (No timing, geared around 3.8-4)

I just picked up an Xray T3 and I have a Ballistic 17.5 and GTB2 which I'd like to run in it, but I need something for my Tamiya TA05 V2 R which I'd like to also race. I don't mind moving the same motor back and forth but if these Cirtix setups are as good as they seem, for the price I think it would be worth it.
RC.Jon22 is offline   Reply With Quote
Old 05-24-2011, 06:25 PM   #693
Tech Fanatic
 
fat500's Avatar
 
Join Date: May 2004
Location: Boca Raton, florida
Posts: 983
Trader Rating: 29 (100%+)
Default

I am wondering the exact opposite. I run a cirtix in my tao5 v2 and love it in rcgt runs cool and strong but was thinking of getting a gtb2/ ballistic combo for my ta06 pro. I was wondering about heat issues/fade with the novak. the cirtix is very cool and fast. i just wanted to try the novak but do not want loose the edge I have with cirtix.
fat500 is offline   Reply With Quote
Old 05-24-2011, 07:56 PM   #694
Tech Regular
 
Join Date: May 2011
Location: Orange County, CA
Posts: 389
Trader Rating: 27 (100%+)
Default

Quote:
Originally Posted by fat500 View Post
I am wondering the exact opposite. I run a cirtix in my tao5 v2 and love it in rcgt runs cool and strong but was thinking of getting a gtb2/ ballistic combo for my ta06 pro. I was wondering about heat issues/fade with the novak. the cirtix is very cool and fast. i just wanted to try the novak but do not want loose the edge I have with cirtix.
Looks like I came to the right place, and same for you! I have a TA05 V2 R but just picked up an Xray T3. I'm using the GTB2/Ballistic 17.5, geared to down to 3.5-4.0, no timing of course, and it flies. Never gets that hot either, but I don't run it for more than 10-15 minutes at a time. It barely gets warm.

The GTB2 and Ballistic run about $100 each, so $200. I don't have the cash for another set, and when I do decide to spend that much, I was thinking of going with a Tekin RS esc so I can have timing. My local track has the Speed Passion Cirtix esc and 17.5 for $90 which is why I really am curious how it performs. Do you like yours a lot? Can you get pretty high speeds with proper gearing?

Thanks!
RC.Jon22 is offline   Reply With Quote
Old 05-25-2011, 09:24 AM   #695
Tech Champion
 
Join Date: Sep 2002
Location: Chicago Illinois USA
Posts: 9,106
Trader Rating: 16 (100%+)
Send a message via ICQ to Solara Send a message via AIM to Solara
Default

Quote:
Originally Posted by RC.Jon22 View Post
Looks like I came to the right place, and same for you! I have a TA05 V2 R but just picked up an Xray T3. I'm using the GTB2/Ballistic 17.5, geared to down to 3.5-4.0, no timing of course, and it flies. Never gets that hot either, but I don't run it for more than 10-15 minutes at a time. It barely gets warm.

The GTB2 and Ballistic run about $100 each, so $200. I don't have the cash for another set, and when I do decide to spend that much, I was thinking of going with a Tekin RS esc so I can have timing. My local track has the Speed Passion Cirtix esc and 17.5 for $90 which is why I really am curious how it performs. Do you like yours a lot? Can you get pretty high speeds with proper gearing?

Thanks!
Go advance like 2-4mm counterclockwise on the V2 motor for the extra timing, with that, the V2 can be as fast as other brand motor...try it, we have alot of USGT car running the same motor that can run against D3 and Ballistic...
Solara is offline   Reply With Quote
Old 06-03-2011, 02:02 PM   #696
Tech Master
 
gene1219's Avatar
R/C Tech Elite Subscriber
 
Join Date: Sep 2009
Location: Wheaton
Posts: 1,874
Trader Rating: 16 (100%+)
Default

I just purchased this system and it's great & super smooth.

I was just wondering if I can use my speedgems 12.5t motor with the the stock citrix esc?
gene1219 is offline   Reply With Quote
Old 06-08-2011, 08:22 PM   #697
Tech Elite
 
Join Date: Dec 2009
Location: Sarasota FL
Posts: 2,059
Trader Rating: 48 (93%+)
Default

I got one of these systems used with a tc. and trying to set it up with my raido. have tried 3 diffent raidos. I hold the set buttion down and turn the switch on and it enters setup mode. I leave the raido in nutral pos and hit the set buttion it beeps. and i pull full thro hold it and press the buttion and it beeps again. full brake hold it press the set buttion it finshes its beeping and goes to solid red and stayes there. wont do any thing. i have steering.. the motor is good tested with other esc tried seting it up with out sensor wire pluged in. same thing 3 diffent raidos 3pk spek mod, dx3s,flysky gt3b... any idea? the motor is a sp 17.5 that comes with the combo....
tcb22185 is offline   Reply With Quote
Old 06-09-2011, 08:10 AM   #698
Tech Champion
 
Join Date: Sep 2002
Location: Chicago Illinois USA
Posts: 9,106
Trader Rating: 16 (100%+)
Send a message via ICQ to Solara Send a message via AIM to Solara
Default

Quote:
Originally Posted by tcb22185 View Post
I got one of these systems used with a tc. and trying to set it up with my raido. have tried 3 diffent raidos. I hold the set buttion down and turn the switch on and it enters setup mode. I leave the raido in nutral pos and hit the set buttion it beeps. and i pull full thro hold it and press the buttion and it beeps again. full brake hold it press the set buttion it finshes its beeping and goes to solid red and stayes there. wont do any thing. i have steering.. the motor is good tested with other esc tried seting it up with out sensor wire pluged in. same thing 3 diffent raidos 3pk spek mod, dx3s,flysky gt3b... any idea? the motor is a sp 17.5 that comes with the combo....
After the setup, you have to turn off the ESC and radio then turn back on in order to get that running.
Solara is offline   Reply With Quote
Old 06-09-2011, 08:12 AM   #699
Tech Champion
 
Join Date: Sep 2002
Location: Chicago Illinois USA
Posts: 9,106
Trader Rating: 16 (100%+)
Send a message via ICQ to Solara Send a message via AIM to Solara
Default

Quote:
Originally Posted by gene1219 View Post
I just purchased this system and it's great & super smooth.

I was just wondering if I can use my speedgems 12.5t motor with the the stock citrix esc?
Never tried that brand before...you can simply wire it onto the ESC and if it works, it works.....the worst case is, the motor is not spinning, it worth to try it...
Solara is offline   Reply With Quote
Old 06-09-2011, 04:33 PM   #700
Tech Elite
 
Join Date: Dec 2009
Location: Sarasota FL
Posts: 2,059
Trader Rating: 48 (93%+)
Default

Quote:
Originally Posted by Solara View Post
After the setup, you have to turn off the ESC and radio then turn back on in order to get that running.
ok then how do u know its full thro there is no green light that lights up.
tcb22185 is offline   Reply With Quote
Old 06-10-2011, 08:30 AM   #701
Tech Champion
 
Join Date: Sep 2002
Location: Chicago Illinois USA
Posts: 9,106
Trader Rating: 16 (100%+)
Send a message via ICQ to Solara Send a message via AIM to Solara
Default

Quote:
Originally Posted by tcb22185 View Post
ok then how do u know its full thro there is no green light that lights up.
If no green light, your setup is not correct...recalibrate again with the ESC and make sure your RADIO setting is in default position, not at max like 120% on Futaba or 150% on KO...especially on throttle EPA.
Solara is offline   Reply With Quote
Old 06-10-2011, 01:00 PM   #702
Tech Elite
 
Join Date: Dec 2009
Location: Sarasota FL
Posts: 2,059
Trader Rating: 48 (93%+)
Default

how many lights is there im only seeing 2leds in the case yellow and red. i give it gas they both go out no green comes on. tried adj my epa to 100 same issue. tried another raido same thing. looks like i got a bum one..
tcb22185 is offline   Reply With Quote
Old 06-14-2011, 11:47 AM   #703
Tech Champion
 
Join Date: Sep 2002
Location: Chicago Illinois USA
Posts: 9,106
Trader Rating: 16 (100%+)
Send a message via ICQ to Solara Send a message via AIM to Solara
Default

Quote:
Originally Posted by tcb22185 View Post
how many lights is there im only seeing 2leds in the case yellow and red. i give it gas they both go out no green comes on. tried adj my epa to 100 same issue. tried another raido same thing. looks like i got a bum one..
I am sorry, there are no GREEN LIGHT on club spec...only for the pro version.
Solara is offline   Reply With Quote
Old 06-27-2011, 11:09 PM   #704
Tech Regular
 
Dan415ms's Avatar
 
Join Date: May 2005
Location: Stonehaven, Scotland
Posts: 386
Questions?? Cirtix Inspire 2.0 and Spextrum DX3E problem

Hi R/C friends,

I've started the very first track here in Oman and it is very popular.

I'm setting up a car for a new member and have used a new Speed Passion Cirtix Inspire 2.0 and 4000kv sensorless combo.

He is using a new Spektrum DX3E radio.

The problem I'm facing is that after ESC calibration, the speedo has a delay - if a little throttle is applied on the tx and then returned to neutral, it takes a long time for the motor to stop or return to neutral, as if throttle is still on for around 2 or 3 seconds.

Same issue (a bit worse) with the brakes, after full throttle, the motor will take 3 seconds to respond to any brake input from the tx....very annoying and undriveable.

I went to the shop and took another new combo but it had exactly the same symptoms.

I have tried recalibrating the ESC (hold set button then neutral, full trottle, full brake) numerous times to no avail.

Maybe a compatibility issue?

Thanks, help!

Dan
Dan415ms is offline   Reply With Quote
Old 06-28-2011, 01:49 AM   #705
Tech Master
 
PizzaDude's Avatar
 
Join Date: Nov 2002
Location: Parts Unkown
Posts: 1,044
Default

Quote:
Originally Posted by Dan415ms View Post
Hi R/C friends,

I've started the very first track here in Oman and it is very popular.

I'm setting up a car for a new member and have used a new Speed Passion Cirtix Inspire 2.0 and 4000kv sensorless combo.

He is using a new Spektrum DX3E radio.

The problem I'm facing is that after ESC calibration, the speedo has a delay - if a little throttle is applied on the tx and then returned to neutral, it takes a long time for the motor to stop or return to neutral, as if throttle is still on for around 2 or 3 seconds.

Same issue (a bit worse) with the brakes, after full throttle, the motor will take 3 seconds to respond to any brake input from the tx....very annoying and undriveable.

I went to the shop and took another new combo but it had exactly the same symptoms.

I have tried recalibrating the ESC (hold set button then neutral, full trottle, full brake) numerous times to no avail.

Maybe a compatibility issue?

Thanks, help!

Dan
Had the same problem with that combo (other rx though).
Because it's sensorless. Large fdr won't help either.
Also responsetime for the brakes took about a sec.

I ran the same esc sensorred , day+night. It ran ok.
PizzaDude is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
World GT Club Racing - To spec or not to spec is the question???? Mr. McGoo Electric On-Road 722 11-01-2014 07:05 AM
Real Stock On Road Racing... Me_MrTyson Australian Racing 214 05-19-2010 06:06 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 07:30 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net