R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 09-17-2010, 11:15 AM   #421
Tech Champion
 
Join Date: Sep 2002
Location: Chicago Illinois USA
Posts: 9,106
Trader Rating: 16 (100%+)
Send a message via ICQ to Solara Send a message via AIM to Solara
Default

Quote:
Originally Posted by jackdani View Post
u r right...
i m worryng only because this is my first car and my first lipo and my first brushless!!!
so in the case my lipo is not well charged or i miss something i dont want theme to be ruined.
this is what i was asking....u r a big help!!
so the car will stop anyway befor 10 minutes because the esc will cut around 3.5 right?

may i ask u another question because u seems to know well the club race combo.
i adjusted the throttle range the first time i switch on the esc ad told in the manual, BUT i forgot to put throttle on REV before doing it. anyway it worked and the motor seems to rum properly BUT the lights are strange:
red light flashing even in neutral and yellow light always on....is this a problem?

thanks
Yes...you are doing fine as long as your car is going FORWARD when you apply the throttle in forward position. Don't worry about the lights too much.

The throttle REV is more for the Futaba Radio.....
Solara is offline   Reply With Quote
Old 09-17-2010, 11:33 AM   #422
Tech Addict
 
js058515's Avatar
 
Join Date: Oct 2008
Location: SoCal
Posts: 574
Trader Rating: 6 (100%+)
Default

"Low voltage cut-off protection: If the lithium battery pack’s voltage is lower than the threshold for 2 seconds, the ESC will cut the output power. Please note that the ESC cannot be restarted if the voltage of each lithium cell is lower than 3.5V. You can disable cutoff voltage protection function for competition racing.

For NiMh/NiCd battery packs, if the voltage of the whole NiMh/NiCd battery pack is higher than 12V, it will be considered as a 4 cell lithium battery pack; If it is higher than 9.0V but lower than 12V, it will be considered as a 3 cell lithium battery pack; If it is lower than 9.0V, it will be considered as a 2 cell lithium battery pack. For example, a NiMh battery pack is 8.0V, and the threshold is set to 2.6V/Cell, so it will be considered as a 2 cell lithium battery pack, and the low-voltage cut-off threshold for this NiMh battery pack is 2.6*2=5.2V."

Source: Cirtix series Brushless Motor Speed Controller manual “V1.1-5222010a”
js058515 is offline   Reply With Quote
Old 09-17-2010, 11:41 AM   #423
Tech Adept
 
jackdani's Avatar
 
Join Date: Jul 2010
Posts: 198
Default

Quote:
Originally Posted by js058515 View Post
"Low voltage cut-off protection: If the lithium battery packs voltage is lower than the threshold for 2 seconds, the ESC will cut the output power. Please note that the ESC cannot be restarted if the voltage of each lithium cell is lower than 3.5V. You can disable cutoff voltage protection function for competition racing.

For NiMh/NiCd battery packs, if the voltage of the whole NiMh/NiCd battery pack is higher than 12V, it will be considered as a 4 cell lithium battery pack; If it is higher than 9.0V but lower than 12V, it will be considered as a 3 cell lithium battery pack; If it is lower than 9.0V, it will be considered as a 2 cell lithium battery pack. For example, a NiMh battery pack is 8.0V, and the threshold is set to 2.6V/Cell, so it will be considered as a 2 cell lithium battery pack, and the low-voltage cut-off threshold for this NiMh battery pack is 2.6*2=5.2V."

Source: Cirtix series Brushless Motor Speed Controller manual V1.1-5222010a

so cut off will work even if i dont/cant set it...as the manual seems to say???
jackdani is offline   Reply With Quote
Old 09-17-2010, 01:30 PM   #424
Tech Master
 
IndyRC_Racer's Avatar
 
Join Date: Jul 2006
Location: Indianapolis
Posts: 1,820
Trader Rating: 9 (100%+)
Default

Can't seem to get my Cirtix Stock Club ESC to work with any sensored motor. When I turn on the speed control with the sensored wire attached, it has a constant beep, beep, beep, etc... If I remove the sensor wire, the speed control seems to work normally as well as the motor attached to it.

Was planning on using this speed control with a 25.5 in VTA.

I have tried 2 different brushless motors - an old Novak 4300/10.5 and a Ballistic 25.5 motor with the same results. I have double checked that the ABC wires are attached in the correct order on the speed control. I have also tried 2 different receivers with the same result.

I have tried 2 different Futaba transmitters and have confirmed that the throttle channel was "reversed".

I did shorten the speed control to receiver wire, but I have also double checked that those connections are good.

Anything obvious that I'm overlooking??
__________________
I'm currently racing VTA. Check here for rules/info: http://www.usvintagetransam.com/

Last edited by IndyRC_Racer; 09-17-2010 at 02:00 PM.
IndyRC_Racer is offline   Reply With Quote
Old 09-17-2010, 03:32 PM   #425
Tech Champion
 
Join Date: Sep 2002
Location: Chicago Illinois USA
Posts: 9,106
Trader Rating: 16 (100%+)
Send a message via ICQ to Solara Send a message via AIM to Solara
Default

Quote:
Originally Posted by IndyRC_Racer View Post
Can't seem to get my Cirtix Stock Club ESC to work with any sensored motor. When I turn on the speed control with the sensored wire attached, it has a constant beep, beep, beep, etc... If I remove the sensor wire, the speed control seems to work normally as well as the motor attached to it.

Was planning on using this speed control with a 25.5 in VTA.

I have tried 2 different brushless motors - an old Novak 4300/10.5 and a Ballistic 25.5 motor with the same results. I have double checked that the ABC wires are attached in the correct order on the speed control. I have also tried 2 different receivers with the same result.

I have tried 2 different Futaba transmitters and have confirmed that the throttle channel was "reversed".

I did shorten the speed control to receiver wire, but I have also double checked that those connections are good.

Anything obvious that I'm overlooking??
See you can borrow a SPEED PASSION or TRINITY base motor and give that a try...just try to make sure the ESC has problem or not. Give that a try first.
Solara is offline   Reply With Quote
Old 09-17-2010, 09:49 PM   #426
Tech Regular
 
qcrc's Avatar
 
Join Date: May 2006
Location: IA Quad Cities
Posts: 363
Trader Rating: 11 (100%+)
Default

Did the wires get reattched in the right order? Might be the causeif they are wrong.
__________________
https://www.facebook.com/ISLANDSPEEWAY/
qcrc is offline   Reply With Quote
Old 09-18-2010, 11:11 AM   #427
Tech Regular
 
CLK@racing's Avatar
 
Join Date: Oct 2007
Posts: 343
Trader Rating: 1 (100%+)
Default

Hi,

Anyone can advise on the gear ratio range for this combo on 13.5 and 17.5?
CLK@racing is offline   Reply With Quote
Old 09-18-2010, 11:32 AM   #428
Tech Regular
 
Join Date: Mar 2009
Posts: 351
Trader Rating: 1 (100%+)
Default

Quote:
Originally Posted by [email protected] View Post
Hi,

Anyone can advise on the gear ratio range for this combo on 13.5 and 17.5?
For 17.5 anywhere from 3.3-4.0 depending on track and size.I just ran mine last night at a local hobbytown,raced rcgt with it in my cyclone s geared 3.72.It had good punch infield and good top end for our short staightaway.Not sure though where the motor should be temped but on the side it read 180'ish and the back 130'ish after a 5 min heat race.The ambient temps were around 100 and the track lots more than that.This esc and motor ran great and gave me no problems so far.
airwoods is offline   Reply With Quote
Old 09-18-2010, 12:15 PM   #429
Tech Master
 
trx450racer174's Avatar
 
Join Date: Mar 2008
Location: Moreno Valley,CA
Posts: 1,261
Trader Rating: 7 (100%+)
Default

I have my 2 Cyclones geared at 3.5 and run them on small to large tracks asphault tracks.

Temp on the motor is usually 125ish.

Last time out it was 100+ outside and the motors got warm 160+ so i added heatsinks and fans to be extra cautious.

__________________
E.K.D. RC Paint Work
Team Serpent USA, Desoto Racing , Team DE Racing, Team Hitec, Team Trakpower, Futaba, Team AKA, TrackstarRC.
trx450racer174 is offline   Reply With Quote
Old 09-20-2010, 03:58 PM   #430
Tech Fanatic
 
mr240's Avatar
 
Join Date: Feb 2010
Location: Chula Vista, CA
Posts: 955
Trader Rating: 61 (100%+)
Default

Anybody got an stock spec ESC they want to sell.
mr240 is offline   Reply With Quote
Old 09-20-2010, 05:28 PM   #431
Tech Addict
 
js058515's Avatar
 
Join Date: Oct 2008
Location: SoCal
Posts: 574
Trader Rating: 6 (100%+)
Default

I swore I saw one in the for sale thread a couple days ago. They wanted $50 shipped for just the ESC.
js058515 is offline   Reply With Quote
Old 09-22-2010, 11:57 AM   #432
Tech Addict
 
maximebeauvais's Avatar
 
Join Date: Feb 2005
Location: Gatineau, QC, Canada (beside Ottawa)
Posts: 748
Trader Rating: 6 (88%+)
Default

after 1 year and half out of racing, I came back last week.

got the second best time, finished 3rd.

track is around 70 feet x 70 feet

losi type r
rubber tire
17.5 combo
4.8 fdr and i was getting a temp of 100
4.6 fdr and I was getting around 115

next time I will try 4 - 4.4 fdr

what will be the max temp for the 17.5 motor?

thanks
__________________
Maxime Beauvais
--- www.rcottawa.com ---
maximebeauvais is offline   Reply With Quote
Old 09-22-2010, 01:50 PM   #433
Tech Addict
 
js058515's Avatar
 
Join Date: Oct 2008
Location: SoCal
Posts: 574
Trader Rating: 6 (100%+)
Default

I have had mine up to 170, but I didn't like it there at all. My local track has a Citrix 17.5 series and that track owner seems to like the motor temp around 150.

When I ran my combo in my Type R, I was getting only 105 running 3.9 FDR. Track is indoor carpet and not sure of exact measurements.

Quote:
Originally Posted by maximebeauvais View Post
after 1 year and half out of racing, I came back last week.

got the second best time, finished 3rd.

track is around 70 feet x 70 feet

losi type r
rubber tire
17.5 combo
4.8 fdr and i was getting a temp of 100
4.6 fdr and I was getting around 115

next time I will try 4 - 4.4 fdr

what will be the max temp for the 17.5 motor?

thanks
js058515 is offline   Reply With Quote
Old 09-22-2010, 08:19 PM   #434
Tech Champion
 
k_bojar's Avatar
 
Join Date: Oct 2001
Location: Philadelphia, PA
Posts: 7,009
Trader Rating: 30 (100%+)
Send a message via ICQ to k_bojar Send a message via AIM to k_bojar
Default

hey guys - just got one of the Cirtix speedos and i got a question..

was looking thru the instructions and didn't see how to program the speedo WITHOUT the box - is this possible?

Its the club spec so i know i can only do so much adjusting, but like to remove some drag brake and adjust a couple of the other things I can

thanks for any help - tomorrow at work, i'll go thru the whole thread
__________________
Bodies By Bean | Team Belly
k_bojar is offline   Reply With Quote
Old 09-22-2010, 09:01 PM   #435
Tech Addict
 
js058515's Avatar
 
Join Date: Oct 2008
Location: SoCal
Posts: 574
Trader Rating: 6 (100%+)
Default

You will need access to a programming box to make any changes. If you got it from a LHS or a track/Hobby shop I am sure they will let you use theirs. My track let me, of course that's where I bought it from and they run a Citrix 17.5 series.

Quote:
Originally Posted by k_bojar View Post
hey guys - just got one of the Cirtix speedos and i got a question..

was looking thru the instructions and didn't see how to program the speedo WITHOUT the box - is this possible?

Its the club spec so i know i can only do so much adjusting, but like to remove some drag brake and adjust a couple of the other things I can

thanks for any help - tomorrow at work, i'll go thru the whole thread
js058515 is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
World GT Club Racing - To spec or not to spec is the question???? Mr. McGoo Electric On-Road 722 11-01-2014 07:05 AM
Real Stock On Road Racing... Me_MrTyson Australian Racing 214 05-19-2010 06:06 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 05:52 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net