R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 02-17-2010, 01:17 PM   #61
Tech Elite
 
JayL's Avatar
R/C Tech Elite Subscriber
 
Join Date: Mar 2006
Location: Ca
Posts: 2,880
Default

Quote:
Originally Posted by NovakTwo View Post
All ROAR approved, Spec motors are built to the same specifications. ESCs featuring timing advance options have to work on these motors as approved.
agreed, BUT that does not mean you make your motor to work great an a system type you don't even make....maybe there is a reason you don't make timing advance esc's.......

"Working" and "optimized for" are two FAR different things



Don't get me wrong as anti, I run a ballistic 10.5 in my SC truck, just not with a timing advance esc
JayL is offline   Reply With Quote
Old 02-18-2010, 09:50 AM   #62
Company Representative
R/C Tech Elite Subscriber
 
Join Date: Jun 2005
Location: SoCal
Posts: 2,891
Default

Quote:
Originally Posted by JayL View Post
agreed, BUT that does not mean you make your motor to work great an a system type you don't even make....maybe there is a reason you don't make timing advance esc's.......

"Working" and "optimized for" are two FAR different things

Don't get me wrong as anti, I run a ballistic 10.5 in my SC truck, just not with a timing advance esc
Our motors work fine with escs featuring advanced timing programming options, including our upcoming Kinetic and Kinetic 1S.

That is why we are trying to get info about the servos used in these problem set-ups. Have any of you experiencing problems run separate BEC modules with the servos described above?
NovakTwo is offline   Reply With Quote
Old 03-02-2010, 02:03 PM   #63
Tech Addict
 
csracing's Avatar
 
Join Date: Nov 2009
Location: Sheboygan, WI
Posts: 726
Trader Rating: 22 (100%+)
Default

Isssue resolved. Replaced the Novak motor with a Duo2.
csracing is offline   Reply With Quote
Old 03-02-2010, 02:21 PM   #64
Tech Fanatic
 
Join Date: Feb 2009
Location: Lynnwood, Washington
Posts: 791
Trader Rating: 8 (100%+)
Default

I had no major issues running a ballistic 17.5 with a tekin rs. I am running a non-digital servo though.

Only issue I had was trying to run 0 timing on the motor. I was able to run 0 on my redline 17.5 but not on the ballistic (the motor seemed gutless with less than N timing). The motor had lots of power and stayed around 160 degrees once I set the timing to N (same RS settings my redline had: boost 50, turbo 10, turbo timing .4, turbo ramp 3, 2700 - 7000).
malkiy is offline   Reply With Quote
Old 03-02-2010, 09:47 PM   #65
Tech Addict
 
Join Date: Jun 2009
Posts: 678
Trader Rating: 10 (92%+)
Default

im running a novak ss pro with tekin 203 with no problems.

went to the duo2 now, and its dog slow now. Although the brakes with the duo2 is now better, but got nothing on the novak in terms of speed. Or maybe I got a dud motor.
captain stacker is offline   Reply With Quote
Old 03-02-2010, 11:15 PM   #66
Tech Elite
 
mjc168's Avatar
 
Join Date: Jul 2007
Posts: 2,808
Trader Rating: 25 (100%+)
Default

I had the exact same issue while running team power motor with tekin rs pro. no turbo and advanced timing apply. after check, i notice that the small sensor LED in rs pro is not light up (mean the esc not able to read/detect the sensor). I had changed few sensor wire but no luck. This happen to my team mate as well. We had tested 5 units tekin rs pro and 4 units team power motor. Only 1 rs pro working fine, no luck for the rest. The working rs pro is the oldest esc among us.

p/s: other than team power motor is worked.
__________________
http://www.pprcc.com/

1/10 On-road Touring: Schumacher MI3 + Tekin RS Pro + Orca RX-1 11.5t BL Motor
1/10 On-road Touring: Xray T3 2011 + Tekin RS Pro + Tekin Redline 10.5t BL Motor
mjc168 is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Tekin RS ESC sensored Jeff Cuffs Electric On-Road 23359 10-02-2016 06:57 AM
Tekin Redline RS Sensored ESC and motors, opinions for offroad? Cain Electric Off-Road 4230 06-07-2015 04:38 PM
Tekin Vegas 2.0 Setup and Support Randy_Pike Electric Off-Road 1713 12-06-2011 05:31 PM
Tekin Rs/Rs pro V200 offroad setups only JdogL Electric Off-Road 272 02-04-2010 11:54 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 01:48 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net