R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 01-25-2010, 11:48 AM   #1
Tech Initiate
 
Join Date: Jan 2010
Posts: 25
Default remove "rust" from RC parts

How long can/may/should I put parts with rust* on them in Coka Cola? Can I just leave them overnight, or better leave them just a couple of hours?

Or is it better to put them in WD40? I thought treating them with WD40 is after you removed the rust from them?

* yeah, it's not really rust, because the parts are aluminium and they obviously don't rust, but there is some kind of orangy rusty material on the parts ...
__________________
Sprint2 - Vorza - Savage - Blitz
selder2 is offline   Reply With Quote
Old 01-25-2010, 05:07 PM   #2
Tech Initiate
 
Join Date: Jan 2010
Posts: 25
Default

Anyone?
__________________
Sprint2 - Vorza - Savage - Blitz
selder2 is offline   Reply With Quote
Old 01-25-2010, 06:55 PM   #3
Tech Master
 
trerc's Avatar
R/C Tech Elite Subscriber
 
Join Date: Mar 2008
Location: Indiana
Posts: 1,821
Trader Rating: 89 (100%+)
Default

I would just clean them up with some Wenol or Maas meal polish.
__________________
If it smells burnt up.. it's more than likely hot.. you don't have to touch it..
trerc is offline   Reply With Quote
Old 01-27-2010, 05:19 PM   #4
Tech Initiate
 
Join Date: Jan 2010
Posts: 25
Default

Tried leaving them in Coca-cola for a night and a day, and it's better now, but there is still some "rust" to be seen... (digital camera is broken, and cellphone takes louzy pics)

Does anyone else have another idea, or should I just buy the parts new?
__________________
Sprint2 - Vorza - Savage - Blitz
selder2 is offline   Reply With Quote
Old 01-27-2010, 06:04 PM   #5
Tech Champion
 
Join Date: Nov 2001
Location: Hawaii, USA
Posts: 7,186
Default

Some sort of metal polish is your best bet...like Mothers or something like that. Likely if you are getting a reddish or orangish coating it is probably coming from a nearby steel part. If it is a dog bone or drive shaft of some sort it could be coming from the steel drive pin.
InspGadgt is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 10:57 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net