R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 09-29-2011, 02:49 PM   #76
Tech Apprentice
 
Pasky's Avatar
 
Join Date: Jan 2007
Location: Gold Coast
Posts: 94
Trader Rating: 4 (100%+)
Default

Hey there Boa,have you tried adding some weight to the old battery cavity to see if that sorts out some of those issues just put the same weight as your 2 lipo batteries there and see if that makes any difference,just add more if you need to .my 966e in standard setup weighs in at 2.5 kg..
i have a 960 also setup for high speed and it weighs in at 3.5 kg but is great for straight line speed and reasonable braking and good handling.
Pasky is offline   Reply With Quote
Old 10-19-2011, 09:20 PM   #77
Boa
Tech Apprentice
 
Join Date: Jan 2011
Posts: 79
Default

No, I haven't tried that but I'm sure going to.
Boa is offline   Reply With Quote
Old 11-18-2011, 02:58 PM   #78
Tech Regular
 
D.a.v.e's Avatar
 
Join Date: Aug 2010
Location: South East, Michigan
Posts: 466
Trader Rating: 8 (100%+)
Default

Quote:
Originally Posted by M7H View Post
With that heavy gearing, I think no motor/ESC/Lipo can deliver enough power on 4S for a decent amount of time.

I've converted my 950R to Electric on 6S lipo, and with 1st gear spurs, a cnc made holder, 22T motor pinion, and a slightly modified motor mount, you have room to fit a modified brake disk again.

Spur/pinion
Break disk
Break servo

Yes, my 2 times 3S lipo lie next to the car, this is not the best set-up, but it's a lot of fun driving it!
1st test run without mechanical brakes was to much for the motor, but here you have some youtube's to see for yourself!

http://www.youtube.com/watch?v=NNb2ZSMchm8
http://www.youtube.com/watch?v=f30iBuujrRY
http://www.youtube.com/watch?v=-VJlxDlMRJw

Topspeed reached was 111kmh, which is the same as 1/8 nitro can reach.
Laptimes where 1 sec less, than what I can drive with my 966, but with better body, and better tyres, I think I am able to get close enough!....
What kind of runtimes are you getting and how many mah are your packs?
D.a.v.e is offline   Reply With Quote
Old 11-20-2011, 01:02 PM   #79
M7H
Tech Elite
 
M7H's Avatar
 
Join Date: Dec 2004
Location: The Netherlands
Posts: 2,196
Default

Quote:
Originally Posted by D.a.v.e View Post
What kind of runtimes are you getting and how many mah are your packs?
I run 4500mAh packs, and am able to get around 6-7 minutes runtime.
I'm not exactly a beginner, so I drive the car pretty hard.....

At the moment I am not able to get to these runtimes, because on way or another, the car seems to go into lipo cut-off, or something like that, after about 2 minutes. Switching of and on again, I can run for another minute or so. What it is I don't know yest, but I am in contact with Hobbywing to try and solve the problem....
At the moment it is getting winter here, so I will start driving the car again, next year...
__________________
Serpent
M7H is offline   Reply With Quote
Old 11-20-2011, 07:05 PM   #80
Tech Elite
 
Pattojnr's Avatar
 
Join Date: Apr 2006
Location: Perth Australia
Posts: 4,594
Trader Rating: 19 (100%+)
Default

we just had our EP onroad National titles here in Perth Western Australia.
with a modified layout of the tray, i use 6000mah 60C packs. 2 2S packs. i know everyone else is using 5s or 6S , but for rules here we have a limit to use 4S. it is hard to get it to work, but we have done so in good hot conditions.
here is a video of the First Final. i went quicker in the 2nd , and let the National Mod driver drive the car in Final 3. he enjoyed it alot. and we created alot of interest here running the class as a demo class. M7H, i believe it is a heat issue causing your problems. i too was cutting out or stutter with in 3 mins of driving too hard, and what i did was cut the fuel tab out on the body, bend it up and flatten the top part, so it acted as a Air Dam. it guided air directly over the motor , the faster you go , the more air over the motor. i was then able to turn it up more and last the entire 5 mins. after the meet, i let 2 other people drive it, and it would have gone another min or more with the same packs used. on a big track, we have no issues of run time.
here is the Vid...

http://www.youtube.com/watch?v=QBov3EFFUlo
__________________
Serpent - Walter RC
Serpent E Power ..... Serpent 747 Reds M3T
Serpent 966-TE Reds M7T .... S411ERYX Speedpassion 3.5T, T-Shox
Serpent 811-TE REDs R5T
Pattojnr is offline   Reply With Quote
Old 11-21-2011, 02:02 AM   #81
M7H
Tech Elite
 
M7H's Avatar
 
Join Date: Dec 2004
Location: The Netherlands
Posts: 2,196
Default

Quote:
Originally Posted by Pattojnr View Post
M7H, i believe it is a heat issue causing your problems.
The ESC is not giving any blinking led's to tell me it's overheated...
Also the motor is around 50 Celcius, the ESC also....
If I drive the car on 5S Lipo, and use a rollout of 44mm maximum, all seems ok and I can drive until lipo cut-off, on 4S lipo it's the same, but there is not enough speed for our track.

But maybe i'm on the edge of what the ESC can deliver, or 1 FET is not capable of delivering the power. I have some ESC returning to me from HW, and will try them when they arrive, and weather permitting ofcourse.
__________________
Serpent
M7H is offline   Reply With Quote
Old 11-22-2011, 03:47 PM   #82
Tech Elite
 
Pattojnr's Avatar
 
Join Date: Apr 2006
Location: Perth Australia
Posts: 4,594
Trader Rating: 19 (100%+)
Default

Quote:
Originally Posted by M7H View Post
The ESC is not giving any blinking led's to tell me it's overheated...
Also the motor is around 50 Celcius, the ESC also....
If I drive the car on 5S Lipo, and use a rollout of 44mm maximum, all seems ok and I can drive until lipo cut-off, on 4S lipo it's the same, but there is not enough speed for our track.

But maybe i'm on the edge of what the ESC can deliver, or 1 FET is not capable of delivering the power. I have some ESC returning to me from HW, and will try them when they arrive, and weather permitting ofcourse.
our Ambient temp is hotter here, when i ran with no cooling holes motor was temping at 70C, with cooling holes, the same temp. but i never had any stutter with the cooling holes on the car. so even though motor temps were fine before, but remained consistant, the cooling holes must cool the motor down to not reach any heat protection. this is just what i found, i was able to turn things up, and stay at the same heat, with cooling holes directly above the motor. so that lead me to believe its a motor heat issue.
__________________
Serpent - Walter RC
Serpent E Power ..... Serpent 747 Reds M3T
Serpent 966-TE Reds M7T .... S411ERYX Speedpassion 3.5T, T-Shox
Serpent 811-TE REDs R5T
Pattojnr is offline   Reply With Quote
Old 10-21-2012, 01:42 PM   #83
Tech Apprentice
 
Join Date: Aug 2010
Location: Northease USA
Posts: 83
Trader Rating: 15 (100%+)
Default Anyone got 1 for sale?

Is anyone looking to sell their 966E?
slowhand55 is offline   Reply With Quote
Old 12-17-2012, 06:38 AM   #84
Tech Adept
 
Join Date: Feb 2009
Location: Panama
Posts: 110
Trader Rating: 2 (100%+)
Default Tires for bashing

I know this is a race car. But some people use it in parking lots and just for fun.
Are there any other tires, beside foams, that can be used?
AlvaSpeed is offline   Reply With Quote
Old 03-09-2013, 02:50 AM   #85
Tech Addict
 
Join Date: May 2010
Posts: 518
Trader Rating: 6 (100%+)
Default

http://www.edamhobby.com/shopping_li...rea=73&cat=241

My 950r electric conversion is ready to go, just need a pinion adapter.
Brokenparts is offline   Reply With Quote
Old 05-06-2013, 04:57 AM   #86
Tech Adept
 
oldnfat's Avatar
 
Join Date: Nov 2010
Location: Michigan
Posts: 167
Trader Rating: 8 (100%+)
Default Help and/or opinionís - thinking about selling my 966e...

Never mind....

Last edited by oldnfat; 10-13-2013 at 01:00 PM. Reason: never mind
oldnfat is offline   Reply With Quote
Old 06-16-2013, 11:49 PM   #87
Tech Rookie
 
Join Date: Jun 2013
Posts: 1
Default 966E

Quote:
Originally Posted by oldnfat View Post
Hi guys, I have a 966e that I built and I am now considering selling it, just wondering what I should target price wise.
Driven once, like new, just a shelf queen.
futuba bls551 servo correction I have a Hitec 625mg in there and not the futuba...sorry....
tekin rx8 esc
tekin t8 2650
nano-tech 5100 mah 60-130c saddle packs (4s config.)
orange surface 3 channel receiver (works with spektrum)
2 full set of tires, cannot remember the brands, but one white and one black set. I will post more later with all the info, shore ratings and brands.
Custom painted body from Larry at kustomRCgraphics

I can post more pics tonight, just wondering what I should ask for this thing as a bind and drive (for spektrum).
I wonder if it would be wise to sell it as a roller and part out the electronics or go for all of it at once.?.?.?.?...
I donít see to many of these for sale and after I add up everything I spent on it, I see why now. I do understand that rc greatly decreases in value, but I am just wondering what I should ask for this. I am thinking that this one may have to go on the bay to get some more views and interest.
Thanks in advance for any and all help
Coop
Can u load more pictures of your car?
966E is offline   Reply With Quote
Old 10-11-2013, 12:35 PM   #88
Tech Adept
 
oldnfat's Avatar
 
Join Date: Nov 2010
Location: Michigan
Posts: 167
Trader Rating: 8 (100%+)
Default

Never mind.

Last edited by oldnfat; 10-13-2013 at 01:01 PM. Reason: never mind
oldnfat is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sydney Model Autosports Inc [smaracing.org] The Ideas Man Australian Racing 25433 12-14-2017 05:42 PM
Serpent 966 madbeats Nitro On-Road 2237 10-29-2014 09:08 AM
Team Kamikaze Rc Racing Team Kamikaze Racing Forum 17924 08-31-2012 04:25 PM
Brushless Serpent 966 f1bmw Nitro On-Road 51 03-06-2010 09:43 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 02:54 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net