R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 11-27-2009, 06:11 AM   #1
Tech Apprentice
 
Tor Erik's Avatar
R/C Tech Charter Subscriber
 
Join Date: Mar 2004
Location: Norway
Posts: 92
Default How to charge Lipo packs ??

I have tried to search the forum for info about how to charge Lipo´s but can find any about it.

I wonder how do you recommend charging Lipo ?

I race mod touring.

I have been told that you should not discharge the pack with the charger and only charge them when they had been cooled down. I have also been told that balancing them around every 3 charge.

Any other advice ?

Thx
Tor Erik is offline   Reply With Quote
Old 11-27-2009, 06:16 AM   #2
Tech Fanatic
 
Airwave's Avatar
 
Join Date: Jul 2007
Posts: 792
Trader Rating: 1 (100%+)
Default

Depending on your charger... and on the pack itself!

I use Orion SLPB 3800 for 2 seasons and it's specified on them that it should be charged between 1C and 2C...

So I charge them @5A with automatic balance.
Airwave is online now   Reply With Quote
Old 11-27-2009, 06:53 AM   #3
Tech Apprentice
 
Tor Erik's Avatar
R/C Tech Charter Subscriber
 
Join Date: Mar 2004
Location: Norway
Posts: 92
Default

oh, sorry, did not say the battery and charger I use.

Uses IP 5000 mAh 40 C

http://www.rc-mushroom.com/product_i...ducts_id=17463

and this charger :

http://www.rc-mushroom.com/product_i...ducts_id=18027

I do charge my batteries at 1 C
Tor Erik is offline   Reply With Quote
Old 11-27-2009, 07:03 AM   #4
Tech Elite
 
portyansky's Avatar
 
Join Date: Mar 2007
Posts: 2,983
Trader Rating: 54 (100%+)
Default

set it to 2s (7.4v) and charge at 5amps. Once its peaked its done. Not like nimh where you can hit the peak button again. Lipos don't lose their charge. Don't let the voltage drop below 6v (3v/cell). I balance my packs when ever I charge them b/c I have a built in balancer so I might as well balance them.

As far as discharging packs. If your charger has a "storage mode" then you can use that, but if you always use them its not necessary. Its mainly if you wont use them over the winter, I believe they say to store them at 60% capacity.
__________________
Team Tekno Canadian Team Manager
Team Hitec
portyansky is offline   Reply With Quote
Old 11-27-2009, 08:41 AM   #5
Tech Elite
 
Toh WL's Avatar
 
Join Date: May 2006
Location: Setapak
Posts: 3,567
Trader Rating: 6 (100%+)
Default

practically one of my LiPo ballooned although the ESC cuts off at 6V. My advice if you notice lack of punch do stop the car & pick it up.

Since 2 cells are in use, anyone of the weaker cells will eventually cause this problem when you cut of at 6V.
Toh WL is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 04:17 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net