Novak GTB help!

Old 11-22-2009, 08:24 AM
  #1  
Tech Initiate
Thread Starter
iTrader: (5)
 
Join Date: May 2009
Location: Buford, Ga
Posts: 48
Trader Rating: 5 (100%+)
Default Novak GTB help!

I have a GTB esc and was runnig it yesterday and had a 10.5T Fantom motor lock up. Not sure why it locked up... could of been a bit of over gearing and some extra mud on the chassis that weigh my SC10 down. Anyway, the GTB is working but smoke came from the power capacitor when I tried to give it throttle when the 10.5T locked down. I installed a new LRP 13.5T on the SC10 this morning and the GTB is working. Should I replace the power capacitor on the GTB since it released the magic blue smoke???? The GTB appears to be working properly now... should I send it back to Novak to see if there is anything internally wrong???

Thanks for the help!!
Ultramarv is offline  
Old 11-22-2009, 09:08 AM
  #2  
Company Representative
 
Join Date: Jun 2005
Location: SoCal
Posts: 2,891
Default

Originally Posted by Ultramarv View Post
I have a GTB esc and was runnig it yesterday and had a 10.5T Fantom motor lock up. Not sure why it locked up... could of been a bit of over gearing and some extra mud on the chassis that weigh my SC10 down. Anyway, the GTB is working but smoke came from the power capacitor when I tried to give it throttle when the 10.5T locked down. I installed a new LRP 13.5T on the SC10 this morning and the GTB is working. Should I replace the power capacitor on the GTB since it released the magic blue smoke???? The GTB appears to be working properly now... should I send it back to Novak to see if there is anything internally wrong???

Thanks for the help!!
The GTBs should not be operated without the TransCap module installed; so, definitely replace the cap as soon as you can.

You can always email [email protected] with your questions, during regular CS hours. Before emailing, take a moment to review the instructions (trouble-shooting guide) originally included with your Novak Item:

Novak Instruction Downloads

Please make your initial email as detailed as possible. Include:

~ warranty claim?
~ speed control (brand/model)
~ motor (brand/wind)
~ rotor (old/new)
~ connectors used
~ servo (brand/model)
~ radio system (receiver/transmitter)
~ vehicle & gearing
~ battery, brand (c rating/capacity)
~ any external modules (BEC/brand, Glitch Buster)
~ other important info: water damage, corrosive chemical sprays, excess heat, etc
The more information you provide in your first email, the more quickly tech support can offer you assistance.
NovakTwo is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.