Xray T1

Reply

Old 11-21-2004, 12:38 AM
  #10276  
Tech Master
iTrader: (16)
 
OHBRAD's Avatar
 
Join Date: Jun 2003
Location: Brisbane Australia
Posts: 1,165
Trader Rating: 16 (100%+)
Default WEIGHTS

HI guys,

the weights you can buy for the xray ft. does anyone know what they weigh.

regards brad
OHBRAD is offline  
Reply With Quote
Old 11-21-2004, 06:55 AM
  #10277  
Tech Master
iTrader: (15)
 
Scrad's Avatar
 
Join Date: Feb 2003
Location: Plover, WI
Posts: 1,510
Trader Rating: 15 (100%+)
Default

Guy's I drove my TC4 yesterday and I all have to say is that it actually worked better than my Xray ever did on foams. So it actually is a good car, just the build quality sucks.

I'll always run my Xray in rubber though.
Scrad is offline  
Reply With Quote
Old 11-21-2004, 07:51 AM
  #10278  
Tech Elite
iTrader: (8)
 
ChrisP's Avatar
 
Join Date: Sep 2003
Location: Shelby Twp, MI
Posts: 2,047
Trader Rating: 8 (100%+)
Default

Originally posted by kidDynomite
Duckman, thanks for the info. I think I'm going to order a set tonight. Found them for only fifty bucks.

http://www.rcmart.com/catalog/produc...oducts_id=4259

I go up to TO all the time. Let me know what RC tracks you go too, nitro or electic. I'd love to check them out. Got the R1 up to 198 (not klicks) on the 401 around London. From Detroit, only 1hr 12min flat.
To get to Toronto you're passing nice tracks in Kingsville at Action Hobbies Kingsville and in London at RCXpress.....(I'll get an updated site adress for them)...

RCXpress is run by the same guys that run the Sammy's Speedway off-road facility in London.

If you're passing through it's defiitely worth checking both of these places out
ChrisP is offline  
Reply With Quote
Old 11-21-2004, 07:54 AM
  #10279  
Tech Lord
iTrader: (37)
 
Oasis's Avatar
 
Join Date: Dec 2002
Location: * Sin Cal *
Posts: 10,395
Trader Rating: 37 (100%+)
Default

I like my Xray in 19 turn but I cant seem to get it up to speed in stock.. I win and TQ with my "other" car in stock,so I know it's not my motors or batterys,I'm using the low ratio pullys and the short arms,I also use the 3mm belts.The drive train seems free,It's driving me crazy,It should be alot faster than it is.The track is med./small parking lot track,med. to hi bite,Any Ideas ????
Oasis is offline  
Reply With Quote
Old 11-21-2004, 08:18 AM
  #10280  
Tech Fanatic
 
S-T-R-l-K-E-R's Avatar
 
Join Date: Jan 2003
Location: CS RACING / RIDDLER HOBBIES
Posts: 973
Default

i am having little problem with hairpins on days with low traction.
when i prep for a hairpin turn as i reach the apex when off throttle my car suddenly spins out. this happens usually on the first few laps when tires are cold. so what happens is i always play catch up. i tired adding more droop (lower numerically on a droop guage). when on throttle the car is on rails. one more thing is that on chicanes and sweepers its really on rails.

any ideas or explanations?

i'm thinking of adding shims under the rear camberlink.
S-T-R-l-K-E-R is offline  
Reply With Quote
Old 11-21-2004, 09:43 AM
  #10281  
Tech Fanatic
iTrader: (8)
 
Michal101's Avatar
 
Join Date: Mar 2002
Location: Norfolk, VA
Posts: 985
Trader Rating: 8 (100%+)
Default

Originally posted by xxxkat
I like my Xray in 19 turn but I cant seem to get it up to speed in stock.. I win and TQ with my "other" car in stock,so I know it's not my motors or batterys,I'm using the low ratio pulleys and the short arms,I also use the 3mm belts.The drive train seems free,It's driving me crazy,It should be alot faster than it is.The track is med./small parking lot track,med. to hi bite,Any Ideas ????
xxxkat,

I had a similar problem with my Xray that it actually felt somewhat slow in stock, but I did very well in mod and what I found is that the Xray inherently has tons of traction (particularly rear traction) and in the stock classes you have to take some of that traction away to especially carry more cornering speeds.

The funny thing is that I spoke with Ralph Burch about this problem at last year's Snowbirds and confirmed this.

I hope this helps.

Mike
Michal101 is offline  
Reply With Quote
Old 11-21-2004, 09:52 AM
  #10282  
Tech Master
 
FW-05RR's Avatar
 
Join Date: May 2004
Location: SoCal
Posts: 1,384
Default

Originally posted by pink pac man
i prefur the xray shocks ......cos they look more sturdy than the tamiyas altho the tamiya shocks are smother

i stilll prefur xrays
I couldn't agree more

by the way nice avatar
FW-05RR is offline  
Reply With Quote
Old 11-21-2004, 09:53 AM
  #10283  
Tech Master
iTrader: (1)
 
dado11g's Avatar
 
Join Date: Aug 2004
Location: Farmington Hills, MI and proud of it
Posts: 1,059
Trader Rating: 1 (100%+)
Default

xxxcat,

i can relate to this in my gokart racing. with a shifter engine you need all of the rear traction you can get(without binding).
but if you put on a 100cc non-shifter engine with about 1/3 of the power with the same chassis setup you will be binding very bad. you want the car to be as free as possible while still having good grip. it is the fastest right on the edge of spinning out.
dado11g is offline  
Reply With Quote
Old 11-21-2004, 02:42 PM
  #10284  
Tech Master
iTrader: (21)
 
dontfeelcold's Avatar
 
Join Date: Aug 2003
Location: Where there's smoke there's a tyre
Posts: 1,725
Trader Rating: 21 (100%+)
Default

Originally posted by S-T-R-l-K-E-R
i am having little problem with hairpins on days with low traction.
when i prep for a hairpin turn as i reach the apex when off throttle my car suddenly spins out. this happens usually on the first few laps when tires are cold. so what happens is i always play catch up. i tired adding more droop (lower numerically on a droop guage). when on throttle the car is on rails. one more thing is that on chicanes and sweepers its really on rails.

any ideas or explanations?

i'm thinking of adding shims under the rear camberlink.
use tyre warmers.
dontfeelcold is offline  
Reply With Quote
Old 11-21-2004, 02:52 PM
  #10285  
Tech Elite
iTrader: (3)
 
JDXray's Avatar
 
Join Date: Mar 2004
Location: Long Island, New York
Posts: 2,802
Trader Rating: 3 (100%+)
Default traction roll

I was on and off today with traction roll on 1 turn i really had to slow down so i didnt flip..

I was thinking maybe it was the camber? Someone help me out thanks

Jon
JDXray is offline  
Reply With Quote
Old 11-21-2004, 03:20 PM
  #10286  
Tech Master
 
raving-monkey's Avatar
 
Join Date: Apr 2004
Location: yorkshire, england.
Posts: 1,818
Default

was it a fast corner?

ages ago (with my first xray) i kept rolling on the sweeper coming off the straight...turned out to be i had to much droop..so i took a bit off and it was finealso if your getting to much side bite (well i know this was a case when i used to do buggies) the car would roll..never had this problem in TC though
raving-monkey is offline  
Reply With Quote
Old 11-21-2004, 03:23 PM
  #10287  
Tech Elite
iTrader: (3)
 
JDXray's Avatar
 
Join Date: Mar 2004
Location: Long Island, New York
Posts: 2,802
Trader Rating: 3 (100%+)
Default

Originally posted by raving-monkey
was it a fast corner?

ages ago (with my first xray) i kept rolling on the sweeper coming off the straight...turned out to be i had to much droop..so i took a bit off and it was finealso if your getting to much side bite (well i know this was a case when i used to do buggies) the car would roll..never had this problem in TC though
yes a very fast corner.

I am already at .5 front and 1 droop lol i dunno how much lower i can go. I might be getting too make side bit but how would that be? The front side isnt really the problem i think its the side rear.
JDXray is offline  
Reply With Quote
Old 11-21-2004, 03:25 PM
  #10288  
Tech Adept
 
kaizen's Avatar
 
Join Date: Nov 2002
Location: SF Bay Area
Posts: 120
Default

Originally posted by xxxkat
I like my Xray in 19 turn but I cant seem to get it up to speed in stock.. I win and TQ with my "other" car in stock,so I know it's not my motors or batterys,I'm using the low ratio pullys and the short arms,I also use the 3mm belts.The drive train seems free,It's driving me crazy,It should be alot faster than it is.The track is med./small parking lot track,med. to hi bite,Any Ideas ????
Hey Kat! Do, I know you?

Anyway, when I ran my XRay in stock I went to about 1 or 1 1/2 degree rear toe. This was really sweet at Stockton and Gilroy. You might give this a try if you haven't already.

Cheers,
Stu
kaizen is offline  
Reply With Quote
Old 11-21-2004, 03:28 PM
  #10289  
Tech Elite
iTrader: (3)
 
JDXray's Avatar
 
Join Date: Mar 2004
Location: Long Island, New York
Posts: 2,802
Trader Rating: 3 (100%+)
Default

Originally posted by xxxkat
I like my Xray in 19 turn but I cant seem to get it up to speed in stock.. I win and TQ with my "other" car in stock,so I know it's not my motors or batterys,I'm using the low ratio pullys and the short arms,I also use the 3mm belts.The drive train seems free,It's driving me crazy,It should be alot faster than it is.The track is med./small parking lot track,med. to hi bite,Any Ideas ????
I am using the thick belts in the rear but i think i am gonna change to a thinner one, it seemss the have a drag when you hit the gas..

I run 2 degree toe in on rear. If you need a setup let me know.

Jon
JDXray is offline  
Reply With Quote
Old 11-21-2004, 03:34 PM
  #10290  
Tech Elite
iTrader: (28)
 
Join Date: Nov 2001
Location: SF Bay Area
Posts: 3,519
Trader Rating: 28 (100%+)
Default

Hummmm.

My car is equally fast in 19turn as its is in stock.Ask those who have been victims of my FK recently on carpet ans asphalt.

Where the heck have you been Stu? I finally got my Fk going and its abosolutely insanely dialed and you don't show up to Gilroy anymore?Kevin and I have been battling it out on Friday recently.Hope to see you soon.
racenut123 is offline  
Reply With Quote

Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Terms of Service