R/C Tech Forums

R/C Tech Forums (https://www.rctech.net/forum/)
-   Electric On-Road (https://www.rctech.net/forum/electric-road-2/)
-   -   XERUN V2.0 Brushless ESC discussion thread. (https://www.rctech.net/forum/electric-road/313094-xerun-v2-0-brushless-esc-discussion-thread.html)

cyanyde 07-19-2009 04:27 AM

XERUN V2.0 Brushless ESC discussion thread.
 
I've been running this esc in my Xray 009 with SP 11.5T (Stock motor for this part of the world) and I have to admit that it can keep up with whatever esc thats out there. All it needs is a little more speed.

And also, the optional LCD program box is great for fine tuning and software updates. This makes the XERUN a great option for racers on a budget.

However, there's no discussion or tests done on this esc for the available software versions. Lets share what we know....

The available softwares, with the top being the latest are:

V1.10_090323a_m
V1.10_090323a_T
V1.10_090312a_T
V1.10_090205g_T
V1.10_090205c_T
V1.10_090205b_T
V1.10_090205a_T
V1.10_090115a_T
V1.10_090105a_U
V1.10_081025a_U
V1.10_080926a_U

dameetz 07-19-2009 07:44 AM

I think this esc is very similar to SP GT ver2/ Much More Fleta ver3...

cyanyde 07-19-2009 10:26 AM

Yep, they are very similar and in fact I helped tweak my mates SP esc with my programmer card. But I don't think the internal hardware are the same coz both feels a little different. Not necessarily faster though.

Just loaded my esc with the latest software. Haven't tested it yet. Will see how it feels this tuesday.

dameetz 07-19-2009 10:57 AM


Originally Posted by cyanyde (Post 6086411)
Yep, they are very similar and in fact I helped tweak my mates SP esc with my programmer card. But I don't think the internal hardware are the same coz both feels a little different. Not necessarily faster though.

Just loaded my esc with the latest software. Haven't tested it yet. Will see how it feels this tuesday.

Which sofware? the 323a-m? Let me know the difference.

cyanyde 07-21-2009 12:46 PM

yup the 323a-m. but couldn't run yet today. track is closed for night practice this week. bummer....

liljohn1064 07-21-2009 01:55 PM

I'd like to try one of the 2.0 60A versions. I'm guessing they perform very similar to the other 2 previously mentioned. I really like my SP 1.1 and think this would better and for the price point, a real easy decision.

blanchjd 07-21-2009 02:05 PM

I just picked up the 120A v2.0 Blue version for $101 shipped. I think I got a good deal. Haven't even installed it yet into my TC5. Does anyone know what differences there are in the software versions?

drsmooth 07-21-2009 03:05 PM

I just got the black 120 V2.0 that I run with a Novak 13.5 motor. I liked it so much, I bought a 25 amp V2.0 for my 1/16th scale. Though I have nothing to compare the 120 amp esc to (first sensored 10th scale system I've had in several years), it runs very well.
The 25 amp replaced a Castle Sidewinder 25. I honestly thing the Ezrun is smoother than the CC.
As for the differences in the V1.1 & V2.0, the V2.0s can be updated on the internet with the 2-in-1 program box. Not sure if the V1.1s can be updated in this manner.

dameetz 07-21-2009 07:50 PM


Originally Posted by blanchjd (Post 6096690)
I just picked up the 120A v2.0 Blue version for $101 shipped. I think I got a good deal. Haven't even installed it yet into my TC5. Does anyone know what differences there are in the software versions?

Where did you get yours from? Thats a very good deal. Can you provide a link?

blanchjd 07-22-2009 01:14 AM


Originally Posted by dameetz (Post 6098132)
Where did you get yours from? Thats a very good deal. Can you provide a link?

I bid for it on ebay:
http://cgi.ebay.com/ws/eBayISAPI.dll...m=350223763175

cyanyde 07-22-2009 05:00 AM

There's a blue version!?... Darn!

As for the software versions, I still haven't had the chance to try them out. But so far all I noticed was the reverse function option is not available on a couple of them.

koval 07-30-2009 03:06 PM

i have a v2 120A XERUN combo with the 3.5t motor in my schumacher!the problem is that when i conect the esc with the program card somes times the screen lights and some other not!i cant understand why that hapens.the contact wires is ok .do anyone else have a broblem like this?

tech5 07-30-2009 03:57 PM

are these sensored?

drsmooth 07-30-2009 04:23 PM

The only problem I have with mine is when I go to plug the deans ultra plugs together, a spark will jump between the two plugs as they touch. Anyone else seen this??

razzor 07-31-2009 12:01 AM

that is not a problem just the cap charging/discharging .
you will have that with most any esc.


All times are GMT -7. It is currently 01:04 PM.

Powered By: vBulletin v3.9.3.8
Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.