R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 05-16-2009, 05:29 AM   #1
Tech Rookie
 
Join Date: Apr 2009
Posts: 5
Default Issues...

Having a few issues with my new RC Car, its a HPI Hot Bodies Cyclone Drift.

Everytime I try to accelerate with the car, the motor will turn as if its going to carry on, go for around 1 second then stop, and the lights on the ESC start flashing....I think it could possibly be a battery issue, but thought Id ask you guys too?

Thanks
Mousey is offline   Reply With Quote
Old 05-16-2009, 08:27 AM   #2
Tech Adept
 
Join Date: Feb 2009
Location: Scott City, MO
Posts: 105
Default

What type of motor and ESC are you using? That info might help us trouble shoot your problem.
Fllyer is offline   Reply With Quote
Old 05-16-2009, 08:35 AM   #3
Tech Regular
 
freeway's Avatar
 
Join Date: Feb 2009
Posts: 326
Trader Rating: 1 (100%+)
Default

that would be an rtr, if i remember right you could try to rebind the TX and RX ?
freeway is offline   Reply With Quote
Old 05-16-2009, 09:36 AM   #4
Tech Elite
 
sosidge's Avatar
 
Join Date: Dec 2001
Location: Bristol, UK
Posts: 3,865
Default

Not meaning to be rude - but is the battery charged? And if you did charge it, what charger did you use, and was the battery warm when it finished?

Sounds like insufficient battery power. May possibly be a problem with the radio signal, or may possibly be a faulty ESC, but probably a flat/bad battery.
sosidge is offline   Reply With Quote
Old 05-16-2009, 11:21 AM   #5
Tech Rookie
 
Join Date: Apr 2009
Posts: 5
Default

Thanks for the advice guys/gals, it turns out it was a craply charged battery, charged another one, and it works just fine.

Thanks
Mousey is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
OCM KAOS DOMINATING zixxer Nitro Off-Road 2252 11-08-2017 03:14 AM
1/10th pan car Taz_S Oval, Larger Scales and More 16138 09-25-2014 10:03 AM
Team Associated 1/8 scale Buggy Info and Tips Kevin Boyle Nitro Off-Road 11189 03-12-2013 06:52 PM
New Caster Racing Nitro Buggy Just Announced! hakmazter Nitro Off-Road 534 07-31-2010 07:20 PM
NEW CLUB OPENNED IN SOUTH AUSTRALIA - NORTH EAST MODEL CAR CLUB VintageFrog1 Australian Racing 2226 08-17-2009 05:47 PM
2004 Reedy Sedan ROC mo Racing Forum 830 05-29-2004 08:52 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 01:50 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net