Go Back  R/C Tech Forums > General Forums > Electric On-Road
Ko Propo 2.4ghz system >

Ko Propo 2.4ghz system

Ko Propo 2.4ghz system

Reply

Old 06-05-2009, 08:08 PM
  #16  
Tech Adept
iTrader: (7)
 
Join Date: Jul 2006
Location: Toronto
Posts: 195
Trader Rating: 7 (100%+)
Default

Originally Posted by jag88 View Post
If you get an updated system then you'd be ok, I think. They had trouble with Futaba 4PKs swamping them out in the begining. They chose not to make it public so you had to find out the hard way but they were very quick to say that they would fix it for free if you sent it in. I think it was lame the way they handled the problem but they problably didn't want to come out and say that Futaba ate their lunch. I think the problem is fixed now.
I think the way Robert at KO handled it was amazing.
KO was very upfront and quick to admit there was an issue. Then all you had to do was send in the module and Robert (basically within a day) sent you back a completely new one, no questions asked.
Compare that to the way Futaba has handled their 2.4 thermal shutdown issue. They STILL don't admit there's a problem.

As for the KO system, mine's been flawless, fast, smooth.
jon123 is offline  
Reply With Quote
Old 06-05-2009, 10:28 PM
  #17  
Tech Master
iTrader: (9)
 
fly_wheel's Avatar
 
Join Date: Oct 2007
Location: sabah lor
Posts: 1,039
Trader Rating: 9 (100%+)
Default

how would i know if mine is an updated version..? any physical signs..?
fly_wheel is offline  
Reply With Quote
Old 06-06-2009, 08:05 AM
  #18  
Tech Master
iTrader: (1)
 
jag88's Avatar
 
Join Date: Nov 2003
Posts: 1,075
Trader Rating: 1 (100%+)
Default

Originally Posted by jon123 View Post
I think the way Robert at KO handled it was amazing.
KO was very upfront and quick to admit there was an issue. Then all you had to do was send in the module and Robert (basically within a day) sent you back a completely new one, no questions asked.
Compare that to the way Futaba has handled their 2.4 thermal shutdown issue. They STILL don't admit there's a problem.

As for the KO system, mine's been flawless, fast, smooth.

Sorry, I can't agree with you on how they handled the 'issue'.
There was nothing on their web site or on this forum about it.
Yes they were quick to say they would fix it for free but NEVER quick to admit that there was a problem.
I found out the hard way, at a race, when my radio wouldn't work as I stepped onto the drivers stand for my main. Actually it was one of their sponsored drivers that told me that there was a problem.
jag88 is offline  
Reply With Quote
Old 06-12-2009, 11:13 AM
  #19  
Tech Initiate
 
jdev's Avatar
 
Join Date: Jun 2009
Posts: 42
Default

Well I got my transmitter module and receiver back. Everything works great now. Syncs instantly and completely flawless. Total turn around time from leaving my place to getting it back was 4 days. Unbelievable!
jdev is offline  
Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service