R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 02-28-2009, 10:09 PM   #61
Tech Elite
 
meon99's Avatar
 
Join Date: Aug 2007
Posts: 2,133
Trader Rating: 76 (100%+)
Default

Quote:
Originally Posted by Randy_Pike View Post
We will honor your warranty with a vaild receipt.

I'm happy to hear that everyone is happy with the Tekin RS. We're continually building upon it.

Next up the RX8!
HI Randy, I just purchased a R1 pro with 358 combo, after I finished setting up the system, I saw smoke coming out from the esc, then I immediately turned it off, now I am afraid to turn it on again, I am wondering where should I send it back to Tekin for warranty, I just purchased it a week ago and I still have the receipt here for the combo, I am new to Tekin equipment. Thanks in advance.
meon99 is offline   Reply With Quote
Old 03-01-2009, 11:50 AM   #62
Tech Fanatic
 
Join Date: Sep 2007
Location: at the track
Posts: 839
Trader Rating: 21 (100%+)
Default

Quote:
Originally Posted by meon99 View Post
HI Randy, I just purchased a R1 pro with 358 combo, after I finished setting up the system, I saw smoke coming out from the esc, then I immediately turned it off, now I am afraid to turn it on again, I am wondering where should I send it back to Tekin for warranty, I just purchased it a week ago and I still have the receipt here for the combo, I am new to Tekin equipment. Thanks in advance.
Thats suck dude....
I hope Tekin will back you up since it is a new purchase..
And I am sure they will as this is their flagship model and GOOD LUCK..
Thanks for sharing as I am on my way to get one too.....
xxx123 is offline   Reply With Quote
Old 03-01-2009, 04:22 PM   #63
Team Tekin
 
Randy_Pike's Avatar
 
Join Date: Nov 2007
Location: Norcal
Posts: 9,702
Trader Rating: 6 (100%+)
Send a message via Yahoo to Randy_Pike
Default

From the sounds of it something isn't wired correctly. We don't just smoke when switch on. If the polarity of the battery wires is wrong there's no reverse polarity protection. Also make sure the cap was installed correctly as it too is polarized.
__________________
"Things may come to those who wait, but only the things left by those who hustle." Abraham Lincoln

Tekin,Protek,A-Main Hobbies,JConcepts,Avid RC,Yokomo,MIP,SikLidz,FactoryRC, www.randypikerc.com
Randy_Pike is offline   Reply With Quote
Old 03-03-2009, 02:51 PM   #64
Tech Regular
 
Kajman's Avatar
 
Join Date: May 2008
Posts: 335
Trader Rating: 4 (100%+)
Default

Quote:
Originally Posted by Randy_Pike View Post
From the sounds of it something isn't wired correctly. We don't just smoke when switch on. If the polarity of the battery wires is wrong there's no reverse polarity protection. Also make sure the cap was installed correctly as it too is polarized.

I had similiar problem, esc smoked after 2 mins of normal driving, dealer luckily took it from me, but said it happens I wrote several mails to tekin, no answet, dissapointed with it, still use only their 278 motors which are nice. But I don't know where good customer care went... Dealers in Europe are not happy with it too.
__________________
XXX-S G+, XXX-S, TRF 415MS, SCTE 2.0, SCTE TLD, Kyosho DRX VE
Kajman is offline   Reply With Quote
Old 03-03-2009, 03:15 PM   #65
Tech Elite
 
meon99's Avatar
 
Join Date: Aug 2007
Posts: 2,133
Trader Rating: 76 (100%+)
Default

Quote:
Originally Posted by Randy_Pike View Post
From the sounds of it something isn't wired correctly. We don't just smoke when switch on. If the polarity of the battery wires is wrong there's no reverse polarity protection. Also make sure the cap was installed correctly as it too is polarized.
Quote:
Originally Posted by Kajman View Post
I had similiar problem, esc smoked after 2 mins of normal driving, dealer luckily took it from me, but said it happens I wrote several mails to tekin, no answet, dissapointed with it, still use only their 278 motors which are nice. But I don't know where good customer care went... Dealers in Europe are not happy with it too.

It is exactly what I had, it ran for 5 mins for just a test, then it stopped working. I talked to Ty at Tekin and he said he is going to take a look at it. I just shipped it out today and will let everyone know what's wrong with it....
by the way, I emailed Ty at Tekin couple times, Tekin has the best customer service in USA.
meon99 is offline   Reply With Quote
Old 03-03-2009, 03:45 PM   #66
okayplayer
Guest
 
Posts: n/a
Default

tekin rs / rs pro + hotwire + tekin motor is really the way to go.

these guys @ tekin really know what quality means. a pure blast.

CÚdric
  Reply With Quote
Old 03-03-2009, 05:16 PM   #67
Tech Addict
 
stonedgti's Avatar
 
Join Date: Jun 2003
Location: U.S.A.
Posts: 699
Trader Rating: 15 (100%+)
Default

Yes, Tekin has their stuff together. I just had a nice conversation with Jim (president), and got a lot of very good information on setting up a RS and other stuff. Jim is a great guy, who is willing to put up quality products ONLY. Very stand-up guy and company. I just ordered a couple motors and ESCs. They deserve my support.
__________________
Team Powers | ORCA | OD 12 Racing | NorCal Hobbies | JWerks | Sonic Racing | Team Gayzer | AYO Racing | Team Hastings | Uncle Larry Concepts | Moonlight Toys
stonedgti is offline   Reply With Quote
Old 03-06-2009, 05:35 PM   #68
Tech Elite
 
meon99's Avatar
 
Join Date: Aug 2007
Posts: 2,133
Trader Rating: 76 (100%+)
Default

Quote:
Originally Posted by Randy_Pike View Post
From the sounds of it something isn't wired correctly. We don't just smoke when switch on. If the polarity of the battery wires is wrong there's no reverse polarity protection. Also make sure the cap was installed correctly as it too is polarized.
I believe it is not the wiring issue, because it worked for 5 mins, after that it stopped working.......

anyway, I have sent it back to Tekin, and hopefully they know what is wrong with it.
meon99 is offline   Reply With Quote
Old 03-09-2009, 05:25 PM   #69
Tech Elite
 
meon99's Avatar
 
Join Date: Aug 2007
Posts: 2,133
Trader Rating: 76 (100%+)
Default

pm to Randy.
meon99 is offline   Reply With Quote
Old 03-13-2009, 11:36 PM   #70
Tech Elite
 
meon99's Avatar
 
Join Date: Aug 2007
Posts: 2,133
Trader Rating: 76 (100%+)
Default

Quote:
Originally Posted by meon99 View Post
I believe it is not the wiring issue, because it worked for 5 mins, after that it stopped working.......

anyway, I have sent it back to Tekin, and hopefully they know what is wrong with it.
Quote:
Originally Posted by Randy_Pike View Post
From the sounds of it something isn't wired correctly. We don't just smoke when switch on. If the polarity of the battery wires is wrong there's no reverse polarity protection. Also make sure the cap was installed correctly as it too is polarized.
Just got the ESC and Motor back from Tekin, all I can say is "Tekin has the best customer service" GOOD JOB TEKIN.

Special thanks to TY and RANDY.
meon99 is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
the Chopping Block-Crawler Wheels. ESC/Motor Combos-Baja stuff Timmahh R/C Items: For Sale/Trade 9 05-24-2009 12:33 AM
Tekin Mini Rage (Problem's) need help Nostrixoxide Micro and Mini Scales 16 01-11-2009 08:57 PM
Brushless Masters please step inside Nostrixoxide Micro and Mini Scales 31 01-10-2009 09:41 AM
Tekin Redline Brushless Motors PeteB Electric On-Road 108 05-16-2007 08:24 PM
<<<<< Extras for sale, Chargers, ESC brushless >>>>> wikedgmc R/C Items: For Sale/Trade 26 06-24-2006 12:07 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 04:57 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net