Ko BMC Speedo

Old 07-05-2009, 04:00 AM
  #526  
Tech Master
 
Join Date: Jul 2007
Posts: 1,326
Default

Not sure what happened, but I cannot go any faster than a car running a sphere TC spec. It was ballistic couple weeks ago. But when I free wheel the car, I can clearly hear the timing advance kick in. Just doen't feel like it is on the track. Anyone else experience this? Gearining is at 4.8 running 17.5DUO Thanks
redbones is offline  
Old 07-05-2009, 09:31 AM
  #527  
Tech Master
iTrader: (2)
 
Join Date: Mar 2003
Posts: 1,465
Trader Rating: 2 (100%+)
Default

Originally Posted by redbones View Post
Not sure what happened, but I cannot go any faster than a car running a sphere TC spec. It was ballistic couple weeks ago. But when I free wheel the car, I can clearly hear the timing advance kick in. Just doen't feel like it is on the track. Anyone else experience this? Gearining is at 4.8 running 17.5DUO Thanks
the ko speedo timing comes on very smooth on the track where as the lrp it comes on very hard and can be felt on the track. i have found with running the spx that at times when in the infield going through a short shoot the timing will kick in about 3/4 of the way through the shoot and cause me to overshoot the corner. i have not had this happen since running the ko speedo.
goop is offline  
Old 07-05-2009, 11:03 AM
  #528  
Tech Master
 
Join Date: Jul 2007
Posts: 1,326
Default

hmm, \i used to be able to out-motor the guys using regular esc before and now I can't. Found out later that they are running 4.0 vs my 4.8. could this be the difference?
redbones is offline  
Old 07-05-2009, 08:14 PM
  #529  
Tech Elite
iTrader: (13)
 
B4james's Avatar
 
Join Date: Apr 2006
Posts: 2,162
Trader Rating: 13 (100%+)
Default

Have you been temping the motor ? It is no good dropping down to 4.0 if the motor is getting too hot.

Also if you haven't been temping your motor and you get it too hot this can also deteriate the performance of the rotor, which you will notice an instant performance drop if this happens.
B4james is offline  
Old 07-05-2009, 09:48 PM
  #530  
Tech Master
 
Join Date: Jul 2007
Posts: 1,326
Default

ok, here's what's happening.
me - KO BMC v1.5, trinity duo 17.5, timing set at 5, FDR 4.8, 5000mah 40C lipo

other guys - LRP TC spec, trinity duo 17.5, FDR 4.0, 4600mah matched Nimh.

result, same top speed down straight away. Is this how it is supposed to be?
redbones is offline  
Old 07-06-2009, 01:09 AM
  #531  
Tech Elite
iTrader: (13)
 
B4james's Avatar
 
Join Date: Apr 2006
Posts: 2,162
Trader Rating: 13 (100%+)
Default

Hi Redbones,


As per my previous question, have you checked the temperature of the motor after a 5 minute run, what temp in degrees is it getting to ?

If it is cool enough then you could potentially go up a pinion or two and be quicker down the straight,

Another question, what is your car like through the infield ? Is it punchier or quicker than theirs ? Sometimes even though you are the same down the straight you might be gaining more on the infield.


.8 drop in ratio is going to make your car quicker but you need to find out whether or not you can do this without cooking your motor, always temp check with brushless motors when dialling in to a track.
B4james is offline  
Old 07-06-2009, 01:22 AM
  #532  
Tech Adept
 
Join Date: Feb 2006
Posts: 137
Default

Anyone who knows where to buy the ICS adaptor for a bargain? I cannot understand how it can be so expensive, and i guess i dont need the majority of the cables that is in the package?
Foodie is offline  
Old 07-06-2009, 01:49 AM
  #533  
Tech Adept
 
ds400's Avatar
 
Join Date: Dec 2008
Posts: 106
Default Ko BMC

Hi guys,
I am using the esc on my 12th and running a 4.5T team orion right.
I was using a brushed motor and esc before, but just moved to brushless. I have download the mod 12th profile/ program from th e ko website but can't get any dragbrake out of my motor. I dont have a computer at the track so need to set the program and go back do testing .

Can you guys save me some time and give me the correct brake frequency to start with? And is it the best setting for 1/12th?
Attached Thumbnails Ko BMC Speedo-untitled.jpg  
ds400 is offline  
Old 07-06-2009, 01:57 AM
  #534  
Tech Master
 
Join Date: Jul 2007
Posts: 1,326
Default

Originally Posted by B4james View Post
Hi Redbones,


As per my previous question, have you checked the temperature of the motor after a 5 minute run, what temp in degrees is it getting to ?

If it is cool enough then you could potentially go up a pinion or two and be quicker down the straight,

Another question, what is your car like through the infield ? Is it punchier or quicker than theirs ? Sometimes even though you are the same down the straight you might be gaining more on the infield.


.8 drop in ratio is going to make your car quicker but you need to find out whether or not you can do this without cooking your motor, always temp check with brushless motors when dialling in to a track.
motor temps around 150F at the end. Someone told me that the target FDR for a 17.5 is around 4.8-5.0 so...
It just felt weird that the car sounds REALLY fast free wheeling, but when I drive it, its no different from the other non-timing boost cars.
redbones is offline  
Old 07-06-2009, 05:35 AM
  #535  
Tech Elite
iTrader: (10)
 
theisgroup's Avatar
 
Join Date: Apr 2002
Posts: 3,191
Trader Rating: 10 (100%+)
Default

Originally Posted by redbones View Post
motor temps around 150F at the end. Someone told me that the target FDR for a 17.5 is around 4.8-5.0 so...
It just felt weird that the car sounds REALLY fast free wheeling, but when I drive it, its no different from the other non-timing boost cars.
fdr, roll out just don't mean alot with the current crop of speedos now adays. even in 1/12 we have seen guys in 13.5 roll out from 74 - 98 all about the same pace. really now adays watching the lap times is more ciritcal and them motor temp. roll out and FDR are just a ball park
theisgroup is offline  
Old 07-06-2009, 06:17 AM
  #536  
Tech Master
iTrader: (2)
 
Join Date: Mar 2003
Posts: 1,465
Trader Rating: 2 (100%+)
Default

Originally Posted by redbones View Post
motor temps around 150F at the end. Someone told me that the target FDR for a 17.5 is around 4.8-5.0 so...
It just felt weird that the car sounds REALLY fast free wheeling, but when I drive it, its no different from the other non-timing boost cars.
Go up 2 teeth and do a five minute run and check temp
it should temp about 160-170
goop is offline  
Old 07-07-2009, 08:14 PM
  #537  
Regional Moderator
 
daniz24's Avatar
 
Join Date: Aug 2001
Location: D-Square Racing
Posts: 3,189
Default

hi guys, can I use this speedo for 12th scale 1cell lipo brushless? what motor is fast enough.

what setting do i need to adjust on the speedo, and do i have to use the receiver battery? thanks
daniz24 is offline  
Old 07-07-2009, 08:33 PM
  #538  
Tech Elite
iTrader: (10)
 
theisgroup's Avatar
 
Join Date: Apr 2002
Posts: 3,191
Trader Rating: 10 (100%+)
Default

Originally Posted by daniz24 View Post
hi guys, can I use this speedo for 12th scale 1cell lipo brushless? what motor is fast enough.

what setting do i need to adjust on the speedo, and do i have to use the receiver battery? thanks
1. yes
2. as fast as you want.
3. start with the 1/12 mod setting on the ko site
4. no, but I would recommend it. i know of guys running the bmc with no rx pack or booster. but that will probably only work in 17.5 and maybe 13.5 if you have the 5000 packs
theisgroup is offline  
Old 07-07-2009, 11:35 PM
  #539  
Tech Adept
 
ds400's Avatar
 
Join Date: Dec 2008
Posts: 106
Default

Originally Posted by theisgroup View Post
1. yes
2. as fast as you want.
3. start with the 1/12 mod setting on the ko site
4. no, but I would recommend it. i know of guys running the bmc with no rx pack or booster. but that will probably only work in 17.5 and maybe 13.5 if you have the 5000 packs
I use the setting from the kopropo website, but looks like I dont have enough drag brakes... What the setting you use??? I have a 4.5T on the kopropo.
ds400 is offline  
Old 07-07-2009, 11:43 PM
  #540  
Tech Elite
iTrader: (10)
 
theisgroup's Avatar
 
Join Date: Apr 2002
Posts: 3,191
Trader Rating: 10 (100%+)
Default

Originally Posted by ds400 View Post
I use the setting from the kopropo website, but looks like I dont have enough drag brakes... What the setting you use??? I have a 4.5T on the kopropo.
i don't run mod. 17.5 I run 5 and in 13.5 i run 120. but it all depends on your liking and also the motor and how much cog it has. I would ramp up the setting until you get to about 180 and then change the brake freq and start at around 100 and see. both adjustments affect drag brake.

actually talking to the factory guys, most in mod do not run any drag brake. they are soo use to a motor with no cog because even brushless do not have cog. Most I have heard run push brake. so they turn the drag brake down to nothing and make changes to brake freq until the brakes hit hard enough for their liking.
theisgroup is offline  

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.