R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 09-24-2008, 03:14 AM   #1
Tech Rookie
 
dOM91's Avatar
 
Join Date: Jul 2007
Posts: 9
Default Team Orion LiPO Balancing system

hey guys and girls of the RC world!
i've bought myself the Team Orion LiPO Balancing system, i had to rewire the 2S harness. then i plug my system into my PeakProdigy charger (very similar to the orginial Avionics charger) and i set it to charge. then is has a warning saying that there is no battery or that the battery circuit is open... can anyone help?
thanks dom
__________________
-Victoire ou défaite, on est toujours fiérs-
dOM91 is offline   Reply With Quote
Old 09-24-2008, 05:55 AM   #2
Tech Master
 
picco007's Avatar
 
Join Date: Dec 2001
Location: TX.
Posts: 1,814
Trader Rating: 91 (100%+)
Send a message via AIM to picco007 Send a message via Yahoo to picco007
Default

Quote:
Originally Posted by dOM91 View Post
hey guys and girls of the RC world!
i've bought myself the Team Orion LiPO Balancing system, i had to rewire the 2S harness. then i plug my system into my PeakProdigy charger (very similar to the orginial Avionics charger) and i set it to charge. then is has a warning saying that there is no battery or that the battery circuit is open... can anyone help?
thanks dom
If you have the Avionics balancer that is plugged in to the charger then the battery is plugged in to the balancer then you need to push the button on the balancer to the charge mode. I'm not sure but after you hook everything up, you'll see the lights blink twice to show you have a 2 cell hooked up then you need to push the button and you will be in the link or charge mode, then you can start charging. Hope that helps......Check the directions to make sure, if that doesn't help you.
__________________
EA Motorsports
picco007 is offline   Reply With Quote
Old 09-24-2008, 06:01 AM   #3
Tech Addict
 
FOXY923's Avatar
 
Join Date: Dec 2005
Location: Canada eh
Posts: 549
Default

Are you using an Orion lipo? If so, chances are the pack is balanced and the balancer shuts off before you can turn on the charger. That happened to me so I just balance my packs off the charger every ten chargers or so.
__________________
Paris Junction Hobbies ~ RROL.ca ~ Lou's Speedway ~ SCAR
XRAY X10 Link ~ CVTA Sakura Zero S ~ XRAY X10 Custom Oval ~ Caster Fusion F18
RACE 4FUN
FOXY923 is offline   Reply With Quote
Old 09-24-2008, 06:04 AM   #4
Tech Master
 
picco007's Avatar
 
Join Date: Dec 2001
Location: TX.
Posts: 1,814
Trader Rating: 91 (100%+)
Send a message via AIM to picco007 Send a message via Yahoo to picco007
Default

Dom,
Just thinking, if the charger says no battery and if you have the Orion balancer between the battery and charger then you need to change the mode on the balancer. If it says open circuit, then there may be an issue with the wiring. Let us know!
__________________
EA Motorsports
picco007 is offline   Reply With Quote
Old 09-24-2008, 06:08 AM   #5
Tech Rookie
 
dOM91's Avatar
 
Join Date: Jul 2007
Posts: 9
Default

yaaa, i managed to get it to work, just had to read the manual PROPERLY
thanks picco
__________________
-Victoire ou défaite, on est toujours fiérs-
dOM91 is offline   Reply With Quote
Old 09-24-2008, 06:09 AM   #6
Tech Master
 
picco007's Avatar
 
Join Date: Dec 2001
Location: TX.
Posts: 1,814
Trader Rating: 91 (100%+)
Send a message via AIM to picco007 Send a message via Yahoo to picco007
Default

No prob.
__________________
EA Motorsports
picco007 is offline   Reply With Quote
Old 09-24-2008, 07:27 AM   #7
Tech Champion
 
RC MARKET's Avatar
 
Join Date: Feb 2007
Location: HK
Posts: 6,172
Trader Rating: 12 (100%+)
Default

buy a balancer price can buy a with balance charger !

http://rcmarket.com.hk/index.php?manufacturers_id=107
RC MARKET is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Another begginer/returning question mark in wi Electric Off-Road 21 08-12-2009 08:51 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 07:09 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net