Go Back  R/C Tech Forums > General Forums > Electric On-Road
Much More 3080evo Controller problem >

Much More 3080evo Controller problem

Much More 3080evo Controller problem

Reply

Old 09-14-2008, 07:24 PM
  #1  
HPZ
Tech Apprentice
Thread Starter
iTrader: (12)
 
Join Date: May 2004
Location: Australia, Sydney
Posts: 98
Trader Rating: 12 (100%+)
Default Much More 3080evo Controller problem

Hi guys i have a 3080 controller that i'm using with reedy tire warmers. The controller has always worked fine, but today it suddenly stopped working . When i hook up the power into the controller, the red input Led turns on, but the yellow (heater) Led will no longer turn on no matter where i place the temperature knob. The tire warmers don't get hot nor does the battery. I tried the tire warmers via direct connection and they work fine.

Any help would be appreciated.

Thank you
HPZ is offline  
Reply With Quote
Old 09-14-2008, 08:49 PM
  #2  
Tech Elite
iTrader: (138)
 
SammyZ's Avatar
 
Join Date: Sep 2005
Location: New England
Posts: 3,045
Trader Rating: 138 (100%+)
Default

the Muchmore product failed, just buy a new one, its fairly cheap!
SammyZ is offline  
Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Terms of Service