R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 08-25-2008, 08:59 AM   #1
Tech Apprentice
 
jaminit's Avatar
 
Join Date: Aug 2008
Location: Lowell MA
Posts: 82
Trader Rating: 1 (100%+)
Default Problems with xcelorin 9400 kv ESC BURNT!!

I recently bought a Losi Mini T. I ran it once and was so impressed I went out and invested like $500 in aluminum parts, a new Fatuba reciever and transmitter and of course a brushless system. I chose the Xcelorin 9400kv because I knew Losi made it and figured it would be very easy to install and use. I am running it on a 1900mah 2 cell Lipo batterey. I spent about 3 hours installing everything. Once installed I program the reciever with the esc. Hold button when powering up, throttle, reverse, both blue and green light on...great, power off, on. Steering works perfect. Hit throttle engine spins a little then dies. Turn off and on, steering still works but blue light is on and no throttle response. I Repeat the programming again and exact same thing engine spinns a little and stops, then no response. Repeat programming and poof smoke poors out of the little hole on the ESC. I contacted Losi and have to send unit back in. Pobably will take a couple of weeks to get the new unit, which is very frusturating. Has any one else had this problem???? This is my first experience with Electric and Losi and not a good start. Any advice or ideas??????Please help.
jaminit is offline   Reply With Quote
Old 08-25-2008, 10:03 AM   #2
wyd
Tech Legend
 
wyd's Avatar
 
Join Date: Sep 2001
Location: Castle Mamba Max Pro. Feel its power!!!!!!!!!!
Posts: 21,142
Trader Rating: 50 (100%+)
Send a message via AIM to wyd
Default

More than likely you just got a bad speedo. It happens from time to time. It does suck when it happens to you but Losi has sold thousands of these things so every now and then a bad one pops up.

For the most part nothing to worry about. Losi will get it fixed or more than likely send you a new one and you will be on your way to having some fun.
__________________
Castle Creations (Since 2005) Just awesome products
Bumps & Jumps RC (Great Indoor facility for offroad and oval)
ST Racing Concepts (STRC)
Custom Works (Best Oval Cars around)
wyd is offline   Reply With Quote
Old 08-25-2008, 10:12 AM   #3
Tech Apprentice
 
jaminit's Avatar
 
Join Date: Aug 2008
Location: Lowell MA
Posts: 82
Trader Rating: 1 (100%+)
Default Thanks...

Thanks. I hope so. I have been using gas for 15 years but am a true NEWBIE to Electric. What is the engine size with the 9400 kv package. Also another quick question. When you do the initial programming should the engine be plugged in or not? And does it matter if it is.
jaminit is offline   Reply With Quote
Old 08-25-2008, 11:49 AM   #4
Tech Master
 
Join Date: Sep 2005
Location: NYC
Posts: 1,267
Trader Rating: 68 (100%+)
Send a message via AIM to joey
Default

the size of the motor is a 180 and its fine to program the esc with the motor plugged in, as the other guy said you just got a defective one it happens with electronics...
__________________
=Joe Wright=
joey is offline   Reply With Quote
Old 08-25-2008, 11:56 AM   #5
Tech Apprentice
 
jaminit's Avatar
 
Join Date: Aug 2008
Location: Lowell MA
Posts: 82
Trader Rating: 1 (100%+)
Default Thanks.

Hate to be a pain, but two more quick questions. One, what spur and pinion gears should I be running with this set up, and two I have been reading the post and am sooooo electric illiterate. Is there any website or books that explain all the electric terms you guys so easily use. Like figuring out what batterys to use, mah, lipo, engine info, and any other pertanent info I may need to excell in this area.
__________________
[COLOR="Red"]TA T4 w/Mamba Max 5400 KV:tire:[/COLOR]
[COLOR="Blue"]Losi Mini T/Slider Conversion w/Mamba Max 8000kv:eek:[/COLOR]
[COLOR="Indigo"]TA RC 18MT w/Mamba 8000kv:nod:
[/COLOR]
[COLOR="DarkRed"]RC 10l3 Oval [/COLOR]
[COLOR="DarkSlateGray"]TA T3 Stock[/COLOR]
jaminit is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Burnt ESC autostyle Electric On-Road 32 12-21-2007 02:48 PM
Help! Burnt TEKIN ESC! cheekeon Electric Off-Road 11 01-08-2007 02:18 PM
burnt up speedo thecrow2k Electric On-Road 1 01-09-2006 04:18 PM
Receiver burnt??? dct147 Nitro On-Road 7 08-21-2005 11:51 AM
Burnt? jwwu Electric On-Road 3 02-09-2003 09:51 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 07:12 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net