R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 05-14-2008, 07:31 AM   #76
Tech Elite
 
JasonC's Avatar
R/C Tech Charter Subscriber
 
Join Date: Apr 2003
Location: oceanside ca
Posts: 4,099
Trader Rating: 120 (100%+)
Default

Quote:
Originally Posted by kn7671 View Post
Funny, I bet you took the fan off because it broke. The Losi ESC uses the same crappy fan as a Novak ESC, just black instead of clear. Mine broke a blade on the 2nd race, before I pulled it off.
Hope your not a betting Man.... actuall i took the fan off to shorten the wires.
like all the fans out there the losi fan's are subject to break too.
JasonC is offline   Reply With Quote
Old 05-14-2008, 07:21 PM   #77
Tech Master
 
Join Date: Nov 2003
Posts: 1,052
Trader Rating: 16 (94%+)
Default

Losi Xcelorin Sensored BL Motors = Hacker Brushless E40 BL Motor.

I recently acquired a Losi 13.5 Sensored Xcelorin BL Motor and a Hacker Brushless E40 17.5, took both apart, and other than the color of the anondizing and the removable harness on the Losi motor, they are 100% identical. These are made by the same manufacturer.

I'm not complaining here, just making everyone aware that if you want a Losi Xcelorin Sensored BL motor and can't find one, pick up a Hacker Brushless E40 motor, same thing.

Last edited by kn7671; 05-14-2008 at 07:38 PM.
kn7671 is offline   Reply With Quote
Old 05-14-2008, 07:46 PM   #78
Tech Elite
 
yyhayyim's Avatar
 
Join Date: May 2006
Location: Weston, FL
Posts: 3,424
Trader Rating: 26 (100%+)
Default

Quote:
Originally Posted by kn7671 View Post
Losi Xcelorin Sensored BL Motors = Hacker Brushless E40 BL Motor.

I recently acquired a Losi 13.5 Sensored Xcelorin BL Motor and a Hacker Brushless E40 17.5, took both apart, and other than the color of the anondizing and the removable harness on the Losi motor, they are 100% identical. These are made by the same manufacturer.

I'm not complaining here, just making everyone aware that if you want a Losi Xcelorin Sensored BL motor and can't find one, pick up a Hacker Brushless E40 motor, same thing.
Great stuff bro...any pics?
yyhayyim is offline   Reply With Quote
Old 05-18-2008, 05:41 PM   #79
Tech Addict
 
cla5675's Avatar
 
Join Date: Feb 2007
Location: Greene County, OH
Posts: 672
Trader Rating: 49 (100%+)
Default

I ordered a Excelorin 13.5 system after reading all the great reviews on this site. I picked the sytsem up at my LHS yesterday and tried it out this morning. I hooked everything up before installing the components and I could not get the ESC to calibrate to my radio (Futaba 3PM with R153F reciever). I reversed the throttle servo, re-set the radio to the stock settings and it still would not calibrate. I tried a Novak XXL receiver and I could calibrate the system, but once I shut it off a coule times I would only get about 25% power at full throttle and the green light would come on indicating I was at full throttle. I thought maybe I needed to update firmware. So, I downloaded the software, but the computer would not connect to the ESC once I instaled the USB connection.....the light on the USB adaptor would not turn green. I uninstalled/re-installed and re-booted for an hour and still nothing. I then noticed I had the ESC switch on and flipped it off while the USB was plugged in.....a puff of smoke and the ESC is now dead!!! Man, I'm super po'ed!! I called Losi's tech line and got a recording, so I just sent them an email. Has anyone had a similar experience? My buddy got the 10.5 earlier this week and it was dead right out of the box. I'm not complaing....well yeah I guess I am.....I just want to know if anyone has had the same bad luck?
cla5675 is offline   Reply With Quote
Old 05-19-2008, 04:34 AM   #80
Tech Master
 
Join Date: Nov 2003
Posts: 1,052
Trader Rating: 16 (94%+)
Default

Quote:
Originally Posted by cla5675 View Post
I just want to know if anyone has had the same bad luck?
I've not had any issues yet, but another guy at our local club just got one and could not keep the ESC Setup/Calibration saved. He kept on having to re-setup, a total of about 10-times he said. Needless to say, he is returning the unit to Horizon Hobby.
kn7671 is offline   Reply With Quote
Old 05-19-2008, 07:20 AM   #81
Tech Elite
 
JasonC's Avatar
R/C Tech Charter Subscriber
 
Join Date: Apr 2003
Location: oceanside ca
Posts: 4,099
Trader Rating: 120 (100%+)
Default

i too had an issue getting my Losi ESC to Calibrate.. Turnd out to be a USER Error... ( you have to Shut the ESC off After the blinking blue light turns solid blue.) ( kinda like Windows... needs to reboot after you install a program...lol)
JasonC is offline   Reply With Quote
Old 05-19-2008, 09:13 AM   #82
Tech Regular
 
Join Date: Sep 2006
Posts: 317
Trader Rating: 3 (100%+)
Default

I thought maybe I needed to update firmware. So, I downloaded the software, but the computer would not connect to the ESC once I instaled the USB connection.....the light on the USB adaptor would not turn green. I uninstalled/re-installed and re-booted for an hour and still nothing. I then noticed I had the ESC switch on and flipped it off while the USB was plugged in.....a puff of smoke and the ESC is now dead!!! Man, I'm super po'ed!! I called Losi's tech line and got a recording, so I just sent them an email. Has anyone had a similar experience? My buddy got the 10.5 earlier this week and it was dead right out of the box. I'm not complaing....well yeah I guess I am.....I just want to know if anyone has had the same bad luck?[/QUOTE]

I had the same problem with the light turning green it have to do with going to the computer systems and do a few config.. the problem you have with the burning of your esc is when you are changing your setup you should not have the power connect you should take the batteries out, you should call Losi and speak to Andrew he is the config guru.
Elijah is offline   Reply With Quote
Old 05-19-2008, 10:23 AM   #83
Tech Elite
 
rocketron's Avatar
 
Join Date: Jun 2003
Location: palm desert
Posts: 2,266
Trader Rating: 16 (100%+)
Default

Quote:
Originally Posted by Elijah View Post
I thought maybe I needed to update firmware. So, I downloaded the software, but the computer would not connect to the ESC once I instaled the USB connection.....the light on the USB adaptor would not turn green. I uninstalled/re-installed and re-booted for an hour and still nothing. I then noticed I had the ESC switch on and flipped it off while the USB was plugged in.....a puff of smoke and the ESC is now dead!!! Man, I'm super po'ed!!
Here is a few things:
If the USB adapter LED is not turning green the drivers did not load, there are two drivers that must be loaded. Many AV programs prevent drivers from loading and will need to be suspended during installation.

Also FULL ADMIN privledges are required to install.

Where did you download the firmware from ? - assuming this is the sensored ESC there is no download available.
__________________
- SchuurSpeed - 6X ROAR National Stock Champion
- Hobbywing North America Team Manager
rocketron is offline   Reply With Quote
Old 05-19-2008, 02:07 PM   #84
Tech Addict
 
cla5675's Avatar
 
Join Date: Feb 2007
Location: Greene County, OH
Posts: 672
Trader Rating: 49 (100%+)
Default

I did not turn off the AV to get the drivers installed. I was too frustrated by the time I got to that point. I was just trying to look to see if there was a firmware update since I was unable to get any one on the phone. Hopefully, I'll have a response to my email from Losi when I get home. Thanks for everyone's help!!
cla5675 is offline   Reply With Quote
Old 05-21-2008, 08:40 AM   #85
Tech Rookie
 
Join Date: Oct 2007
Posts: 7
Thumbs up Xcelorin 6.5 w/RC10 T4

Hello,

I bought my Xcelorin 6.5 combo last Friday from my LHS and love it! I went from the Traxxas VXL-3 which is def 1 solid ESC (believe it or not). I was looking to upgrade and wanted the tunability of the Novak but also be able to run my 3S pack I previously purchased. Anywho, I have been practicing with it for about a week now and its def taking some getting used to relative to the Traxxas, but I really enjoy making changes via my laptop and then see the instance difference on the track. I had no issues calibrating to my DX3 and no issues connecting to the laptop and making changes. The ONLY problem I have had so far is when I ran a 2S lipo and put the "Initial Acceleration" to anything but "High", I would get a glitch or a pause when going from 1/4 or 1/2 throttle to full throttle. I would even keep the trigger on transmitter fully pulled in and the truck would just sit there until I released the trigger and re-pulled it, then the truck would move....weird.

Jeremy D.
karmahkid is offline   Reply With Quote
Old 05-25-2008, 01:46 PM   #86
Tech Apprentice
 
JLTrinity's Avatar
 
Join Date: Oct 2006
Location: Jerez De La Frontera (Spain)
Posts: 57
Default

Hello!
What do you think about the 7500kv combo? has someone test it? its reliable?, thanks
JLTrinity is offline   Reply With Quote
Old 05-25-2008, 02:55 PM   #87
Tech Master
 
Join Date: Nov 2003
Posts: 1,052
Trader Rating: 16 (94%+)
Default

FYI - there is a software update for the ESC available on Losi's website for the Sensored ESC now.

Here is the link to it:

http://www.losi.com/Support/XcelorinDownloads.aspx

Anyone notice that changing the timing has little to no effect on the motor speed?
kn7671 is offline   Reply With Quote
Old 05-26-2008, 02:07 AM   #88
Tech Elite
 
rocketron's Avatar
 
Join Date: Jun 2003
Location: palm desert
Posts: 2,266
Trader Rating: 16 (100%+)
Default

The firmware posted is the same version D110123 that is supplied on the ESC.

Larry Fairtrace (losi), EJ Evans, Jason E. (TOP), Tony Fiorilla (sp? sorry Tony) Carl Hindman (Corally), Jason C.(Yokomo) used Xcelorin ESC's at the Reedy Race

Larry Fairtrace, Carl Hindman, Jason C. and , Hiro K. Hotbodies used Xcelorin 13.5 Motors

Great weekend guys!
__________________
- SchuurSpeed - 6X ROAR National Stock Champion
- Hobbywing North America Team Manager

Last edited by rocketron; 05-26-2008 at 11:57 AM.
rocketron is offline   Reply With Quote
Old 05-26-2008, 05:37 PM   #89
Tech Rookie
 
Join Date: Oct 2007
Posts: 7
Default

Quote:
Originally Posted by kn7671 View Post
FYI - there is a software update for the ESC available on Losi's website for the Sensored ESC now.

Here is the link to it:

http://www.losi.com/Support/XcelorinDownloads.aspx

Anyone notice that changing the timing has little to no effect on the motor speed?
I actually downloaded and installed the above firmware. I had a full throttle issue where the vehicle would stop until the throttle is released and then pulled again. Even if it is the same firmare that came with the ESC originally, it seems to have fixed it for this past weekends race.

When turning up the timing I definitely noticed an improvement in motor performance.

Just wanted to apologize for posting in an on road forum all though I run aff road. Its just hard to find any forums right now with the Xcelorin being so new.
karmahkid is offline   Reply With Quote
Old 05-26-2008, 08:48 PM   #90
Tech Fanatic
 
Join Date: Oct 2003
Location: bella vista ar
Posts: 869
Send a message via AIM to ERTRACHTER
Default

congrats to larry fairtrace and to losi on their big win abd a big thanks goes out to ron schuur for all the help this weekend
__________________
ASSOCIATED 12r5.1,REEDY MOTOR AND BATTERY, LRP SPEEDO,KIMBROUGH PRODUCTS,BIG DOG RACING,BELMONT R/C SPEEDSHOP, DENNIS LYMAN RACING, TEAM TOSO, TEAM FACTORY BITTER, SCHUUR SOLUTIONS, SIMMONS RACING, TEAM BOOZCRUZ
ERTRACHTER is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
LOSI Xcelorin Brushless/ESC combo ORANGE DOG R/C Items: For Sale/Trade 26 09-01-2008 10:44 PM
<< ** New Losi Desert Truck with NIP Xcelorin Brushless Combo ** >> RcOneNitro R/C Items: For Sale/Trade 28 08-09-2008 07:35 PM
XCELORIN brushless? matthewh Micro and Mini Scales 48 06-26-2008 04:34 PM
losi xcelorin brushless system HarleyMf2 Electric Off-Road 3 04-27-2008 09:39 AM
Losi Xcelorin S Brushless Electronic Speed Control SoCalMitch Electric On-Road 12 03-27-2008 08:08 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 11:52 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net