R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 11-14-2008, 06:52 PM   #286
Tech Regular
 
revo523's Avatar
 
Join Date: Oct 2006
Location: NOLA!
Posts: 466
Trader Rating: 8 (100%+)
Default

Quote:
Originally Posted by metalracer2 View Post
i just picked up a brushless system
is there anything i should do be for i run it?
What kind of radio you running with? you should adjust everything on the computer first.
revo523 is offline   Reply With Quote
Old 11-14-2008, 08:14 PM   #287
Tech Elite
 
metalracer2's Avatar
 
Join Date: Nov 2007
Location: Riverside, CA
Posts: 2,548
Trader Rating: 20 (100%+)
Send a message via AIM to metalracer2
Default

i will be using the ko ex1 mars with a spektrum module
__________________
First you forget names, then you forget faces. Next you forget to pull your zipper up and finally, you forget to pull it down.
Team BOOZE CRUISEN!
Rides....
AE B4.1W AE T4.1
metalracer2 is offline   Reply With Quote
Old 11-23-2008, 04:56 AM   #288
Tech Apprentice
 
Colin8ight-E's Avatar
 
Join Date: Nov 2008
Location: Adelaide, South Australia
Posts: 67
Default Xcelorin ESC Problem

Hi Guys,

I'm new to this Forum.
I have a Limited Edition 8ight-E and the settings on the ESC are all set on Default, I was practicing with the Buggy yesterday and it was going fine on 1 Losi 4s Battery and then bout half way through the battery the Buggy just stopped and only made the cogging sound. So I plugged my Friends Losi 2100KV motor into my ESC and it was gogging like mine, then I plugged my motor into my friends 8ight-E ESC (yes he has one to) and the motor worked fine. I plugged the ESC into the computer and the settings where the same as before the ESC stuffed up. There is no burnt smell or the ESC and Motor wasn't hot at all. will updating the ESC work? or can anyone help me fix this problem. Or should I buy another brand of ESC.

Has anyone heard of this problem with Xcelorin 1/8th ESC?

Thanks for any comments.
Colin8ight-E is offline   Reply With Quote
Old 12-01-2008, 09:13 AM   #289
Tech Elite
 
metalracer2's Avatar
 
Join Date: Nov 2007
Location: Riverside, CA
Posts: 2,548
Trader Rating: 20 (100%+)
Send a message via AIM to metalracer2
Default

I ran my speed control this weekend with the default setting and it ran great.
One thing I was wondering is, how does the timing affect the brushless motors?
__________________
First you forget names, then you forget faces. Next you forget to pull your zipper up and finally, you forget to pull it down.
Team BOOZE CRUISEN!
Rides....
AE B4.1W AE T4.1
metalracer2 is offline   Reply With Quote
Old 12-01-2008, 09:40 AM   #290
Tech Champion
 
MikeXray's Avatar
 
Join Date: Oct 2006
Location: New York
Posts: 5,749
Trader Rating: 73 (100%+)
Default

Quote:
Originally Posted by Colin8ight-E View Post
Hi Guys,

I'm new to this Forum.
I have a Limited Edition 8ight-E and the settings on the ESC are all set on Default, I was practicing with the Buggy yesterday and it was going fine on 1 Losi 4s Battery and then bout half way through the battery the Buggy just stopped and only made the cogging sound. So I plugged my Friends Losi 2100KV motor into my ESC and it was gogging like mine, then I plugged my motor into my friends 8ight-E ESC (yes he has one to) and the motor worked fine. I plugged the ESC into the computer and the settings where the same as before the ESC stuffed up. There is no burnt smell or the ESC and Motor wasn't hot at all. will updating the ESC work? or can anyone help me fix this problem. Or should I buy another brand of ESC.

Has anyone heard of this problem with Xcelorin 1/8th ESC?

Thanks for any comments.
Horizon has very good support, I would call them up and send in the ESC for repair.
__________________
Mike L. Awesomatixusa.com | TQWire.com | Islandraceway.com |JacksonRCracing.com | Horsham RC | Sweepracingusa.com
MikeXray is offline   Reply With Quote
Old 12-01-2008, 10:32 AM   #291
Tech Champion
 
Kwikvdub's Avatar
 
Join Date: Mar 2003
Location: Queens, NY
Posts: 5,972
Trader Rating: 91 (100%+)
Send a message via AIM to Kwikvdub
Default

Ran my BL Speedo for the first time yesterday in my Type R in sedan foam and I must say this speedo ROCKS!!........... Great product, easy to use!!
__________________
Alex Valdes

TQRacing / 360 v2 RC Raceway / Team Downgrade Designs
Kwikvdub is offline   Reply With Quote
Old 12-07-2008, 05:40 AM   #292
Tech Master
 
yokemad's Avatar
 
Join Date: Apr 2007
Posts: 1,150
Default

At the end of the day Are these LoSi Brushless motor has the same performance as the Hacker Motors???
Cheers
yokemad is offline   Reply With Quote
Old 12-07-2008, 07:18 PM   #293
Tech Apprentice
 
Join Date: Mar 2007
Location: Dallas, TX
Posts: 54
Default

Quote:
Originally Posted by yokemad View Post
At the end of the day Are these LoSi Brushless motor has the same performance as the Hacker Motors???
Cheers
I have been wondering the same. Someone from Hacker in the Hacker thread said something like, “If it doesn’t say Hacker then don’t expect Hacker performance.” or something like that. He didn’t direct the statement at Losi or really anybody, but it makes me wonder if the Losi motors are made with the same quality iron/magnets and copper as Hacker branded motors?
Squating Goat is offline   Reply With Quote
Old 12-07-2008, 08:12 PM   #294
Tech Master
 
Join Date: Nov 2003
Posts: 1,052
Trader Rating: 16 (94%+)
Default

Quote:
Originally Posted by Squating Goat View Post
I have been wondering the same. Someone from Hacker in the Hacker thread said something like, “If it doesn’t say Hacker then don’t expect Hacker performance.” or something like that. He didn’t direct the statement at Losi or really anybody, but it makes me wonder if the Losi motors are made with the same quality iron/magnets and copper as Hacker branded motors?
Yes - the Losi and Hacker motors are virtually identical. I took pictures of both in a side-by-side comparison. I think I posted the pictures in the Hacker thread. Below is the link:

http://www.rctech.net/forum/electric...ml#post4447344
kn7671 is offline   Reply With Quote
Old 12-07-2008, 08:28 PM   #295
jrp
Tech Master
 
jrp's Avatar
 
Join Date: Nov 2003
Posts: 1,606
Trader Rating: 18 (100%+)
Default

The Losi motors run very well. I have run Losi, Novak, and Trinity and the Losi runs as well as all the others.
jrp is offline   Reply With Quote
Old 12-08-2008, 06:22 AM   #296
Tech Master
 
Join Date: Nov 2003
Posts: 1,052
Trader Rating: 16 (94%+)
Default

Quote:
Originally Posted by jrp View Post
The Losi motors run very well. I have run Losi, Novak, and Trinity and the Losi runs as well as all the others.
I agree that my Losi 13.5 Brushless ran as good as the others too, but I felt that it did not have the punch my Novak motor did.
kn7671 is offline   Reply With Quote
Old 12-16-2008, 06:13 PM   #297
Tech Elite
 
nitrobeast's Avatar
 
Join Date: Apr 2006
Location: Colonia, NJ
Posts: 2,340
Trader Rating: 41 (100%+)
Default losi stock fan needed

Hey guys

Im in need of a stock fan for the xcelorin. Does anyone have one they removed and dont use?
__________________
Rui Goncalves
Team CRC|Awesomatix USA|TQ Wire|
Jackson curbs, ready for lift off!
nitrobeast is offline   Reply With Quote
Old 12-16-2008, 06:49 PM   #298
Tech Elite
 
rocketron's Avatar
 
Join Date: Jun 2003
Location: palm desert
Posts: 2,266
Trader Rating: 16 (100%+)
Default

Here is the direct replacement fan. They are 30mm fans

http://www.horizonhobby.com/Products...rodID=LOSB9365
__________________
- SchuurSpeed - 6X ROAR National Stock Champion
- Hobbywing North America Team Manager
rocketron is offline   Reply With Quote
Old 12-17-2008, 04:58 AM   #299
Tech Elite
 
nitrobeast's Avatar
 
Join Date: Apr 2006
Location: Colonia, NJ
Posts: 2,340
Trader Rating: 41 (100%+)
Default

Quote:
Originally Posted by rocketron View Post
Here is the direct replacement fan. They are 30mm fans

http://www.horizonhobby.com/Products...rodID=LOSB9365
I understand that. I need to send me esc in for repair but dont want to send it in with the much more fan i have on it now, just in case they send me a new one. The stock fan i gave it away to a local racer and now i need one. I was trying to get one free and cover shipping...
__________________
Rui Goncalves
Team CRC|Awesomatix USA|TQ Wire|
Jackson curbs, ready for lift off!
nitrobeast is offline   Reply With Quote
Old 12-24-2008, 02:32 AM   #300
Tech Regular
 
sb7979's Avatar
 
Join Date: Jan 2007
Location: Toledo, OH
Posts: 382
Trader Rating: 36 (100%+)
Default

Quote:
Originally Posted by dr_hfuhuhurr View Post
Just tried it. No Vista 64 drivers. This product will not work with Vista 64. Anyone from Losi know if it will be compatible anytime soon?

Was this question ever answered? Maybe I missed it, or someone knows something......?
sb7979 is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
LOSI Xcelorin Brushless/ESC combo ORANGE DOG R/C Items: For Sale/Trade 26 09-01-2008 10:44 PM
<< ** New Losi Desert Truck with NIP Xcelorin Brushless Combo ** >> RcOneNitro R/C Items: For Sale/Trade 28 08-09-2008 07:35 PM
XCELORIN brushless? matthewh Micro and Mini Scales 48 06-26-2008 04:34 PM
losi xcelorin brushless system HarleyMf2 Electric Off-Road 3 04-27-2008 09:39 AM
Losi Xcelorin S Brushless Electronic Speed Control SoCalMitch Electric On-Road 12 03-27-2008 08:08 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 03:17 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net