Go Back  R/C Tech Forums > General Forums > Electric On-Road
integy 16X9 charger >

integy 16X9 charger

integy 16X9 charger

Old 12-23-2001, 05:24 PM
  #1  
Tech Master
Thread Starter
iTrader: (1)
 
Join Date: Dec 2001
Posts: 1,249
Trader Rating: 1 (100%+)
Default integy 16X9 charger

I bought a new indi 16X9 charger about 2 weeks ago and i love it. It does everything i need it to do for my batteries for stock racing. What does every one else think of it. Any problems?
Jarrod Langlois is offline  
Old 12-25-2001, 10:13 AM
  #2  
Tech Fanatic
iTrader: (19)
 
Join Date: Nov 2001
Location: Central IL.
Posts: 839
Trader Rating: 19 (100%+)
Thumbs up

I like mine alot sofar. I run tire warmers and my 16x2 off the back of it. Pretty sweet charger for the money..
DHMOTORSPORTS is offline  
Old 12-25-2001, 08:51 PM
  #3  
Tech Rookie
 
Join Date: Dec 2001
Location: Iwata Japan
Posts: 4
Default Help me

Hi, I just bought the 16X9 charger and I got really annoyed by the fact that my charger false peaked. I tried using the the delta peak charger and it worked well, so I know that there is something wrong with the 16X9. Is there anything that I can do in the settings that can solve my problem.
Azmi is offline  
Old 12-25-2001, 09:30 PM
  #4  
Tech Apprentice
 
Join Date: Sep 2001
Location: lakehood, ca. 90715
Posts: 90
Default

azmi,

it shouldn't false peak. it could be your batteries. if that's the case, increase the volt threshold. for nicads, i use 15 mv/cell. for nimh, i use 6 mv/cell. other than that, you shouldn't be false peaking. perhaps, your unit needs to be re-calibrated. my buddy purchased one that would give very high voltage readings at the completion of the charge. it wasn't charging the batteries to high, but the built-in volt meter was reading the battery voltages higher than what they actually were. the 16x9 is a very good charger. maybe you got one that might be defective, i'd send it back to have it checked out. but before that, try adjusting the volt thresholds to my suggestions, and if that doesn't work- send it back! i've charged old batteries and they never false peaked w/ this charger.
diesel31 is offline  
Old 12-26-2001, 01:15 AM
  #5  
Tech Rookie
 
Join Date: Dec 2001
Location: Iwata Japan
Posts: 4
Default

Diesel buddy
Thank you so much for your suggestion. I will increase the voltage threshold and recharge those batteries. At first I thought that the batteries that were in trouble but my charger false peaked even the newly bought Tamiya 2400.
I got to admit that I am very new to this hobby and I need all the helps that I can get. Anyway, thanks for your suggestion
Azmi is offline  
Old 12-26-2001, 08:37 AM
  #6  
Tech Master
Thread Starter
iTrader: (1)
 
Join Date: Dec 2001
Posts: 1,249
Trader Rating: 1 (100%+)
Default

azmi, what was ur voltage threshold set at??
Jarrod Langlois is offline  
Old 12-30-2001, 09:31 AM
  #7  
Tech Rookie
 
Join Date: Dec 2001
Location: Iwata Japan
Posts: 4
Default

Spaz
I kept my threshold value to the one set by the manufacturer. I think that's the reason why it was not optimized for my batteries. I guess 15 can be a good number the 2400 batteries.
Azmi is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell or Share My Personal Information -

Copyright © 2023 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.