RDX question...

Old 01-23-2008, 06:06 PM
  #1  
Tech Addict
Thread Starter
 
TL_XXX-S_racer's Avatar
 
Join Date: Jun 2004
Location: Florida
Posts: 577
Default RDX question...

Hey guys, Well I just finished re-building my RDX and seems like I have a little problem. With running the 1,1 roll centers in the front, I cant seem to get the ride height down to 5mm. Running rubber tires 22lb springs. Plus, before the chassis bottems out on the board, the shocks get fully compressed. What seems to be the problem so I can fix the problem?

Thanks,
Chris
TL_XXX-S_racer is offline  
Old 01-23-2008, 08:04 PM
  #2  
Tech Elite
iTrader: (10)
 
Brian McGreevy's Avatar
 
Join Date: Jan 2003
Location: Illinois
Posts: 4,081
Trader Rating: 10 (100%+)
Default

Cut approximately 3 mm off the shock end where the shaft threads in. This will allow the spring cup (and spring) to sit lower.
Brian McGreevy is offline  
Old 01-23-2008, 08:25 PM
  #3  
Tech Elite
iTrader: (19)
 
RCFREAK's Avatar
 
Join Date: Sep 2001
Location: MEMBER OF THE "MWC" Mimi Wong Clan
Posts: 2,433
Trader Rating: 19 (100%+)
Default

i use hpi spring perches... lower than the rdx ones.
RCFREAK is offline  
Old 01-23-2008, 09:00 PM
  #4  
Tech Initiate
iTrader: (1)
 
Nuclear Dave's Avatar
 
Join Date: Jan 2008
Location: Deland, FL
Posts: 32
Trader Rating: 1 (100%+)
Default

http://www.corallyusa.com/2005/shocks.htm
Nuclear Dave is offline  
Old 01-23-2008, 09:04 PM
  #5  
Tech Champion
iTrader: (16)
 
Still Bill's Avatar
 
Join Date: Jan 2004
Location: Reno, NV
Posts: 7,379
Trader Rating: 16 (100%+)
Default

Originally Posted by RCFREAK View Post
i use hpi spring perches... lower than the rdx ones.
Agreed that this is the answer for your rubber tire setup.
Still Bill is offline  
Old 01-24-2008, 07:12 AM
  #6  
Tech Elite
iTrader: (50)
 
Join Date: Apr 2006
Location: Midwest
Posts: 2,010
Trader Rating: 50 (100%+)
Default

Originally Posted by TL_XXX-S_racer View Post
Hey guys, Well I just finished re-building my RDX and seems like I have a little problem. With running the 1,1 roll centers in the front, I cant seem to get the ride height down to 5mm. Running rubber tires 22lb springs. Plus, before the chassis bottems out on the board, the shocks get fully compressed. What seems to be the problem so I can fix the problem?

Thanks,
Chris
Chris,

I run an RDX and was wondering how much traction you have. I have never ran a spring that stiff unless traction was through the roof. Usually 17's in front and 14's in rear. I use the 3mm chassis. and standard Corally spring cups. Associated cups are lower also. I use them for when I race Foam though.

I use full length shock shafts and std towers.
Jaz406 is offline  
Old 01-24-2008, 12:17 PM
  #7  
Tech Addict
Thread Starter
 
TL_XXX-S_racer's Avatar
 
Join Date: Jun 2004
Location: Florida
Posts: 577
Default

Ok thanks guys for the help. What would the easiest way to go? Get different shock spring perches? If so, just get the HPI ones, for the Pro4 or what? Im also using the Phi shock towers, with standard shock length. The towers so ride height doesnt change when you move shock position

Jaz: Well the thing is, Im running 35 weight oil, with one-way. And the rest of the setup you would have to know, why Im running that stiff of a spring
TL_XXX-S_racer is offline  
Old 01-24-2008, 07:47 PM
  #8  
Tech Champion
iTrader: (16)
 
Still Bill's Avatar
 
Join Date: Jan 2004
Location: Reno, NV
Posts: 7,379
Trader Rating: 16 (100%+)
Default

Originally Posted by TL_XXX-S_racer View Post
Ok thanks guys for the help. What would the easiest way to go? Get different shock spring perches? If so, just get the HPI ones, for the Pro4 or what? Im also using the Phi shock towers, with standard shock length. The towers so ride height doesnt change when you move shock position

Jaz: Well the thing is, Im running 35 weight oil, with one-way. And the rest of the setup you would have to know, why Im running that stiff of a spring
Yes, the Pro4 spring perches are the ones.

Why are you running Phi shock towers on your RDX? Are you sure that they aren't the low version ones?
Still Bill is offline  
Old 01-25-2008, 12:07 AM
  #9  
Tech Elite
iTrader: (50)
 
Join Date: Apr 2006
Location: Midwest
Posts: 2,010
Trader Rating: 50 (100%+)
Default

Originally Posted by TL_XXX-S_racer View Post
Ok thanks guys for the help.

Jaz: Well the thing is, Im running 35 weight oil, with one-way. And the rest of the setup you would have to know, why Im running that stiff of a spring
Cool

Send me your setup via p.m. I'd like to see it.
Jaz406 is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.