R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 10-27-2007, 01:19 AM   #1
Tech Regular
 
wog....supraman's Avatar
 
Join Date: Jan 2007
Location: PERTH
Posts: 489
Trader Rating: 3 (100%+)
Send a message via MSN to wog....supraman
Default Blown ESC??

Hey,

I have a LRP IPC v7.1......have had it 4 about 5-6months now....i accidently plugged into my RX the wrong way around......and now it doesnt turn on......i had a servo hookd up at the time and it is still fine...

have i blown my ESC......i went through the manual and it only said things about the battery polarity...nuffin bout hookin it up 2 the RX the wrong way around...but my guess is i have blown it....

can any1 help me?

cheers
wog
__________________
Tamiya TNX5.2R, Taniya TA05, Tamiya TB-02, Team Associated Factory Team B4, Twister CP V2, HoBao Pirate 10 MT, Tamiya TNX5.2R spare chassis x2, ebay spec submarine, HSP Rock crawler! FOR SALE!!! pm me
wog....supraman is offline   Reply With Quote
Old 10-27-2007, 02:51 AM   #2
Tech Addict
 
more$thanbrains's Avatar
 
Join Date: Aug 2006
Location: Sooke BC Canada
Posts: 677
Send a message via MSN to more$thanbrains
Default

shouldnt be blown

maybe you blew your reciver due to incorrect voltage going into the signal port


try a different reciver or if you have another ESC you know works try that

or even a reciver pack and plug your servo into the throttle port

hope this helps
__________________
Xray~Titan~Ko Propo~Orion~Muchmore~Dekelz.com
T2 007 US/EU~CRC Gen-XL~MO3-Pro~NT1~Corally C10X
'73 Ford Bronco sittin on 36" swampers~ 10" lift
more$thanbrains is offline   Reply With Quote
Old 10-27-2007, 03:11 AM   #3
Tech Regular
 
wog....supraman's Avatar
 
Join Date: Jan 2007
Location: PERTH
Posts: 489
Trader Rating: 3 (100%+)
Send a message via MSN to wog....supraman
Default

thanxs 4 the help mate but sumhow i found out wat the prob was....

i had 2 leave in a rush 4 a drivng lesson...so i didnt have time 2 chek over the whole thing...

the power switch is inclosed......the wire came off the terminal and still stayd in the enclosure so i couldnt see that it was d/c

thanxs anyways

wog
__________________
Tamiya TNX5.2R, Taniya TA05, Tamiya TB-02, Team Associated Factory Team B4, Twister CP V2, HoBao Pirate 10 MT, Tamiya TNX5.2R spare chassis x2, ebay spec submarine, HSP Rock crawler! FOR SALE!!! pm me
wog....supraman is offline   Reply With Quote
Old 10-27-2007, 06:11 AM   #4
Tech Elite
 
t4m1y4niac's Avatar
 
Join Date: Feb 2006
Posts: 4,309
Default

carefull next time bro
__________________
SABRE S4 by TOP RACING....
t4m1y4niac is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Blown Speed Control. Blown Reciever? DomainG8 Radio and Electronics 6 03-17-2008 02:15 PM
WTB Blown Duratrax ICE Paco1001 R/C Items: Wanted to Buy 16 06-28-2007 09:28 PM
Blown Motor derricklong38 Electric Off-Road 10 09-18-2006 10:08 PM
Blown 4.5 Drewdc90 Electric On-Road 7 07-10-2006 07:21 AM
Much More PSU blown up?? VenomWorldOrder Electric On-Road 26 12-31-2005 10:02 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 10:15 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net