R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 08-04-2007, 10:47 AM   #1
Tech Adept
 
Join Date: Feb 2007
Posts: 240
Default i need help fats please.

hey guys,

i just came from my LHS and bought 2 battery's and a speed control for my F103 LM the battery's are charged and the remote is at full power... now heres my problem ... i connected all the wires and turned everything on and try to test it out before going outside and nothing happened... so i moved the wires from ch. 1 to ch.2 and so forth and still nothing, but when i touch the antenna to the reciver wire the car goes hay wire going to forward and reverse with no control input from me, and the steering servo wont turn either... i went with what my LHS suggested i get , i have the traxxas Tl-1 ESC and a venom 3300 NIMH battery

any help would be great thanks
Hpimichael is offline   Reply With Quote
Old 08-04-2007, 10:50 AM   #2
Tech Adept
 
Join Date: Feb 2007
Posts: 240
Default

sorry ESC IS XL-1
Hpimichael is offline   Reply With Quote
Old 08-04-2007, 10:54 AM   #3
Tech Regular
 
Join Date: Jul 2006
Location: Surrey British Columbia Canada
Posts: 304
Default

si the esc setup for your radio???? do you have the wires going to the reciever the right way??
C_Suzuki is offline   Reply With Quote
Old 08-04-2007, 10:55 AM   #4
Tech Rookie
 
Join Date: Dec 2006
Posts: 13
Default

Are the connectors in the reciever the correct way around?


Ian
fatboy_coach is offline   Reply With Quote
Old 08-04-2007, 11:01 AM   #5
Tech Adept
 
Join Date: Feb 2007
Posts: 240
Default

yes i have a futaba magnum 2pl and the wires are in the right way they wont go in the other way ... and im running the tamiya black can ... idk if that makes a difference...
Hpimichael is offline   Reply With Quote
Old 08-04-2007, 11:02 AM   #6
Tech Elite
 
K_Spec_RC's Avatar
 
Join Date: Oct 2006
Location: Powder Springs, Ga
Posts: 2,734
Trader Rating: 8 (100%+)
Send a message via MSN to K_Spec_RC
Default

do you have the transmitter crystal in the receiver and rec. in the trans? I did this once and it drove me up the wall...
__________________
HighVelocityRacing.com | TurtleTraxRaceway.com | itFitzDesign.wordpress.com | Misfitz Motorsports | Jconcepts | KO Propo | Tekin | Kyosho RB5 SP | Kyosho Ultima SC
K_Spec_RC is offline   Reply With Quote
Old 08-04-2007, 11:09 AM   #7
Tech Adept
 
Join Date: Feb 2007
Posts: 240
Default

hahahah i feel like an idot , i had grabbed the wrong reciver i grabbed teh 27 hertz not the 75 herts
Hpimichael is offline   Reply With Quote
Old 08-04-2007, 11:31 AM   #8
Tech Adept
 
Join Date: Feb 2007
Posts: 240
Default

okay guys so i have a prophet charger from dynomite and it wont charge my battery, it just keeps beeping .... any ideas?
Hpimichael is offline   Reply With Quote
Old 08-04-2007, 02:48 PM   #9
Tech Adept
 
Join Date: Nov 2006
Posts: 128
Default

check your fuse. could have gone bad or gotten damaged.
swannco is offline   Reply With Quote
Old 08-04-2007, 10:11 PM   #10
Tech Adept
 
Join Date: Feb 2007
Posts: 240
Default

yea that charger is a POS .... for some reason the two fueses they gave me in the box Blew and i bought more 7.5 amp fuses(the eact same) and blew 5 of those , so im just giving up with this charger and gonna get the intelli peak seeing that it does 1-4 amps not just 1,2,4 amps....thnaks for eveyones help
Hpimichael is offline   Reply With Quote
Old 08-04-2007, 10:34 PM   #11
Tech Adept
 
Join Date: Sep 2006
Posts: 187
Default Charger

Word of advice, get the Intellipeak ICE, get that and you'll never need another charger.
_pilot_ is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 03:05 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net