R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 07-18-2007, 06:00 AM   #1
Tech Addict
 
Superkarter's Avatar
 
Join Date: Aug 2005
Location: Scarborough Australia
Posts: 630
Trader Rating: 2 (100%+)
Default Charger Problems

I have a Eagle Racing CDC Version 6.0/b Charger and when I plug a battery on to it after connecting it to the power supply, it shuts the power supply off like itís a short. If I connect the battery to the charger before turning the power supply on it turns on and appears normal, but when you start charging on the charge screen the mAh counter doesnít start counting and the battery voltage doesnít change.

Does anyone have any ideas or has anyone come across this before

Thanks
Superkarter is offline   Reply With Quote
Old 07-18-2007, 07:42 AM   #2
Tech Master
 
Xanavi_R34's Avatar
 
Join Date: Jun 2006
Location: TAMIYA WORLD
Posts: 1,550
Trader Rating: 7 (100%+)
Default

Quote:
Originally Posted by Superkarter View Post
I have a Eagle Racing CDC Version 6.0/b Charger and when I plug a battery on to it after connecting it to the power supply, it shuts the power supply off like itís a short. If I connect the battery to the charger before turning the power supply on it turns on and appears normal, but when you start charging on the charge screen the mAh counter doesnít start counting and the battery voltage doesnít change.

Does anyone have any ideas or has anyone come across this before

Thanks
this you should remember... never use your batteries as power supply (to power up your charger or else)... I think one of your fuses exploded already, kindly check fuses and change them if necessary... your charger will really on when you plug first the battery but this can damage your charger, so please, as much as possible, never plug in the batts first...
Xanavi_R34 is offline   Reply With Quote
Old 07-18-2007, 07:51 AM   #3
Tech Regular
 
GymBeam's Avatar
 
Join Date: Mar 2007
Location: Losi|Novak|MuchMore
Posts: 434
Trader Rating: 4 (100%+)
Default

what power supply is it? not a computer PS is it???


try powering your charger with your 12v car battery.
GymBeam is offline   Reply With Quote
Old 07-18-2007, 08:14 AM   #4
Tech Master
 
Xanavi_R34's Avatar
 
Join Date: Jun 2006
Location: TAMIYA WORLD
Posts: 1,550
Trader Rating: 7 (100%+)
Default

yeah, also kindly check the input of your charger...
Xanavi_R34 is offline   Reply With Quote
Old 07-18-2007, 04:55 PM   #5
Tech Master
 
nikkiesteban's Avatar
 
Join Date: Apr 2005
Posts: 1,649
Trader Rating: 5 (100%+)
Send a message via Yahoo to nikkiesteban
Default

same thing happened to my CDC Version 6.0/b.. it doesnt charge.. but can discharge..
nikkiesteban is offline   Reply With Quote
Old 08-19-2007, 05:48 PM   #6
Tech Master
 
nikkiesteban's Avatar
 
Join Date: Apr 2005
Posts: 1,649
Trader Rating: 5 (100%+)
Send a message via Yahoo to nikkiesteban
Default

did anyone figured out why did this thing happened???
it doesn't charge any the counter for mah doesn't count and the voltage isn't increasing.. so it does not put any charge in the batts.. but the discharge function is working...
__________________
hello miss, puwede pa bind?
nikkiesteban is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Duratrax Ice Charger Problems Associated-08 Electric Off-Road 10 04-05-2008 09:34 AM
Much More Cellmaster Charger Problems noline Electric On-Road 0 02-18-2008 07:25 PM
Charger Problems After Getting Deans waterblast02 Electric On-Road 9 06-28-2006 05:39 PM
Please help. Battery charger problems. J_ROD48 Rookie Zone 4 05-22-2006 09:02 PM
Charger Problems Need Help NoahTheBoa Rookie Zone 5 01-23-2006 09:46 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 05:33 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net