R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Closed Thread
 
Thread Tools Search this Thread
Old 04-07-2007, 10:11 AM   #1
Tech Initiate
 
Join Date: Apr 2007
Posts: 30
Default LRP Sucks

To All,
I have had a really bad experience with LRP. Back in January I decided to go brushless and bought the new sphere 2007 ($200.00). When I first ran it at the track (Planet RC) the car would only go when I gave it a push start, but it was getting the signal from my radio because the green light was flashing when I hit the gas. After trying numerous motors and trouble shooting the problem, the conclusion was made (read that Mike Blackstock had this same problem in a big race) that it was the speed controller. I immediately sent it back to AE (first week of Feb).

Finally, we roll into the month of March and no word on speed contoller. I call the Team AE number several times and leave messages with the LRP service department asking for a follow up on the speedo, I sent emails as well and received no return call or message (I do understand they had a week where they moved). I finally get dialed into someone named Brad who says that he will help me out with my problem from here on out. I explained my frustration to him and felt I was being pushed off by the service team. He says "the service team says they sent you an email let me look for it in the outbox". I said that I have not received an email and sure enough he can not find an email to me in their email outbox. He couldn't give me any idea of when the speed controller would be returned as the California does not fix them, they just ship the broken ones to Germany and wait for new ones to come. I said that if they couldn't fix it within a couple of weeks, just send it back and I would be happy to buy a Novak. I had talked to Evan at Stormer Hobbies about the situation and he was happy to issue me a refund. Brad assured me that the next batch of speed controllers were in US Customs and once they reached that point, it usually isn't more then a few days. I agreed to wait on them to come, what is a few more days after waiting two months??

So, I finally get the package in the mail from Team AE this monday. I am excited to start racing again after 3 months off. I open up the package and it is my broken speed contoller returned!! The slip says "asked for spher back so he could, get money back from tower and purchase a novak". They could not even spell Sphere correctly. So here I am on April 7th with my bunk speed controller back after 3 1/2 months after my purchase.

I am in the wrong here to be p**d? It isn't so much the wait, but the lack of effort and response from LRP on this. I spend $200.00 and I am the bad customer?? I have never had problems with LRP products before this, I a lot of other LRP equipment. However, I hope that this story has influence on your purchase of speed controllers that are not made or even serviced in the US for that matter.

Thanks for listening,

Ryan McBee
[email protected]
Ryan McBee is offline  
Old 04-07-2007, 10:18 AM   #2
Tech Legend
 
Wild Cherry's Avatar
 
Join Date: Aug 2001
Location: TRCR Modified Driver
Posts: 22,595
Default

If your in between shipments from Lrp ...
You will have to be more patient because if they do not have a extra ESC to hand out for warranty work, you will have to wait a while ....

Everyone is treated the same....

should of waited .....
and
that`s your mistake .......

Funny, a fresh shipment of ESC`s
came in two month`s ago .
I got my Sphere repaired . I don`t understand how your`s did`nt get taken care of ....
__________________
Any driver can copy a great set up, a Champion however will steal it .
If Jesus returned as a Rc car he be a Rc10 B5M
George W. Cherry
Wild Cherry is offline  
Old 04-07-2007, 10:22 AM   #3
Tech Master
 
sportpak's Avatar
 
Join Date: Oct 2006
Location: Ft Wayne, IN
Posts: 1,314
Trader Rating: 26 (100%+)
Default

Too many stories like that is why I'll always buy Orange. At the top level they're all the same in my opinion. I have a GTB that's been flawless. I still have some Cyclones that get beat on pretty regularly during offroad that don't break a sweat.
__________________
-Tamiya TA05-R - Tamiya M05 - Summit Raceway Ft. Wayne, IN

www.summitrcraceway.com
sportpak is offline  
Old 04-07-2007, 10:23 AM   #4
Tech Apprentice
 
Torsp's Avatar
 
Join Date: Mar 2007
Location: San Diego, CA.
Posts: 67
Trader Rating: 12 (100%+)
Default

Harsh lesson learned there, go with Mamba 5700. Superior product and service.
Torsp is offline  
Old 04-07-2007, 10:42 AM   #5
Tech Master
 
pcar951's Avatar
 
Join Date: Dec 2005
Location: Cow Town
Posts: 1,706
Trader Rating: 19 (100%+)
Default

Just for the sake of comparison.....I blew up a new GTB, shipped it back to Novak and had a replacement ESC in 2 weeks. All I did was fill out the return form and drop it in the mail. This was the first time a Novak has ever failed for me and I've probably had 20 of their ESCs. Nice to know Novak's got your back if you do have a problem.
__________________
Jim Chapman
PM Hobbycraft | RCAmerica | Xray | Hudy
pcar951 is offline  
Old 04-07-2007, 10:52 AM   #6
Tech Adept
 
losi nut's Avatar
 
Join Date: Nov 2006
Location: Parkton (just south of Fayetteville), NC
Posts: 185
Default

Last summer I bought a QC2 and broke the on/off switch wire at the case, sent it in for repair thru my LHS and was told "for $48 they would send me a refurbished one" . It came in I installed it and on a test run in a parking lot at part throttle, it melted itself into goo. No it didn't short out on anything, it was securely mounted. It shorted internally. End of my dealings with lrp esc's.
losi nut is offline  
Old 04-07-2007, 11:02 AM   #7
Tech Master
 
losi guy's Avatar
R/C Tech Elite Subscriber
 
Join Date: Aug 2006
Location: Wisconsin
Posts: 1,258
Trader Rating: 38 (100%+)
Send a message via ICQ to losi guy
Default

I run LRP and Novak. Like them both. I only had one go out on me and that was the LRP Sphere, it was under warranty so i sent in and i had a new one in about 1 month so it wasn't bad considering i had a back up speedo. If you don't have the time to wait for the Lrp stuff to get fixed and sent back, i would get a novak.
__________________
Spektrum | Avid | DE Racing | Tekno
losi guy is offline  
Old 04-07-2007, 11:05 AM   #8
Tech Master
 
Join Date: Jan 2007
Location: Oklahoma City
Posts: 1,767
Trader Rating: 49 (95%+)
Send a message via Yahoo to loopedout
Default

Lmao, Ill have to say I love my LRP controller but its taking them a long long time, over a month to get one of mine back to me. Called them yesterday and its finally on its way to my home. I think all companies have thier faults just in different areas. Nice thread though, brings back memories
__________________
Caster Racing USA Dirt Oval
Hyperdrive
Tekin
THD Custom R/C Products/Team Holy Rollers/Team Terribles
loopedout is offline  
Old 04-07-2007, 11:05 AM   #9
Tech Regular
 
Join Date: Jan 2004
Location: Durham, NC
Posts: 313
Default

Had a LRP QC2, would reset itself after a run on my 1/12th and I had to go through and do a complete setup on the esc and this would happenen every 2nd or 3rd run. Been running Novak since mid 80's and the one time I ever needed service it was my faul and for a very low price they fixed it and had it back in about 2 weeks. Now I dont feel the need to try any other esc.
tarheelquality is offline  
Old 04-07-2007, 11:08 AM   #10
Tech Master
 
veecee's Avatar
 
Join Date: Sep 2001
Posts: 1,439
Trader Rating: 34 (100%+)
Default

Maybe the title should have read AE customer service sucks?
__________________
SMOKEM --- XPRESS --- MONTECH --- SRT
veecee is offline  
Old 04-07-2007, 11:09 AM   #11
Tech Addict
 
Join Date: Dec 2004
Location: MI
Posts: 574
Trader Rating: 2 (100%+)
Default

I bought a 2007 edition and on the first run the alu cover fell out. I sent it back in mid Feb. After 3 weeks I asked for an update by email and I've got a response saying they are waiting for the replacement. I thought OK I think a simple cleaning and some glue would fix the problem but it is their call. Finally after 6+ weeks the package showed up and in there my old ESC fixed. I have no problem with that but what takes 6 weeks in that is beyond me. This is my only ESC and I mainly race TC on carpet so they pretty much took 6 weeks of the winter season for nothing... I should have just cleaned it myself and reglue it. Lesson learned but the bitter aftertaste will stay.
cvt01 is offline  
Old 04-07-2007, 11:16 AM   #12
Tech Addict
 
Iceracer's Avatar
 
Join Date: Feb 2006
Location: Canada
Posts: 656
Trader Rating: 1 (100%+)
Default

Is there any issue with LRP quality, or is it only the North American warranty service through AE?
Iceracer is offline  
Old 04-07-2007, 11:21 AM   #13
Tech Addict
 
Join Date: Dec 2004
Location: MI
Posts: 574
Trader Rating: 2 (100%+)
Default

I think both.
cvt01 is offline  
Old 04-07-2007, 11:28 AM   #14
Tech Legend
 
Wild Cherry's Avatar
 
Join Date: Aug 2001
Location: TRCR Modified Driver
Posts: 22,595
Default

Quote:
Originally Posted by cvt01
I think both.
Not true !
The 2007 Competition is the best of the best ....

Reliable and smooth...
Nobody can touch it...
__________________
Any driver can copy a great set up, a Champion however will steal it .
If Jesus returned as a Rc car he be a Rc10 B5M
George W. Cherry
Wild Cherry is offline  
Old 04-07-2007, 11:31 AM   #15
Tech Addict
 
Join Date: Dec 2004
Location: MI
Posts: 574
Trader Rating: 2 (100%+)
Default

If there wasn't any problem with LRP products in the first place nobody would have bad experience with AE service.
cvt01 is offline  
Closed Thread

Similar Threads
Thread Thread Starter Forum Replies Last Post
this sucks joe_jenkins Georgia Racing 4 06-11-2008 05:39 AM
sucks big time rc31cli Georgia Racing 1 05-11-2008 07:38 PM
Sucks be this kid roadrashracing Chat Lounge 37 03-22-2008 05:06 PM
RCMart sucks charlessito Buyer/Seller dispute and Feedback discussion forum 5 09-07-2007 08:18 AM
LRP Sucks Ryan McBee Electric Off-Road 24 04-08-2007 02:55 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 11:31 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net