Go Back  R/C Tech Forums > General Forums > Electric On-Road
LRP Speed Comp, 3PK, Spektrum Pro - Drag Brake Problem >

LRP Speed Comp, 3PK, Spektrum Pro - Drag Brake Problem

LRP Speed Comp, 3PK, Spektrum Pro - Drag Brake Problem

Old 02-05-2007, 10:43 AM
  #1  
Tech Champion
Thread Starter
iTrader: (38)
 
Join Date: Oct 2005
Location: Cincinnati, OH
Posts: 5,360
Trader Rating: 38 (100%+)
Default LRP Speed Comp, 3PK, Spektrum Pro - Drag Brake Problem

Im having an occassional problem with my drag brake. When I have the car on a stand and hit the throttle 1 out of maybe 5 times the drag brake wont engage when I put the trigger back to nuetral. Any ideas what might cause that? Im using an LRP Speed Comp ESC, Futaba 3pk, and Spektrum Pro. I have the cap on the spektrum.
or8ital is offline  
Old 02-06-2007, 04:50 AM
  #2  
Tech Regular
 
Join Date: Jul 2004
Location: Kuala Lumpur Malaysia
Posts: 278
Default

could it be that your drag brake is just too small for you to feel the difference? I run so many motors and to tell you the truth, BL with rating higher than 6.5, the drag brake is just too small.
azmio is offline  
Old 02-06-2007, 07:03 AM
  #3  
Tech Champion
Thread Starter
iTrader: (38)
 
Join Date: Oct 2005
Location: Cincinnati, OH
Posts: 5,360
Trader Rating: 38 (100%+)
Default

Its not a feel thing. I can see it when I have the car on a car stand.
or8ital is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.