Go Back  R/C Tech Forums > General Forums > Electric On-Road
whats wrong with my tc3 >

whats wrong with my tc3

whats wrong with my tc3

Reply

Old 09-18-2006, 05:34 PM
  #1  
Tech Initiate
Thread Starter
 
Tc3Venom's Avatar
 
Join Date: Sep 2006
Posts: 49
Default whats wrong with my tc3

its been running perfect, better than ever latly till today i took it out and it ran with crap. no power, going way slower than normal and steering kept going out it would get stuck turning one way and id drive around in circles for a few secs then it would be fine again. whats up? i think its just an old pos all the stuff on its super old except for motor and batterys...but i dont get the loss of power part! im tired of problems at least im building a new up to date car.
Tc3Venom is offline  
Reply With Quote
Old 09-18-2006, 05:39 PM
  #2  
Tech Master
 
Join Date: Aug 2005
Location: Michigan
Posts: 1,049
Default

Try checking the brushes in the motor. Are you sure the battery had a good charge?
John Warner is offline  
Reply With Quote
Old 09-18-2006, 06:10 PM
  #3  
Tech Initiate
Thread Starter
 
Tc3Venom's Avatar
 
Join Date: Sep 2006
Posts: 49
Default

im pretty sure the brushes are fine its only been ran about 4 times on the new motor but ill check them. the batts were charged like 3 days ago...do they lose juice that quick(they were in a basement, kinda cool temp)?
Tc3Venom is offline  
Reply With Quote
Old 09-18-2006, 06:21 PM
  #4  
Tech Apprentice
 
Join Date: Jun 2005
Posts: 83
Default

.

Last edited by thommo09; 07-03-2018 at 04:46 PM.
thommo09 is offline  
Reply With Quote
Old 09-18-2006, 06:35 PM
  #5  
Tech Elite
iTrader: (15)
 
James khoo's Avatar
 
Join Date: Jun 2006
Location: Malaysia
Posts: 2,794
Trader Rating: 15 (100%+)
Default

Hi,what type of charger your using?it best that use the battery just after charging,the voltage will stay at it top,battery will lost it's power every 5 minute 0.2v.hope this help.

Cheers
James khoo is offline  
Reply With Quote
Old 09-18-2006, 06:43 PM
  #6  
Tech Initiate
Thread Starter
 
Tc3Venom's Avatar
 
Join Date: Sep 2006
Posts: 49
Default

yea i have a new batt pack and i tried a few. Im using a dynamite peak charger.
Tc3Venom is offline  
Reply With Quote
Old 09-18-2006, 06:50 PM
  #7  
Tech Elite
iTrader: (15)
 
James khoo's Avatar
 
Join Date: Jun 2006
Location: Malaysia
Posts: 2,794
Trader Rating: 15 (100%+)
Default

Oh,don't forget to check you connections(battery,ESC,motor and receiver)
I had run my Tc3 for years,the only problem i face is too heavy when used with brushless system(1636 grams)
James khoo is offline  
Reply With Quote
Old 09-18-2006, 07:10 PM
  #8  
Tech Elite
 
dodo's Avatar
 
Join Date: Mar 2005
Location: the archipelago
Posts: 3,095
Default

also make sure that it's not a false peak detected.
dodo is offline  
Reply With Quote
Old 09-18-2006, 08:00 PM
  #9  
Tech Initiate
Thread Starter
 
Tc3Venom's Avatar
 
Join Date: Sep 2006
Posts: 49
Default

well i cant pinpoint it but since everything is pretty old i think im going to update it since i already got a new motor. Ill totally clean it, rebuilt some stuff, and buy new servo, receiver, and speed control
Tc3Venom is offline  
Reply With Quote
Old 09-18-2006, 08:06 PM
  #10  
Tech Initiate
Thread Starter
 
Tc3Venom's Avatar
 
Join Date: Sep 2006
Posts: 49
Default

well i cant pinpoint it but since everything is pretty old i think im going to update it since i already got a new motor. Ill totally clean it, rebuilt some stuff, and buy new servo, receiver, and speed control
Tc3Venom is offline  
Reply With Quote
Old 09-19-2006, 04:14 AM
  #11  
Tech Regular
 
Join Date: Apr 2006
Posts: 297
Default

As far as your steering sticking, take apart your steering rack and clean the goo off it. It's a common thing with that style of steering rack. Also...if you have bearings in your rack, switch to bushings. Bearings are useless in the TC3 steering rack.
Stampede is offline  
Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service