R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 09-11-2006, 11:49 AM   #1
Tech Fanatic
 
Join Date: Apr 2006
Location: socal
Posts: 858
Trader Rating: 52 (98%+)
Default spektrum glitch with burshless system

My spektrum system glitches when I run brushless system in my electric. Does anyone know any solution to this? Thanks in advance.
straightaway is offline   Reply With Quote
Old 09-11-2006, 01:01 PM   #2
Tech Master
 
Kings Kid's Avatar
 
Join Date: Sep 2005
Location: sw lower michigan
Posts: 1,681
Trader Rating: 35 (100%+)
Default

What are you driving it in? What surface are you driving on?Did you buy it new or used and how long have you owned it? With these questions answered we can help you with a solution
Kings Kid is offline   Reply With Quote
Old 09-12-2006, 01:36 AM   #3
Tech Fanatic
 
Join Date: Apr 2006
Location: socal
Posts: 858
Trader Rating: 52 (98%+)
Default

they are less than 1 yr old. I used them on my mrx4 on road going 70 mph no problem.

I am using them on xxx cr buggy, running at socal.
straightaway is offline   Reply With Quote
Old 09-12-2006, 07:55 PM   #4
Tech Addict
 
swopemike's Avatar
 
Join Date: Jun 2006
Posts: 526
Trader Rating: 6 (100%+)
Default Spektrum/Brushless Glitches

See the spektrum forum as they have a lot of info on this issue.

It is likely to be related to voltage drop with the massive power uptake of BL. Esp. heavier offroad vehicles are prone to this like my specially weighted T3 for oval racing. Capacitor is a likely fix. This assumes the issue is nothing broken in the unit. Also, you can always call Novak. Good tech support, although you might need to be on the phone a bit to get through.
swopemike is offline   Reply With Quote
Old 09-12-2006, 08:01 PM   #5
Tech Addict
 
swopemike's Avatar
 
Join Date: Jun 2006
Posts: 526
Trader Rating: 6 (100%+)
Default PS I meant spektrum THREAD not forum

PS I meant spektrum THREAD not forum
swopemike is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Spektrum Glitch problems overflow Radio and Electronics 4 05-20-2008 08:17 PM
new burshless systems? streetracer745 Electric Off-Road 19 11-07-2007 03:25 PM
spektrum glitch? tenpins77 Electric Off-Road 22 08-30-2007 07:03 PM
WTT- 1/18 w/burshless system! I have LOADS Stevietd14 R/C Items: Wanted to Buy 0 11-12-2006 05:51 PM
Spektrum - GTB Glitch/shut down Takt Electric On-Road 13 03-22-2006 08:33 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 06:18 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net