Go Back  R/C Tech Forums > General Forums > Electric On-Road
Team Losi JRXS Type-R > Team Losi JRXS Type-R
Like Tree1Likes

Team Losi JRXS Type-R


Old 07-25-2008, 03:05 AM
  #7696  
Tech Addict
 
Join Date: Dec 2004
Posts: 517
Default

I'm interested to get JRXS R, do you know if I can use SMC4000 or SMC5000 in JRXS R?
ioxqq is offline  
Reply With Quote
Old 07-25-2008, 06:28 AM
  #7697  
Tech Master
iTrader: (11)
 
mojoman's Avatar
 
Join Date: Jan 2006
Location: Straight, No Chaser
Posts: 1,995
Trader Rating: 11 (100%+)
Default

SMC 4000s fit without any modification.
mojoman is offline  
Reply With Quote
Old 07-25-2008, 04:57 PM
  #7698  
Tech Regular
iTrader: (5)
 
MaxSp97's Avatar
 
Join Date: Aug 2007
Location: Camarino
Posts: 458
Trader Rating: 5 (100%+)
Default

Horizon is shipping Steel Lipo Tray.
I just got 2 came today.
Lee! call me.

Calvin
MaxSp97 is offline  
Reply With Quote
Old 07-25-2008, 05:30 PM
  #7699  
Tech Elite
iTrader: (16)
 
rocketron's Avatar
 
Join Date: Jun 2003
Location: palm desert
Posts: 2,268
Trader Rating: 16 (100%+)
Default

Losi LiPo fits as well
rocketron is offline  
Reply With Quote
Old 07-26-2008, 10:22 AM
  #7700  
Tech Elite
iTrader: (7)
 
yodace's Avatar
 
Join Date: Oct 2001
Location: Caleb
Posts: 2,516
Trader Rating: 7 (100%+)
Default

whats a good asphalt set up?
yodace is offline  
Reply With Quote
Old 07-26-2008, 03:31 PM
  #7701  
Tech Addict
iTrader: (1)
 
tim fry's Avatar
 
Join Date: Aug 2004
Location: Kent UK
Posts: 533
Trader Rating: 1 (100%+)
Default

Originally Posted by yodace View Post
whats a good asphalt set up?
Mine is nearly there so I will post it when I have tested my recent changes.

Try the kit setup first and work from there.
tim fry is offline  
Reply With Quote
Old 07-27-2008, 09:10 PM
  #7702  
Tech Elite
iTrader: (20)
 
metalracer2's Avatar
 
Join Date: Nov 2007
Location: Riverside, CA
Posts: 2,548
Trader Rating: 20 (100%+)
Default

man i finally got my car to hook up, man when it hooks up it's fast
i added some sway bars and it helped with my corner entrance and my rear end traction.
it was good knowing that when i left the track with the WIN that my car was handling good
metalracer2 is offline  
Reply With Quote
Old 07-29-2008, 09:39 AM
  #7703  
Tech Master
iTrader: (11)
 
mojoman's Avatar
 
Join Date: Jan 2006
Location: Straight, No Chaser
Posts: 1,995
Trader Rating: 11 (100%+)
Default

Regarding the steel lipo tray. Has anybody experienced the chassis flex decrease when using the tray? I haven't run it yet but at first glance it was pretty stiff.
mojoman is offline  
Reply With Quote
Old 07-29-2008, 01:56 PM
  #7704  
Tech Addict
iTrader: (1)
 
tim fry's Avatar
 
Join Date: Aug 2004
Location: Kent UK
Posts: 533
Trader Rating: 1 (100%+)
Default

Originally Posted by mojoman View Post
Regarding the steel lipo tray. Has anybody experienced the chassis flex decrease when using the tray? I haven't run it yet but at first glance it was pretty stiff.

Not had any issues with mine. It is stiff but I cant see it making a massive difference.
tim fry is offline  
Reply With Quote
Old 07-29-2008, 06:56 PM
  #7705  
Tech Elite
iTrader: (41)
 
nitrobeast's Avatar
 
Join Date: Apr 2006
Location: Colonia, NJ
Posts: 2,346
Trader Rating: 41 (100%+)
Default

Originally Posted by metalracer2 View Post
man i finally got my car to hook up, man when it hooks up it's fast
i added some sway bars and it helped with my corner entrance and my rear end traction.
it was good knowing that when i left the track with the WIN that my car was handling good
Same with me..This past Saturday the car felt great!! In the last 3 weeks i went from just getting 18 laps to just getting 20 laps.. That only happened once but who's counting? I got 19 laps, 3 out of 4 races, and 20 once...My driving has become a lot better and im sure that help, but the car feels great..
nitrobeast is offline  
Reply With Quote
Old 07-29-2008, 07:02 PM
  #7706  
Tech Fanatic
 
RobS's Avatar
 
Join Date: Jul 2004
Location: Chatham, Ontario
Posts: 900
Default

I just put my Type R back together tonight, hopefully this time I will have better luck with it. If all goes well I might take all of my brushless stuff out of my current primary car and throw it in the Type R for the fall season.
RobS is offline  
Reply With Quote
Old 07-29-2008, 07:17 PM
  #7707  
Tech Elite
iTrader: (41)
 
nitrobeast's Avatar
 
Join Date: Apr 2006
Location: Colonia, NJ
Posts: 2,346
Trader Rating: 41 (100%+)
Default

Originally Posted by mtveten View Post


In general the rear feels too planted at corner entry and onpower transitions and just pushes the front out of the corner. Weight is 50/50 front to back.

Mark
Let me start by saying im not a pro at tuning a car at all, and might be wrong saying this.
Would a little less drop in the front help? How about rear? How about moving the rear shocks to the center, number 2 or even 3? Try some 40-45 weight oil in the rear? Again im not a pro and trying to learn. This is something i would try if i had your issue.
nitrobeast is offline  
Reply With Quote
Old 07-30-2008, 10:08 AM
  #7708  
Tech Addict
iTrader: (8)
 
RedRocketRacing's Avatar
 
Join Date: Jan 2004
Location: Woodinville,Wa
Posts: 646
Trader Rating: 8 (100%+)
Default

Anybody run the Jaco Blues on there car? I am looking for some input as to why my car was so bad on these tires. They worked on the first run and not on the second, I couldn't get more than 5 minutes on them. My setup was pretty standard to what others have been running on asphalt. High roll center in the front, low in the rear, 17.5 front, 12.5 rear, and so on. The car would enter the corner alright, and than push in the middle and than be loose on exit. And only on the second run. Any body else run these?

RedRocket
Andres Hagen
RedRocketRacing is offline  
Reply With Quote
Old 07-30-2008, 10:41 AM
  #7709  
Tech Elite
iTrader: (5)
 
Yeti35's Avatar
 
Join Date: Sep 2004
Location: SL, UT
Posts: 2,804
Trader Rating: 5 (100%+)
Default

Originally Posted by RedRocketRacing View Post
Anybody run the Jaco Blues on there car? I am looking for some input as to why my car was so bad on these tires. They worked on the first run and not on the second, I couldn't get more than 5 minutes on them. My setup was pretty standard to what others have been running on asphalt. High roll center in the front, low in the rear, 17.5 front, 12.5 rear, and so on. The car would enter the corner alright, and than push in the middle and than be loose on exit. And only on the second run. Any body else run these?

RedRocket
Andres Hagen
Low bite or medium? I am running 15 spring in the rear with 35wt and longest camber link. I run lowbite tracks though. I have not run any of the Jaco blues but have read that you need more camber for them to work properly. I am guess because of the lower side wall.
Yeti35 is offline  
Reply With Quote
Old 07-30-2008, 11:00 AM
  #7710  
Tech Elite
iTrader: (32)
 
YmeBP's Avatar
 
Join Date: Aug 2007
Posts: 2,927
Trader Rating: 32 (100%+)
Default

Originally Posted by RedRocketRacing View Post
Anybody run the Jaco Blues on there car? I am looking for some input as to why my car was so bad on these tires. They worked on the first run and not on the second, I couldn't get more than 5 minutes on them. My setup was pretty standard to what others have been running on asphalt. High roll center in the front, low in the rear, 17.5 front, 12.5 rear, and so on. The car would enter the corner alright, and than push in the middle and than be loose on exit. And only on the second run. Any body else run these?

RedRocket
Andres Hagen
Larry, tell him about blues at Jackson hahaha .
YmeBP is offline  
Reply With Quote

Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Terms of Service