R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 07-01-2006, 11:29 PM   #1
Tech Fanatic
 
dynasty's Avatar
 
Join Date: Oct 2003
Location: New Jersey
Posts: 834
Trader Rating: 27 (100%+)
Default LRP Pulsar compeition charger Problem! anyone else?

My charger can only charge at .6 amps.. i dont know what happened and i didnt let the smoke out. Supply volts is 13VDC and the internal fuse is good.
The display flashes "Inp-low" where the amperage is indicated. Has anyone experienced this problem? Help!
thanks in advance
dynasty is offline   Reply With Quote
Old 07-01-2006, 11:57 PM   #2
Tech Elite
 
Yeti35's Avatar
 
Join Date: Sep 2004
Location: SL, UT
Posts: 2,804
Trader Rating: 5 (100%+)
Default

I have experienced it once when using a crappy PS. But I have not seen it since buyin my 25amp PS from Radio Hack.
__________________
JRXS Type R, I have four of them!! ;) ( Yes, I still have them!!)And racing one of them again!!
22 3.0SR
22T 2.0 w/ Exotech chassis
Yeti35 is offline   Reply With Quote
Old 07-01-2006, 11:57 PM   #3
Tech Apprentice
 
Join Date: May 2006
Posts: 58
Default

when it says input low the power supply cant punch out atleast 12v DC power. time to change P/S unit
skamolly is offline   Reply With Quote
Old 07-02-2006, 02:27 AM   #4
Tech Regular
 
Join Date: Jul 2004
Location: Kuala Lumpur Malaysia
Posts: 278
Default

both my pulsar and pulsar 2 will display that error message if I charge my transmitter battery. No problem at all for 6 cells nimh or nicd. If your power supply has voltage selector, crank it up to the max.
azmio is offline   Reply With Quote
Old 07-02-2006, 08:40 AM   #5
Tech Fanatic
 
dynasty's Avatar
 
Join Date: Oct 2003
Location: New Jersey
Posts: 834
Trader Rating: 27 (100%+)
Default

i just realized that the battery volts and the power supply volts are reading in the wrong position. strange.. when i try charging using the "Matching" mode, everything works fine. supply voltage is 13.8Vdc.
umh... strange.
dynasty is offline   Reply With Quote
Old 07-02-2006, 08:42 PM   #6
Tech Master
 
fast-ho-cars's Avatar
 
Join Date: Sep 2003
Location: it's a dry heat
Posts: 1,058
Trader Rating: 3 (100%+)
Default

take your charger and hook it up to your car battery and charge a pack, if it works fine then you need a better power supply...if it don't, ship your charger for repair
fast-ho-cars is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
LRP Pulsar compeition charger dynasty R/C Items: For Sale/Trade 0 08-08-2006 09:27 PM
LRP Pulsar Competition Charger Problem! 190mph Electric On-Road 5 11-10-2005 07:58 AM
Pulsar reseting problem rcguy2477 Electric On-Road 16 03-29-2005 08:49 AM
LRP pulsar competition problem raceblast Electric On-Road 12 12-28-2004 10:11 AM
LRP Pulsar Comp - Question / Problem? rctoyguy Electric On-Road 6 09-14-2004 02:06 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 01:38 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net