Plz Help Me

Reply

Old 06-03-2006, 05:15 PM
  #1  
Tech Fanatic
Thread Starter
iTrader: (3)
 
Join Date: Dec 2005
Posts: 903
Trader Rating: 3 (100%+)
Default Plz Help Me

OK guys i have just gotten back into mod right and im havign a bit of a problem.
First im running a xray fk 05 and a futaba 9451 digital servo and a 9x2 cobalt motor. Ok when i go slow and straight my car goes straight forward but when im goign around the staright my car sometimes torque steers and i loose a bit of control.
So how do you fix this plz help me

Thanks in advance
jamie
jamie814340 is offline  
Reply With Quote
Old 06-03-2006, 05:30 PM
  #2  
Registered User
 
Join Date: May 2006
Location: Philly
Posts: 31
Default

Torque steer is symbolic of shaft driven vehicles.
Express_Guy is offline  
Reply With Quote
Old 06-03-2006, 05:40 PM
  #3  
Tech Master
iTrader: (1)
 
berger's Avatar
 
Join Date: Aug 2003
Location: Bathurst, Australia
Posts: 1,149
Trader Rating: 1 (100%+)
Default

Check your car for tweak, check your droop and shock lengths also..
berger is offline  
Reply With Quote
Old 06-05-2006, 08:57 PM
  #4  
Tech Master
iTrader: (24)
 
pinggoy's Avatar
 
Join Date: Mar 2006
Location: WBP Florida
Posts: 1,263
Trader Rating: 24 (96%+)
Default

make sure your arms, knuckles are moving freely... cause if there is binding somewhere in your car it make your car handles odd...
pinggoy is offline  
Reply With Quote
Old 06-05-2006, 09:05 PM
  #5  
Tech Master
 
Join Date: Aug 2005
Location: Michigan
Posts: 1,049
Default

Originally Posted by Express_Guy
Torque steer is symbolic of shaft driven vehicles.
I thought the FK05 was belt driven, right?
John Warner is offline  
Reply With Quote
Old 06-06-2006, 08:08 AM
  #6  
Tech Elite
iTrader: (86)
 
RaceAce701's Avatar
 
Join Date: Jan 2006
Location: Carbondale, Pa
Posts: 3,017
Trader Rating: 86 (99%+)
Default

Ya it is i dont no wat he was thinkin
RaceAce701 is offline  
Reply With Quote
Old 06-06-2006, 08:51 AM
  #7  
Tech Addict
iTrader: (4)
 
Tsquare's Avatar
 
Join Date: Sep 2004
Location: San Diego
Posts: 618
Trader Rating: 4 (100%+)
Default

Originally Posted by jamie814340
OK guys i have just gotten back into mod right and im havign a bit of a problem.
First im running a xray fk 05 and a futaba 9451 digital servo and a 9x2 cobalt motor. Ok when i go slow and straight my car goes straight forward but when im goign around the staright my car sometimes torque steers and i loose a bit of control.
So how do you fix this plz help me

Thanks in advance
jamie
It sounds like a tweak issue. Check tweak, check for no bent hinge pins, shock shafts etc, check for a free moving suspension, check your servo saver. Good Luck.
Tsquare is offline  
Reply With Quote
Old 06-06-2006, 07:30 PM
  #8  
Tech Fanatic
Thread Starter
iTrader: (3)
 
Join Date: Dec 2005
Posts: 903
Trader Rating: 3 (100%+)
Default

hey guys thanks for your replys and i found why it was doing it because my servo horn was stripped and it was stickign so its all fixed
jamie814340 is offline  
Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service