Go Back  R/C Tech Forums > General Forums > Electric On-Road
XPRESS Execute XQ2S >

XPRESS Execute XQ2S

Like Tree194Likes

XPRESS Execute XQ2S

Old 03-17-2022, 09:42 AM
  #376  
Tech Master
iTrader: (24)
 
Join Date: Sep 2014
Posts: 1,661
Trader Rating: 24 (100%+)
Default

Anyone have an issue with a steering knuckle not moving freely?
phatboislim is offline  
Old 03-17-2022, 12:27 PM
  #377  
Tech Regular
iTrader: (20)
 
Join Date: Dec 2007
Posts: 356
Trader Rating: 20 (100%+)
Default

Originally Posted by phatboislim View Post
Anyone have an issue with a steering knuckle not moving freely?
First thing, are you running the v2 c hubs?

Second, if you are, you might try lightly sanding the bottom of the steering knuckles to give them a little more room in the c hub.
phatboislim likes this.
timberline97 is offline  
Old 03-17-2022, 05:33 PM
  #378  
Tech Elite
 
Join Date: Sep 2004
Location: Kuala Lumpur, Malaysia
Posts: 3,337
Default

Originally Posted by phatboislim View Post
Anyone have an issue with a steering knuckle not moving freely?
Yup, I did. Had to sand down both my knuckles to get them to move freely
phatboislim likes this.
ntc3freak is online now  
Old 03-24-2022, 02:40 PM
  #379  
Tech Rookie
 
Join Date: Jan 2022
Location: Sompting
Posts: 10
Default Chassis Flex

I am just experimenting with front and rear chassis flex and wondering if any of you are playing around with this.

I note in the manual that there’s a med and low flex option for the front but I assume you can remove the chassis stiffener completely to give a high flex at the front?

Now that the asphalt track is warming up a bit outdoors I am going to add flex at the front and stiffen up the rear to try and get better on power initial turn in…

why is everyone else doing?
mr.si is offline  
Old 03-24-2022, 06:56 PM
  #380  
Tech Master
Thread Starter
 
moparSRT's Avatar
 
Join Date: Oct 2013
Location: Tampa Bay FL
Posts: 1,682
Default

Originally Posted by phatboislim View Post
Anyone have an issue with a steering knuckle not moving freely?
also check the ballend, the black ones tend to bind up the suspension a little, the grey ones are a great upgrade.
phatboislim likes this.
moparSRT is offline  
Old 03-24-2022, 07:58 PM
  #381  
Tech Elite
 
Join Date: Sep 2004
Location: Kuala Lumpur, Malaysia
Posts: 3,337
Default

I've found the grey ones to be quite an upgrade in terms of smoothness, but they seem to be quite brittle. I ordered a bunch to replace the kit ball cups, but one of them cracked after popping onto the ball stud. They also seem to need holding on to while adjusting the turnbuckles. My steering ones always seem to pop out of the balls when adjusting toe.

If I were to do it again I would have probably gotten Xray ball cups (and maybe even the ball studs). Other than the one cracked ball cup and some of them needing to be held to adjust turnbuckles, they're definitely an improvement over the stock ones.
ntc3freak is online now  
Old 03-28-2022, 03:03 PM
  #382  
Tech Addict
 
IslandBwoy's Avatar
 
Join Date: Nov 2004
Location: Orlando, FL
Posts: 620
Default

The xray ball cups do not work on the xpress platform. I learned this the hard way just a few weeks ago when I had to borrow a ball cup from an xray driver AND a ball joint to go with it. Xpress balls are bigger (no pun intended).
IslandBwoy is offline  
Old 03-31-2022, 10:10 AM
  #383  
Tech Regular
 
Join Date: Apr 2019
Posts: 439
Default Xpress battery mount

I broke one of the arms off my battery mount last Sunday. Would the X-ray battery arms (graphite) fit or have near the same bolt holes? I could get it complete or just the arms.
Xrayray is offline  
Old 04-16-2022, 10:00 PM
  #384  
Tech Apprentice
 
Join Date: Sep 2021
Posts: 95
Default XQ2S Leaking Differential Fluid

Hi All,
Thank you for the assistance!

I finished the XQ2S build, and all seemed fine, except the differential is leaking and spraying drops of differential fluid. I assume either one of the O-Rings is crimped or the gasket is torn.

The gasket material is very brittle and was already wrinkled when I installed it. Before I disassemble the differential would like to order parts; I assume I should get;
  1. Hiro Seiko Pure Silicone Diff Oil 60ml 5000cst $8.95 AUD
  2. Xpress XP-10184 XQ1 Silicone Gear Differential O-RING 5x2mm 10pcs $7.95 AUD
  3. Xpress XP-10183 XQ1 Silicone Gear Differential O-RING 25x1mm 10pcs $7.95 AUD
  4. Xpress XP-10179 Gear Differential Gasket 5pcs $7.95 AUD
I would appreciate any advice or suggestions; thank you! Cheers.
museguy is offline  
Old 04-16-2022, 10:49 PM
  #385  
Tech Regular
iTrader: (20)
 
Join Date: Dec 2007
Posts: 356
Trader Rating: 20 (100%+)
Default

I would check these out first.
Seals

and yes they do fit.
museguy likes this.
timberline97 is offline  
Old 04-17-2022, 03:10 AM
  #386  
Tech Elite
iTrader: (2)
 
gigaplex's Avatar
 
Join Date: Dec 2015
Location: Melbourne, VIC
Posts: 4,875
Trader Rating: 2 (100%+)
Default

Where is it leaking from? If it's coming out of the outdrives, check the o-rings. If it's the pulley seam, replace the gasket and make sure it's closed properly.
museguy likes this.
gigaplex is offline  
Old 04-17-2022, 10:18 AM
  #387  
Tech Apprentice
 
Join Date: Sep 2021
Posts: 95
Default

Originally Posted by gigaplex View Post
Where is it leaking from? If it's coming out of the outdrives, check the o-rings. If it's the pulley seam, replace the gasket and make sure it's closed properly.
Thank you gigaplex

It looks like it is coming from the pulley seam, I will order the new gasket and replace it. Cheers
museguy is offline  
Old 04-17-2022, 10:23 AM
  #388  
Tech Apprentice
 
Join Date: Sep 2021
Posts: 95
Default

Originally Posted by timberline97 View Post
I would check these out first.
Seals
and yes they do fit.
Thank you timberline97

I will added the X-Rings to the order. Cheers
museguy is offline  
Old 04-18-2022, 04:47 PM
  #389  
Tech Rookie
 
Join Date: Apr 2022
Posts: 1
Default

Hi everyone, I have just assembled the kit but I have a problem when I accelerate and while I turn the steering wheel vibrates the belt and the whole car. it's normal ?
ENiGMiST4 is offline  
Old 04-18-2022, 05:11 PM
  #390  
Tech Elite
iTrader: (2)
 
gigaplex's Avatar
 
Join Date: Dec 2015
Location: Melbourne, VIC
Posts: 4,875
Trader Rating: 2 (100%+)
Default

Originally Posted by ENiGMiST4 View Post
Hi everyone, I have just assembled the kit but I have a problem when I accelerate and while I turn the steering wheel vibrates the belt and the whole car. it's normal ?
At full steering lock, the stock driveshafts will cause some vibration. That might be what you're experiencing. The fix is to upgrade to the DCJ front axles.
trx-1racer and timberline97 like this.
gigaplex is offline  

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright © 2022 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.