R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 03-13-2006, 01:51 PM   #1
Tech Addict
 
Join Date: Mar 2006
Location: UK Stoke-on-Trent
Posts: 603
Send a message via MSN to TAMIYAMANUK
Default NOSRAM stealth charger problem

hi there guys

sorry about this but its another charger problem lol

but when i come to charge me cells my nosram stealth starts bleeping with this message coming up 'low input' and iam using a prolux 10amp power supply and i have never had a problem before with the charger or power supply but every where i use it ( my house,trackside, even at work) i still get the same message.

also my mate who a stealth charger has been using the my 10amp power supply at the same places as me and he has no problem i even got all the guys at track side to turn off all chargers etc to see if that helpped but no it didnt


any help please?????

cheers tamiya man uk
TAMIYAMANUK is offline   Reply With Quote
Old 03-13-2006, 04:21 PM   #2
Tech Apprentice
 
Join Date: May 2005
Location: Schiedam/Netherlands
Posts: 80
Default

have you tried your charger on your mate's powersupply ? Does the charger beeps for the same thing ?

From your post info I gues it's a lose contact in the wire to power the charger. Have you checked these ?
Frans H is offline   Reply With Quote
Old 03-14-2006, 08:44 AM   #3
Tech Addict
 
Join Date: Mar 2006
Location: UK Stoke-on-Trent
Posts: 603
Send a message via MSN to TAMIYAMANUK
Default

hi there
thanks for the reply but my mate uses my power supply and its all ok with his stealth charger.

could it be a loose wire in side the charger. if so can i open it or will it voild the warranty in anyway.

tamiyamanuk
TAMIYAMANUK is offline   Reply With Quote
Old 03-14-2006, 11:01 AM   #4
Tech Apprentice
 
Join Date: Nov 2004
Posts: 82
Default

I hook up my Stealth and CDC to my 14A power supply.
The stealth must start first before the CDC can start.
If you do it the other way round, the stealth would not charge and the same error occur "input low".

This is irritating!!!!
ah_liang is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Nosram Stealth evo Charlie_Murphy Australia For Sale/Trade 3 06-29-2007 11:44 PM
Nosram Stealth Charger (UK) TAMIYAMANUK R/C Items: For Sale/Trade 8 05-21-2007 05:39 AM
Nosram stealth charger Sergios Electric Off-Road 0 12-18-2006 01:38 PM
nosram stealth charger flysti R/C Items: For Sale/Trade 0 06-03-2006 08:32 AM
nosram stealth charger flysti Australia For Sale/Trade 9 05-11-2006 03:40 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 12:22 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net