Go Back  R/C Tech Forums > General Forums > Electric On-Road
HPI RS4 Sport 3 problems-HELP >

HPI RS4 Sport 3 problems-HELP

HPI RS4 Sport 3 problems-HELP

Reply

Old 02-04-2019, 06:34 PM
  #1  
Tech Rookie
Thread Starter
 
Join Date: Feb 2019
Posts: 1
Default HPI RS4 Sport 3 problems-HELP

I just got this car and went to run it and within the first few minutes it stopped and didnít move. I thought it was the Lipo failsafe but I checked and it was set on nimh mode. So now after trying different methods, whenever I max out the throttle it stops and beeps and I have to wait until I can drive it again after a couple seconds. if someone can help thatíd be awesome




Also I checked the battery but wasnít sure if on the charger green meant charged or not I checked the manuals or missed something but Idk about the light. Thanks

Superepicty is offline  
Reply With Quote
Old 02-05-2019, 12:11 AM
  #2  
Tech Fanatic
iTrader: (81)
 
SuperFastSnail's Avatar
 
Join Date: Feb 2012
Posts: 851
Trader Rating: 81 (100%+)
Default

If you are running NiMH battery packs and it is in NiMH mode then you are good there. I suspect the problem is with temperature. If you are running the car and the pinion and spur gears are not freely moving (paper thickness for gapping space) then the thermal shutdown mode kicks in and then you have to wait until it properly cools down before you can drive it. If your gear mess is okay and you are constantly running straights in high speed I would suggest you put in a smaller pinion to reduce the heat load on your esc. By doing this you will go slower but it saves your esc and the time for cooling. Otherwise buy a cheap Gool RC brushless system from Fleabay and let her rip, because that car is ready for a brushless setup as it is.
SuperFastSnail is offline  
Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service