R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 02-25-2006, 09:47 AM   #1
Tech Initiate
 
Join Date: Nov 2005
Location: phx az
Posts: 30
Default lrp quantum burn up!!!!!help!!!!!

hello everyone.i was running some practice laps at my local track this morning and my lrp quantum 2 esc had a melt down.i was hoping that i could get some feedback on the cause of this from you guys.

here is the vital info:lrp quantum 2 esc(2 weeks old),spektrum reciever,birdman 27t stock motor,3300 batt all installed on a ft tc4.

as stated,the esc is 2 weeks old and was working great until this morning,the only thing different in the equation was the birdman motor,i havent run it in about a month,it had a fresh com.i ran the esc with a different birdman 27t last night at my club race and an orion 19t spec this morn previous to the birdman,both without issue.

about 2 mins into my run i go into a corner,when i lift off the throttle the esc didnt let off the power for about 1 second,i stopped the car and noticed smoke under the body.i drove it over to me(throttle sticking now) and got the battery unplugged as fast as i could,but obviously it was too late!!!

any info as to what could have caused this will be greatly appreciated.

ive heard that lrp warranty service is pretty good,is this true??i have all the relevant papers as the esc was bought brand new by me.

thanks in advance. Derek K
Derek K is offline   Reply With Quote
Old 02-25-2006, 09:50 AM   #2
Tech Elite
 
GrandeGixxer's Avatar
 
Join Date: Jun 2004
Location: Waldorf, MD
Posts: 2,929
Trader Rating: 15 (100%+)
Default

Send it in, it's done.
__________________
Joe Cude
Mugen MBX-7R Mugen MTX-6R Mugen MTC-1 Mugen MRX-6 Mugen MST-1 Tamiya Euro Truck
GrandeGixxer is offline   Reply With Quote
Old 02-25-2006, 09:59 AM   #3
Tech Initiate
 
Join Date: Nov 2005
Location: phx az
Posts: 30
Default

^^^^^^yep,no doubt about that!!!

i should have stated this in my original post,i have another brand new still in the box qc2 esc,i bought it for my second car,but i dont want to install it if i did something to cause the first one to burn up.i def. wont run this motor again until i get some more info.
Derek K is offline   Reply With Quote
Old 02-25-2006, 11:53 AM   #4
Tech Initiate
 
Join Date: Nov 2005
Location: phx az
Posts: 30
Default

upon further inspection i found a glob of solder from the pos. terminal on the motor which was possibly touching the hold down bar from the bell to the circut board.(on the top of a stock motor)

any thought would be greatly appreciated
Derek K is offline   Reply With Quote
Old 02-25-2006, 12:07 PM   #5
Tech Adept
 
Twin-Kyle's Avatar
 
Join Date: Dec 2004
Location: Puce,ONT Canada
Posts: 234
Default

Quote:
Originally Posted by Derek K
upon further inspection i found a glob of solder from the pos. terminal on the motor which was possibly touching the hold down bar from the bell to the circut board.(on the top of a stock motor)

any thought would be greatly appreciated

Don't THINK that would have anything to do with your problem.
Some LRP's had problems burning up early in there lives.You might of had one of them.
Send it back.They will fix it.
Twin-Kyle is offline   Reply With Quote
Old 02-25-2006, 12:20 PM   #6
Tech Elite
 
Team Speedy's Avatar
 
Join Date: Mar 2005
Location: South Eastern, PA
Posts: 2,066
Trader Rating: 42 (100%+)
Default

Send it back, LRP is good with there customer service. They ask no questions about it and send you a new on in replace of it. It's not your fought you blew it up it has to do with the Esc it's self. I've seen a few go like this nothing major just send it in and you'll have a new one in 3-4 weeks at tops. That's the good thing about LRP they take great care of their customers.
__________________
RcAmerica | Xray | Hudy |
Team Speedy is offline   Reply With Quote
Old 02-25-2006, 01:52 PM   #7
Tech Addict
 
Join Date: Mar 2005
Location: New Jersey
Posts: 558
Send a message via AIM to WhoMe
Default

You should be good to go. Send it in ASAP..if you wait till the warrenty is up yull be paying 52 bucks for a replacement.
WhoMe is offline   Reply With Quote
Old 02-26-2006, 08:44 AM   #8
Tech Initiate
 
Join Date: Nov 2005
Location: phx az
Posts: 30
Default

it will be sent tomorrw!!!!from what ive been told,it seems as if it was not something i did,but just a faulty speed control.i was running a motor well within the turn range,my normal,proven gear ratio,and was just into a run when it happened.

either way,thanks for the replies!!!!

DEREK k
Derek K is offline   Reply With Quote
Old 02-26-2006, 07:19 PM   #9
Tech Elite
 
Team Speedy's Avatar
 
Join Date: Mar 2005
Location: South Eastern, PA
Posts: 2,066
Trader Rating: 42 (100%+)
Default

Derek,

I wouldn't sweat it at all. They'll take it back no questions asked. I once used a LRP product and sent it back twice in the same month. First time it was the speedo itself going to slow. The second time it somehow was zapped and shutdown. Both times they sent me a brand new one. I wouldn't worry about your Quantum 2. I've seen a few go under race conditons for no reason at all. Don't really know why they go as I don't run them but just send it back and you'll have a new one within 3 weeks. And don't hesitate to run the other one you have. There's a small chance it could happen again but it's unlikely that it could happen. With the motor, a overload can shut anything down on a speed control. Too much amperage will surely shut it down. (Correct me if I'm wrong) I would recommend checking out the motor, cleaning it, and cutting the arm. and adding new brushes and checking it out on a motor run in feature like ones found on a LRP Pulsar of a CE GFX. That should at least take care of the one "faulty" motor you have. Hope that helps.
Speedy-
__________________
RcAmerica | Xray | Hudy |
Team Speedy is offline   Reply With Quote
Old 03-28-2006, 09:12 PM   #10
Tech Initiate
 
Join Date: Nov 2005
Location: phx az
Posts: 30
Default

whats up guys,recieved my replacement quantum 2 yesterday,brand new in the box,no charge.(just under 4 weeks from the day i sent it,as you guys said)

big thumbs up to associated/lrp warranty/customer service dept,i heard good things about them and they came throgh for me.
Derek K is offline   Reply With Quote
Old 03-28-2006, 10:21 PM   #11
Tech Adept
 
Twin-Kyle's Avatar
 
Join Date: Dec 2004
Location: Puce,ONT Canada
Posts: 234
Default

Good to here,glad to help.
Twin-Kyle is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
rate the burn out MMS1 Chat Lounge 4 12-15-2007 06:32 PM
Motor Burn Out B4Bandit Electric Off-Road 3 04-18-2007 09:42 AM
Motor Burn Out B4Bandit Electric On-Road 4 04-13-2007 07:13 AM
Almost burn myself BBSGS4 Electric On-Road 11 06-26-2004 06:40 PM
lrp v7.1 burn up monsooni1 Racing Forum 8 01-17-2002 03:40 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 06:44 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net