Go Back  R/C Tech Forums > General Forums > Electric On-Road
Team Associated TC4 rear diff question >

Team Associated TC4 rear diff question

Team Associated TC4 rear diff question

Old 09-10-2018, 07:22 AM
  #1  
Tech Rookie
Thread Starter
 
Join Date: Sep 2018
Posts: 3
Default Team Associated TC4 rear diff question

Hi everyone!

I have a somewhat noob question on my Factory Team TC4. I recently dusted it off and have it up and running but I'm having trouble figuring out an issue with the rear diff. For some reason it appears that it might be slipping. If I put my car on a flat surface and give it any amount of throttle, it's very sluggish when accelerating, and won't even drive up onto a carpet from the hard floor surface.

I took apart the gear box, cleaned it out, reapplied a small amount of diff lube, put it back together but still didn't help. Anyone have any suggestions for what I should focus on to fix this?

Thank you very much!

--Eric
emf411 is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.