R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 02-01-2006, 02:42 AM   #1
Tech Regular
 
kimbalion7's Avatar
 
Join Date: Jan 2006
Location: Melbourne Australia
Posts: 269
Trader Rating: 1 (100%+)
Default ESC or SERVO Problem

Hi People
I have a problem with my radio gear, i have tried 4 different ESC's but to no avil. I am running a JR XS3 digital system and rs310 receiver. I have connected a Towerpro high torque digital servo into my losi xxxbk2. Everytime i turn a corner the unit dies for about 10 seconds then restarts. No problems in a straight line just when i turn. running GTX ESC with monster stock motor and still has problems.
Have tried a non digital servo and that seemed to be fine but doesnt have the torque or speed of the digital.
Any suggestions??
Thanks
Simon

PS im located in Australia
__________________
What?? And you cant beat that????
DOES ANYONE HAVE A RUSTY ARMATURE??
GO TEAM HARDCORE
Chistmas is like a 540, It's for the kids
kimbalion7 is offline   Reply With Quote
Old 02-01-2006, 03:55 AM   #2
Tech Fanatic
 
Drewdc90's Avatar
 
Join Date: Sep 2005
Location: Sunshine Coast Australia
Posts: 828
Trader Rating: 3 (100%+)
Default

You may need to run a Capacitor wired into the receiver to smooth the voltage out to the servo. I had similar issues with an LRP QC2 and the cap worked. Or run the servo directly off the battery using a voltage reulator or a diode /cap setup. Check out this thread.
http://www.rctech.net/forum/showthre...&page=41&pp=30
I also run same servo with a Novak GTB and this works without cap.
__________________
-Xray--Nosram--Orion--Trak Power--Duratrax--Spektrum--Futaba-

Sunshine Coast QLD AUSTRALIA

"If you stand still long enough you'll go backwards"
Drewdc90 is offline   Reply With Quote
Old 02-01-2006, 04:59 AM   #3
Tech Regular
 
kimbalion7's Avatar
 
Join Date: Jan 2006
Location: Melbourne Australia
Posts: 269
Trader Rating: 1 (100%+)
Default

Hi And thanks Drewdc90 will give that a go but am thinking maybe the receiver could be playing a part in this ??? Only because when i use anolog servo no problems.. Someone told me that these digi servos require more power and receiver shuts down as part of failsafe?
Simon
__________________
What?? And you cant beat that????
DOES ANYONE HAVE A RUSTY ARMATURE??
GO TEAM HARDCORE
Chistmas is like a 540, It's for the kids
kimbalion7 is offline   Reply With Quote
Old 02-02-2006, 04:09 AM   #4
Tech Fanatic
 
Drewdc90's Avatar
 
Join Date: Sep 2005
Location: Sunshine Coast Australia
Posts: 828
Trader Rating: 3 (100%+)
Default

Its not the receiver that is causing the shutdown. The Digi servo requires more power than the ESC can put out. The LRP is 4.8v at 1amp. The Novak is 6v at 3amps. Thats why with my GTB no problems. The LRP will NOT have enough power for the Tower Pro servo. I have one and the only way to get it to work is to wire a capacitor to the spare slot in your receiver or a separate power supply regulated to the servo. Try the cap first as your receiver is ok.
__________________
-Xray--Nosram--Orion--Trak Power--Duratrax--Spektrum--Futaba-

Sunshine Coast QLD AUSTRALIA

"If you stand still long enough you'll go backwards"
Drewdc90 is offline   Reply With Quote
Old 02-02-2006, 04:27 AM   #5
Tech Master
 
Join Date: Jun 2004
Location: United Kingdom
Posts: 1,870
Trader Rating: 1 (100%+)
Default

Digital servo is a defo problem.

Ensure that the end points are set correctly so the servo isn't stalling against the steering stops, and ensure that your ESC can produce sufficient juice to power it. You can always hot wire the +ve of the servo to the fet lead output of the ESC, but this will shorten the life of the servo a little.

so, don't forgt 'SET THE EPA FOR STEERING LEFT AND RIGHT'
DA_cookie_monst is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
SERVO PROBLEM lancerevo22194 Micro and Mini Scales 11 07-23-2008 04:17 PM
Servo problem ???WTF Please TRFTIM Electric On-Road 1 11-20-2006 03:03 PM
servo problem. Please help! cars.cars.cars Nitro On-Road 4 08-22-2005 01:02 AM
servo problem wothrottle Electric On-Road 0 09-29-2004 06:24 AM
servo problem wahturi Nitro On-Road 7 12-25-2002 10:48 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 12:24 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net