R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric Off-Road

Reply
 
Thread Tools Search this Thread
Old 12-10-2005, 05:03 PM   #16
Tech Master
 
jaejw1's Avatar
 
Join Date: Jun 2005
Location: dana point
Posts: 1,782
Send a message via AIM to jaejw1
Default

had the same thing happen to me,, the guy at novak kind of gave me a hard time,, trying to make it seem it was my fault,, but they did replace it.. so far i have had no problems.. this is also my third unit,, the first one just stopped running correctly,, somehting about burnt fets
__________________
vendetta videos.. http://www.rcuniverse.com/forum/m_5684344/tm.htm

motor review
http://www.rcuniverse.com/forum/m_5643067/tm.htm
http://www.rctech.net/forum/micro-mini-scales/156814-vendetta-bl-motor-reviews-pros-cons.html

tire review
http://www.rcuniverse.com/forum/m_6000527/tm.htm
jaejw1 is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
10 minute qualy. Pro and con?? J.Gonzalez Nitro On-Road 32 08-25-2008 02:11 AM
Last minute info on VP PRO !! Tabushi Nitro Off-Road 0 08-04-2008 09:25 PM
20 minute mod finals anyone? aus jd 2703 Australian Racing 2 08-05-2007 11:45 PM
TAKE A FIVE MINUTE PIT STOP socalbomber Electric On-Road 9 08-05-2007 01:34 AM
10 Minute Qualifiers GrandeGixxer Nitro On-Road 13 07-17-2006 01:48 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 06:05 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net