R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric Off-Road

Reply
 
Thread Tools Search this Thread
Old 10-13-2005, 03:50 PM   #1
Tech Initiate
 
Join Date: Mar 2004
Location: Maine
Posts: 22
Send a message via AIM to OptimaMid89
Default T-maxx troubles

Recently got a T-maxx from a friend who kinda abused it. I cleaned it and fixed it up but it still won't start. I've tried everything, pull start, electric start, checked and swapped out glowplugs and ignitors. I think the problem may be my gas. The gas I have is probably over a year old and when I went to start my xxx-nt, no go. Any other ideas on what it could be?
OptimaMid89 is offline   Reply With Quote
Old 10-13-2005, 05:09 PM   #2
Tech Adept
 
Join Date: Sep 2005
Location: Texas
Posts: 137
Default

Yeah Try some new gas, and make sure you are getting power to the glow plug, if you are you are using the EZ-start.
crash21 is offline   Reply With Quote
Old 10-13-2005, 05:13 PM   #3
Tech Initiate
 
Join Date: Mar 2004
Location: Maine
Posts: 22
Send a message via AIM to OptimaMid89
Default

Ya, i dont use that glow plug ingnitor thingy on the electric start. I just use a regular ole glow plug ingnitor, so i know i am getting power to the plug.
OptimaMid89 is offline   Reply With Quote
Old 10-14-2005, 09:35 AM   #4
Tech Master
 
Team Duratrax's Avatar
 
Join Date: Aug 2004
Location: NSW, Albury/Wodonga
Posts: 1,674
Send a message via MSN to Team Duratrax
Default

If the engine was abused as well then there is a chance that the engine is toast. Engines that have lost compression or pinch are extremely hard to start.

Sean
Team Duratrax is offline   Reply With Quote
Old 10-14-2005, 12:46 PM   #5
Tech Initiate
 
Join Date: Mar 2004
Location: Maine
Posts: 22
Send a message via AIM to OptimaMid89
Default

Ya, it doesn't have great compression but I am pretty sure it will start. I used the same gas on my XXX-NT which has very good compression (can't turn flywheel with one or two fingers) and that wouldn't start. So the only constant in both of these is the gas.
OptimaMid89 is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
tt-01 troubles nekmiyevo2 Electric On-Road 21 08-11-2005 07:34 AM
Car troubles? acutts Electric On-Road 6 03-27-2004 06:16 AM
Tech_Muggz ...having troubles.... Altrodesigns Buyer/Seller dispute and Feedback discussion forum 3 12-16-2003 12:00 PM
T Maxx 2.5 Trans troubles...Please Help kevinswart Monster Trucks 6 04-15-2003 07:29 PM
OS TR(P) Troubles Glenn Nitro On-Road 12 08-28-2002 02:38 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 02:52 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net