EZ start

Reply

Old 09-19-2005, 09:40 PM
  #1  
Tech Adept
Thread Starter
 
Join Date: Sep 2005
Location: Texas
Posts: 137
Default EZ start

Hey I just found something out that just might help anybody that has ever had a problen with their EZ start. I wrecked my T-maxx last weekend and it would not turn over at all. It just made a clicking sound. Well.I thought the motor was smoked or the gears were out of wack. I dissasembled the EZ start, and what happened was the 2 screws that hold the motor on the unit backed out and were jammed against the gears keepin it from turning. I was just wondering if this has happend to anyone else.
crash21 is offline  
Reply With Quote
Old 09-22-2005, 02:48 PM
  #2  
Tech Regular
 
Join Date: Sep 2005
Location: Au
Posts: 329
Default

woulnt be suprised, they are crap!
qwerty is offline  
Reply With Quote
Old 09-22-2005, 07:54 PM
  #3  
Tech Master
 
Platinum_Racing's Avatar
 
Join Date: Jun 2005
Location: Rowley MA
Posts: 1,844
Default

TRX 2.5 or PRO .15? The EZ start is different on either one.
Platinum_Racing is offline  
Reply With Quote
Old 09-24-2005, 02:37 PM
  #4  
Tech Adept
Thread Starter
 
Join Date: Sep 2005
Location: Texas
Posts: 137
Default

This was on the 2.5. The EZ start 2
crash21 is offline  
Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Terms of Service