Go Back  R/C Tech Forums > General Forums > Electric Off-Road
HPI Savage & Vorza... Different ESCs? >

HPI Savage & Vorza... Different ESCs?

HPI Savage & Vorza... Different ESCs?

Reply

Old 02-06-2014, 09:28 PM
  #1  
Tech Rookie
Thread Starter
 
Join Date: Feb 2014
Posts: 2
Default HPI Savage & Vorza... Different ESCs?

Hello Guys... Last week I purchased a savage and a vorza...

Problems immediately happen...

First day I ran the Savage under light driving conditions the truck stopped running… only had steering… Turned the ESC off and now it won’t turn on… No noise no nothing no steering… like if batteries were not connected… tried several different batteries no luck… castle link does connect perfectly to the esc… but when you turn it on it doesn’t work…

Ran the Vorza fine... but with the castle link I was looking for the punch control configuration... did not find it...Also I saw something weird... When I connect the Castle link to the Savage a screen with the logo "MAMBA MONSTER 2" appears... and When I connect the Vorza the logo that appears says "FLUX BLUR" ... I Thought they had the same esc? also the Savage does have punch control...


So any help will be greatly appreciated!
JC
james cole is offline  
Reply With Quote
Old 02-07-2014, 03:13 AM
  #2  
Tech Rookie
 
Join Date: Mar 2013
Posts: 2
Default

i dont have the savage but i do have the vorza and mine does the same thing no power tab on the castle link.i talked to castle and they said they had an update waiting but they have to get it aproved from hpi to put it on the castle link.as for your other mm2 call castle it should be under warrenty.where did you buy it i think they might be of some help to.i know my lhs when i bought my rustler some years ago was having esc problems and they replaced the esc
hottrodd1090 is offline  
Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service