Go Back  R/C Tech Forums > General Forums > Electric Off-Road
1/10 Buggy Motor problem >

1/10 Buggy Motor problem

1/10 Buggy Motor problem

Reply

Old 05-02-2013, 09:38 PM
  #1  
Tech Rookie
Thread Starter
 
Join Date: Apr 2013
Posts: 8
Default 1/10 Buggy Motor problem

I tried using this leopard 2pole brushless a couple of times, and first it had some weird sound "zzzzz"
then it was okay. at least from my observation.
Do you guys think I need to fix it?
Asiatees say 365 days return..
Emailed them and waiting for their reply.
fkl1 is offline  
Reply With Quote
Old 05-02-2013, 10:15 PM
  #2  
Tech Elite
iTrader: (27)
 
rcgod's Avatar
 
Join Date: Apr 2002
Location: Tracy, CA
Posts: 3,083
Trader Rating: 27 (100%+)
Default

Originally Posted by fkl1 View Post
I tried using this leopard 2pole brushless a couple of times, and first it had some weird sound "zzzzz"
then it was okay. at least from my observation.
Do you guys think I need to fix it?
Asiatees say 365 days return..
Emailed them and waiting for their reply.
What ESC?
rcgod is offline  
Reply With Quote
Old 05-07-2013, 12:42 AM
  #3  
Tech Rookie
Thread Starter
 
Join Date: Apr 2013
Posts: 8
Default

I got this ESC, shouldn't be the problem of the ESC right.
Topcad- Toprock- Super drag brake.
Last time I used, even had smoke came out.
But then again, it was alright after.
Got a reply back from customer service, they think its a faulty part. too lazy to ship it back, looking to see if this would cause a big problem.
fkl1 is offline  
Reply With Quote
Old 05-07-2013, 05:15 AM
  #4  
Tech Elite
iTrader: (27)
 
rcgod's Avatar
 
Join Date: Apr 2002
Location: Tracy, CA
Posts: 3,083
Trader Rating: 27 (100%+)
Default

Any time smoke comes out of an ESC it's not good. Don't know anything about that brand but sounds like you need to replace it.
rcgod is offline  
Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service