Go Back  R/C Tech Forums > General Forums > Electric Off-Road
I need help with a 17.5 t fuse brushless system >

I need help with a 17.5 t fuse brushless system

I need help with a 17.5 t fuse brushless system

Old 01-26-2013, 08:33 PM
  #1  
Tech Rookie
Thread Starter
 
Join Date: Jan 2013
Posts: 6
Default I need help with a 17.5 t fuse brushless system

Hi I have a traxxas slash 2 wheel drive I was told by a local hobby shop that I could put in a 17.5 t fuse brushless system I just installed it and when I full throttle it it cuts off and then when I let go the throttle and slowly pull it back works fine but when its full throttle it does the same thing I'm running a 8.4 3000 mah traxxas battery please help me I don't know what I'm doing wrong

Last edited by newrcguy; 01-26-2013 at 08:35 PM. Reason: miss spelled word
newrcguy is offline  
Old 01-26-2013, 08:43 PM
  #2  
Tech Master
 
rcduder's Avatar
 
Join Date: Oct 2011
Location: Tacoma, WA
Posts: 1,123
Default

Originally Posted by newrcguy View Post
Hi I have a traxxas slash 2 wheel drive I was told by a local hobby shop that I could put in a 17.5 t fuse brushless system I just installed it and when I full throttle it it cuts off and then when I let go the throttle and slowly pull it back works fine but when its full throttle it does the same thing I'm running a 8.4 3000 mah traxxas battery please help me I don't know what I'm doing wrong
make sure you calibrated your radio properly after your install and also make sure that battery isn't too much for the esc, because some but not all speed controls are made to except no more the 7.4v either 6 cell nimh or 2s lipo
rcduder is offline  
Old 01-26-2013, 09:15 PM
  #3  
Tech Rookie
Thread Starter
 
Join Date: Jan 2013
Posts: 6
Default

Ok I will do that but if that still don't work can it be the system malfunction
newrcguy is offline  
Old 01-26-2013, 09:18 PM
  #4  
Tech Master
 
rcduder's Avatar
 
Join Date: Oct 2011
Location: Tacoma, WA
Posts: 1,123
Default

Originally Posted by newrcguy View Post
Ok I will do that but if that still don't work can it be the system malfunction
it could be u never know,but I don't think that's it. but it is always helpful too know what servo and rx you are running ? and is this system sensored or sensorless? also check your esc settings.
rcduder is offline  
Old 01-26-2013, 09:39 PM
  #5  
Tech Rookie
Thread Starter
 
Join Date: Jan 2013
Posts: 6
Default

It's a sensored system and my radio and receiver is a tqi 2.4ghz
newrcguy is offline  
Old 01-26-2013, 09:45 PM
  #6  
Tech Apprentice
 
ratrod0's Avatar
 
Join Date: Jul 2011
Location: basement
Posts: 85
Default

You Have the motor set on kill tone it down and it will work. if you set the timming all the way up it will do it. set it back down till it stops.
ratrod0 is offline  
Old 01-26-2013, 09:46 PM
  #7  
Tech Master
iTrader: (3)
 
AndrewTom's Avatar
 
Join Date: Nov 2011
Location: Thousand Oaks, CA
Posts: 1,429
Trader Rating: 3 (100%+)
Default

it probably in LIPO mode.
AndrewTom is offline  
Old 01-26-2013, 09:46 PM
  #8  
Tech Rookie
Thread Starter
 
Join Date: Jan 2013
Posts: 6
Default

Do u think I should go with Lipo maybe there is not enough battery current for system
newrcguy is offline  
Old 01-26-2013, 09:49 PM
  #9  
Tech Rookie
Thread Starter
 
Join Date: Jan 2013
Posts: 6
Default

I have taken it try every setting I even set it to standard setting and still the same
newrcguy is offline  
Old 01-26-2013, 10:03 PM
  #10  
Tech Rookie
Thread Starter
 
Join Date: Jan 2013
Posts: 6
Default

Thanks for everyone help I'm going to try Lipo if that don't work fuse system is just a waste of money
newrcguy is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell or Share My Personal Information -

Copyright © 2023 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.