Go Back  R/C Tech Forums > General Forums > Electric Off-Road
Would a Castle bec help? >

Would a Castle bec help?

Would a Castle bec help?

Reply

Old 01-13-2013, 05:10 PM
  #1  
Tech Rookie
Thread Starter
 
Join Date: Jan 2013
Posts: 18
Default Would a Castle bec help?

I have been running the castle mamba max pro esc with a castle 1415 motor in my Losi Ten-SCTE. I recently got a Tekin Pro 4 4600 kv motor. The motor runs great but right out of the box I noticed that the motor was to hot to touch after running and that my esc was pretty warm. I also found that with this new motor I can barely run 7 minutes before my battery is dead, with the castle motor i could run 12 minutes. I'm running a 13 tooth pinion gear and my batterys are orion 5000mah 90c lipos. Does anyone know whether a Castle bec would help or not?
KTMRacer50 is offline  
Reply With Quote
Old 01-13-2013, 05:39 PM
  #2  
Tech Elite
iTrader: (19)
 
Rockthecatbox21's Avatar
 
Join Date: Apr 2012
Location: Texas panhandle
Posts: 2,797
Trader Rating: 19 (100%+)
Default

Nothing's wrong. Just ROAR'S stupid 2s rule causing all those effects. Since you have ran the castle 1415 you already know how much better of a setup it is. Most of us using high Kv/2s setups get less than 10 mins. Don't need an external bec, just a bigger mah battery. As for the post under me, no need to switch brands. There's nothing wrong.
Rockthecatbox21 is offline  
Reply With Quote
Old 01-13-2013, 05:39 PM
  #3  
Tech Master
iTrader: (36)
 
Join Date: Oct 2011
Location: Anaheim Hills, CA
Posts: 1,254
Trader Rating: 36 (100%+)
Default

The BEC won't help as it is for a different problem. I had a problem with my castle esc and high amp draw with a similar switch. Once I switched to a different brand of ESC with my new motor, the problem went away.
ufoDziner is offline  
Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service