Go Back  R/C Tech Forums > General Forums > Electric Off-Road
Help with Mugen MT12 in HPI MT >

Help with Mugen MT12 in HPI MT

Help with Mugen MT12 in HPI MT

Reply

Old 04-15-2005, 01:28 PM
  #1  
Tech Rookie
Thread Starter
 
Join Date: Apr 2005
Posts: 1
Default Help with Mugen MT12 in HPI MT

I have a HPI MT that I just put a Mugen MT12 in. It seems to run out great at home, however when I take it to the track it stalls if I hit the wall, or pretty much anything that brings the car to a dead stop. (it's going to be a long time before I stop doind this....) The motor seems to be running out great, I can burn through a few tanks, without it stalling or running hot.

Any input would be greatly appreciated.
kubicki88 is offline  
Reply With Quote
Old 04-18-2005, 12:48 AM
  #2  
Tech Elite
iTrader: (23)
 
HarKonnenD's Avatar
 
Join Date: Aug 2001
Location: Connecticut
Posts: 3,024
Trader Rating: 23 (100%+)
Default

For one, stop hitting thing's...LOL. Secondly, make sure the flywheel isnt coming on contact with anything. A rock got stick by the chassis and flywheel'; the engine cut right off.
HarKonnenD is offline  
Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service