Go Back  R/C Tech Forums > General Forums > Electric Off-Road
please help! BL motor wont run! >

please help! BL motor wont run!

please help! BL motor wont run!

Old 09-22-2012, 08:41 PM
  #16  
iTrader: (13)
 
slim jim's Avatar
 
Join Date: Mar 2011
Location: land of cows and corn fields
Posts: 645
Trader Rating: 13 (100%+)
Default

at least you can edit it
slim jim is offline  
Old 09-22-2012, 08:43 PM
  #17  
Tech Addict
Thread Starter
iTrader: (3)
 
preciadoalex123's Avatar
 
Join Date: Aug 2012
Location: San Bernardino County, CA
Posts: 566
Trader Rating: 3 (100%+)
Default

Mehhh.......
preciadoalex123 is offline  
Old 09-22-2012, 10:12 PM
  #18  
Tech Master
iTrader: (2)
 
scwrod's Avatar
 
Join Date: Apr 2008
Posts: 1,420
Trader Rating: 2 (100%+)
Default

Which ESC is it. Some are only rated for 2s.
scwrod is offline  
Old 09-23-2012, 06:55 AM
  #19  
iTrader: (13)
 
slim jim's Avatar
 
Join Date: Mar 2011
Location: land of cows and corn fields
Posts: 645
Trader Rating: 13 (100%+)
Default

ae sc-700 bl, from 1st. post. 2-3s capable. I had to look up the specs b4 advising.
slim jim is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell or Share My Personal Information -

Copyright © 2023 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.