Go Back  R/C Tech Forums > General Forums > Electric Off-Road
3-Cell shipped with faulty cell >

3-Cell shipped with faulty cell

3-Cell shipped with faulty cell

Old 02-24-2012, 05:59 PM
  #1  
Tech Fanatic
Thread Starter
iTrader: (29)
 
Devigili22's Avatar
 
Join Date: Jan 2012
Location: Austin, TX
Posts: 852
Trader Rating: 29 (97%+)
Default 3-Cell shipped with faulty cell

Well here is my story,

I ordered a SkyLipo 3 cell lipo from hobbypartz, can't post a URL, but it was a 3 Cell 4400mah 40C soft-case. Once it got here, I kept it in my drawer for about a week because school(Mechanical Engineering Major) got in the way of my RC time. Well, finally, a free slot where I could charge and run. Well I got my charger out, plugged in the leads and the balancer, started to charged, and it began going nuts. I looked at what was wrong, the 3rd cell was at 1.9V! What should I do? I can't/won't use this battery but it wasn't cheap. Can I get my money back? Can I get a replacement? Not really sure what to do here.
Devigili22 is offline  
Old 02-24-2012, 06:17 PM
  #2  
Tech Master
iTrader: (26)
 
Autocratic's Avatar
 
Join Date: Dec 2011
Location: Dallas, Tx
Posts: 1,691
Trader Rating: 26 (100%+)
Default

You should contact Hobbypartz.com customer service, instead of posting in a forum.
Autocratic is offline  
Old 02-24-2012, 06:50 PM
  #3  
Tech Fanatic
Thread Starter
iTrader: (29)
 
Devigili22's Avatar
 
Join Date: Jan 2012
Location: Austin, TX
Posts: 852
Trader Rating: 29 (97%+)
Default

I have seen members with similar problems post their issues and get some answers to their questions.
Devigili22 is offline  
Old 02-24-2012, 07:00 PM
  #4  
Tech Master
iTrader: (26)
 
Autocratic's Avatar
 
Join Date: Dec 2011
Location: Dallas, Tx
Posts: 1,691
Trader Rating: 26 (100%+)
Default

Originally Posted by Devigili22 View Post
I have seen members with similar problems post their issues and get some answers to their questions.
Considering the pack should have been at storage voltage, (3.7v/cell) when shipped, and you had one at 1.9v, you need to contact Hobbypartz.com and return it for exchange or refund. The pack is worthless with a dead cell.
Autocratic is offline  
Old 02-24-2012, 08:48 PM
  #5  
Tech Apprentice
iTrader: (16)
 
Join Date: Jan 2012
Location: Michigan, USA
Posts: 69
Trader Rating: 16 (100%+)
Default

Hobbypartz is pretty good about returns, As long as it is not obvious damage by the consumer. The only thing that could hurt you is if you changed the connector, That voids their warranty I believe.
OrigJoker is offline  
Old 02-24-2012, 08:50 PM
  #6  
Tech Champion
iTrader: (21)
 
MarkA's Avatar
 
Join Date: Aug 2001
Location: Corvallis, OR
Posts: 9,161
Trader Rating: 21 (100%+)
Default

Originally Posted by Autocratic View Post
You should contact Hobbypartz.com customer service, instead of posting in a forum.
Or even better, search said forum for brands like those and decide if you want to take the risk before ordering. There are more than enough dead Chinese un-brand battery threads on here to make sure everyone buying them knows what they're getting into.

In the meantime, best of luck to the original poster in getting an exchange or refund.
MarkA is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.