Go Back  R/C Tech Forums > General Forums > Electric Off-Road
XP sc450 esc problem!!!!!! >

XP sc450 esc problem!!!!!!

XP sc450 esc problem!!!!!!

Reply

Old 02-19-2012, 02:01 PM
  #1  
Tech Addict
Thread Starter
iTrader: (2)
 
elecRC23's Avatar
 
Join Date: Jan 2012
Location: Culver City, CA
Posts: 506
Trader Rating: 2 (100%+)
Default XP sc450 esc problem!!!!!!

I was runnung my buggy around in my culdisac when i accidentally ran it in water. A few drops of water got onto the esc so i figured i'd put some rice on it to soak up the water. Now, whenever I try to run it, only the servo works. Is there anything i can do to fix it or do i have to completely replace it?
elecRC23 is offline  
Reply With Quote
Old 02-19-2012, 02:04 PM
  #2  
Tech Master
iTrader: (77)
 
lodhammerdin's Avatar
 
Join Date: Jun 2010
Location: Northern Mexico (aka, El Paso, TX)
Posts: 1,194
Trader Rating: 77 (100%+)
Default

Originally Posted by elecRC23 View Post
I was runnung my buggy around in my culdisac when i accidentally ran it in water. A few drops of water got onto the esc so i figured i'd put some rice on it to soak up the water. Now, whenever I try to run it, only the servo works. Is there anything i can do to fix it or do i have to completely replace it?
I'd say get a blow dryer and hold it about a foot or so away on the slowest speed for a few mins and make sure it's not getting the esc hot, just drying the water. It this doesnt work, call associted on monday and talk to them. when did you buy the truck? if it's not under warranty and you have to replace it, it'll be 50% of the retail price.
lodhammerdin is offline  
Reply With Quote
Old 02-19-2012, 02:08 PM
  #3  
Tech Addict
Thread Starter
iTrader: (2)
 
elecRC23's Avatar
 
Join Date: Jan 2012
Location: Culver City, CA
Posts: 506
Trader Rating: 2 (100%+)
Default

i got it two weekends ago. the warranty sais that misuse and anything damaged by the user r not covered by the warranty.
elecRC23 is offline  
Reply With Quote
Old 02-19-2012, 02:40 PM
  #4  
Tech Master
iTrader: (77)
 
lodhammerdin's Avatar
 
Join Date: Jun 2010
Location: Northern Mexico (aka, El Paso, TX)
Posts: 1,194
Trader Rating: 77 (100%+)
Default

Originally Posted by elecRC23 View Post
i got it two weekends ago. the warranty sais that misuse and anything damaged by the user r not covered by the warranty.
I would still give them a call, the guys at AE are really great people and will go out of there way to make sure the customer is happy.
lodhammerdin is offline  
Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service