R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric Off-Road

Reply
 
Thread Tools Search this Thread
Old 02-22-2011, 09:48 PM   #1
Tech Rookie
 
Join Date: Feb 2011
Posts: 1
Default E-maxx problem

i have an older e-maxx and the other day it was running great but now it will not even turn on it ran through a little water and i think that is the problem it has a waterproff ESC but the reciver is not so if i put a new reciver on it dos any one think it will work??????
budy60 is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
T/E Maxx Thread Modena AL Monster Trucks 619 05-19-2014 01:30 PM
Traxxas E-Maxx Thread! ThePrfctGetaway Monster Trucks 79 09-24-2012 08:23 AM
New traxxas e-maxx xsxracing Monster Trucks 439 09-05-2012 04:15 PM
e-maxx with vxl system and 3s lipo streetracer745 Monster Trucks 50 06-12-2011 08:00 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 01:23 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net