Go Back  R/C Tech Forums > General Forums > Electric Off-Road
Losi 1/10 TEN-SCTE ARR 4x4 Short Course Truck Thread >

Losi 1/10 TEN-SCTE ARR 4x4 Short Course Truck Thread

Like Tree9Likes

Losi 1/10 TEN-SCTE ARR 4x4 Short Course Truck Thread

Old 01-17-2012, 01:34 PM
  #27781  
Tech Master
iTrader: (39)
 
BDRMBULLY's Avatar
 
Join Date: May 2006
Location: toronto CANADA
Posts: 1,490
Trader Rating: 39 (100%+)
Default

Originally Posted by AgroAMG View Post
I noticed them ever so slightly less rubbing, but they do still for me. It seems like a poor design as the threads on the shock body will be worn down. But, they only seem to wear down at the bottom and I really dont ever put preload down that far, so I guess it wont be a real concern.
Its not just the wear im concerned with , its the fact it makes them not as smooth acting. Conidering chris conversion with 2.0 springs as most spring kits are on B.O any ways. Do you still run the conversion chris????Does the 2.0 springs then hit the tie rods ??
Thanks
BDRMBULLY is offline  
Old 01-17-2012, 02:09 PM
  #27782  
Tech Fanatic
iTrader: (2)
 
Join Date: Feb 2008
Posts: 778
Trader Rating: 2 (100%+)
Default

Originally Posted by BDRMBULLY View Post
Its not just the wear im concerned with , its the fact it makes them not as smooth acting. Conidering chris conversion with 2.0 springs as most spring kits are on B.O any ways. Do you still run the conversion chris????Does the 2.0 springs then hit the tie rods ??
Thanks
I've been waiting on the rear spring race set from my LHS for over 3 weeks now. They keep saying its back ordered.

On a side not my Nano techs have been sitting in New York "i guess" for a week now. The tracking info stopped at arrived in target country USJFKA, is what it says. I almost wish I would have paid for the faster shipping.
LosiMadMan is offline  
Old 01-17-2012, 02:23 PM
  #27783  
Tech Addict
iTrader: (18)
 
Join Date: Apr 2011
Location: MI
Posts: 645
Trader Rating: 18 (100%+)
Default

Originally Posted by LosiMadMan View Post
On a side not my Nano techs have been sitting in New York "i guess" for a week now. The tracking info stopped at arrived in target country USJFKA, is what it says. I almost wish I would have paid for the faster shipping.
Post office probably has them now...unfortunately they don't update tracking after they arrive here. They'll probably show up at your door in the next day or two.
teknic is offline  
Old 01-17-2012, 02:47 PM
  #27784  
Tech Adept
 
Join Date: Dec 2011
Location: Shingle Springs
Posts: 128
Default

Originally Posted by LosiMadMan View Post
I've been waiting on the rear spring race set from my LHS for over 3 weeks now. They keep saying its back ordered.

On a side not my Nano techs have been sitting in New York "i guess" for a week now. The tracking info stopped at arrived in target country USJFKA, is what it says. I almost wish I would have paid for the faster shipping.
Mine says the same thing. It's funny though. The info changed on the 15th. But if I look at the date on the swisspost site it says it landed on the 11th. I'm expecting them to just show up in the mail any day.

EDIT. I checked JUST NOW and it says they are sorting at my local Post Office. I should have them tomorrow!!!!
65BAJA is offline  
Old 01-17-2012, 02:51 PM
  #27785  
Tech Fanatic
iTrader: (2)
 
Join Date: Feb 2008
Posts: 778
Trader Rating: 2 (100%+)
Default

Originally Posted by 65BAJA View Post
Mine says the same thing. It's funny though. The info changed on the 15th. But if I look at the date on the swisspost site it says it landed on the 11th. I'm expecting them to just show up in the mail any day.

EDIT. I checked JUST NOW and it says they are sorting at my local Post Office. I should have them tomorrow!!!!
Same here it didn't say anything about arrived at target country untill the 15th and the date on the tracking said the 5th. Let me know when you get yours.
LosiMadMan is offline  
Old 01-17-2012, 03:11 PM
  #27786  
Tech Adept
iTrader: (3)
 
Join Date: Nov 2011
Location: San Diego, CA
Posts: 190
Trader Rating: 3 (100%+)
Default

Originally Posted by 65BAJA View Post
Mine says the same thing. It's funny though. The info changed on the 15th. But if I look at the date on the swisspost site it says it landed on the 11th. I'm expecting them to just show up in the mail any day.

EDIT. I checked JUST NOW and it says they are sorting at my local Post Office. I should have them tomorrow!!!!
USPS is pathetic. Loses BILLIONS each year. So inefficient. You go in there and the employees are usually grumpy and not very helpful. Their tracking is crap, everything is crap. Compare it to UPS or FedEx, which are superior. Sure USPS is cheaper to ship a lot of times, but you have to remember it's losing billions each year. How can you operate in the red like that? UGH! Dont get me started.
AgroAMG is offline  
Old 01-17-2012, 03:34 PM
  #27787  
Tech Lord
iTrader: (8)
 
Integra's Avatar
 
Join Date: Dec 2006
Posts: 12,486
Trader Rating: 8 (100%+)
Default

Originally Posted by LosiMadMan View Post
I've been waiting on the rear spring race set from my LHS for over 3 weeks now. They keep saying its back ordered.

On a side not my Nano techs have been sitting in New York "i guess" for a week now. The tracking info stopped at arrived in target country USJFKA, is what it says. I almost wish I would have paid for the faster shipping.
Originally Posted by teknic View Post
Post office probably has them now...unfortunately they don't update tracking after they arrive here. They'll probably show up at your door in the next day or two.



Check USPS with the tracking # from Swiss post. Mine gets updated By Canada Post when it's landed on our side of the pond.
Integra is offline  
Old 01-17-2012, 03:35 PM
  #27788  
Tech Regular
iTrader: (6)
 
yfzracer912's Avatar
 
Join Date: Jan 2009
Posts: 270
Trader Rating: 6 (100%+)
Default

Are these the kyosho x-rings? I know they are for 1/10th but I cant seem to find anything else.

http://www.gshobby.com/index.php?mai...ducts_id=18989
yfzracer912 is offline  
Old 01-17-2012, 03:42 PM
  #27789  
Tech Adept
 
Join Date: Dec 2011
Location: Shingle Springs
Posts: 128
Default

Originally Posted by Integra View Post
Check USPS with the tracking # from Swiss post. Mine gets updated By Canada Post when it's landed on our side of the pond.
You're right. That worked. The package arrived at my LPO at 4:22am today. So I might even get them today.
65BAJA is offline  
Old 01-17-2012, 03:43 PM
  #27790  
Tech Lord
iTrader: (8)
 
Integra's Avatar
 
Join Date: Dec 2006
Posts: 12,486
Trader Rating: 8 (100%+)
Default

Originally Posted by 65BAJA View Post
You're right. That worked. The package arrived at my LPO at 4:22 today.


Cool so it does work Down South. Wasn't sure if it was the same as up here.
Integra is offline  
Old 01-17-2012, 03:45 PM
  #27791  
Tech Adept
iTrader: (3)
 
Join Date: Nov 2011
Location: San Diego, CA
Posts: 190
Trader Rating: 3 (100%+)
Default What size are those screws on the beadlocks?

I wanna remove my beadlocks but those screws inside the wheels look super tiny. are they even hex? I can barely see them. What are they? I dunno if i have anything that tiny to remove them with.
AgroAMG is offline  
Old 01-17-2012, 03:49 PM
  #27792  
Tech Adept
 
Join Date: Dec 2011
Location: Shingle Springs
Posts: 128
Default

Originally Posted by AgroAMG View Post
I wanna remove my beadlocks but those screws inside the wheels look super tiny. are they even hex? I can barely see them. What are they? I dunno if i have anything that tiny to remove them with.
They are star but a .050 hex works.
65BAJA is offline  
Old 01-17-2012, 03:55 PM
  #27793  
Tech Adept
iTrader: (3)
 
Join Date: Nov 2011
Location: San Diego, CA
Posts: 190
Trader Rating: 3 (100%+)
Default

Originally Posted by 65BAJA View Post
They are star but a .050 hex works.
I have a kit I got at Fry's Electronics for repairing Smart Phones (iPhone and the like) and there are some super tiny hex/torx/etc. bits in there. I'll try those. Thanks.
AgroAMG is offline  
Old 01-17-2012, 03:57 PM
  #27794  
Tech Fanatic
iTrader: (6)
 
Join Date: Jan 2008
Location: Miami Beach
Posts: 959
Trader Rating: 6 (100%+)
Default

Can someone tell me what is the best aftermarket screw set for the SCTE?

Thanks in advance..
SouthFloridaApp is offline  
Old 01-17-2012, 04:05 PM
  #27795  
Tech Regular
iTrader: (9)
 
scracer68's Avatar
 
Join Date: Nov 2011
Posts: 401
Trader Rating: 9 (100%+)
Default

Originally Posted by SouthFloridaApp View Post
Can someone tell me what is the best aftermarket screw set for the SCTE?

Thanks in advance..
Tonys Screws
scracer68 is offline  

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.