Go Back  R/C Tech Forums > General Forums > Electric Off-Road
Losi 1/10 TEN-SCTE ARR 4x4 Short Course Truck Thread >

Losi 1/10 TEN-SCTE ARR 4x4 Short Course Truck Thread

Like Tree9Likes

Losi 1/10 TEN-SCTE ARR 4x4 Short Course Truck Thread

Old 12-10-2011, 09:18 AM
  #25546  
Tech Elite
iTrader: (79)
 
lowroad's Avatar
 
Join Date: Nov 2010
Location: New Mexico
Posts: 3,126
Trader Rating: 79 (100%+)
Default

Originally Posted by tc5 man
Really are you sure the only thing that looks diffrent to me is a 2.0 chassis or a longer center rear shaft everything else looks the same ?
It isn't. The scte is based off The eight ten, or ten T platform. shrunken down version of the 8ight. Nothing converts from the 8ight to the scte really except turnbuckles.
lowroad is offline  
Old 12-10-2011, 09:36 AM
  #25547  
Tech Master
iTrader: (3)
 
chucko's Avatar
 
Join Date: Apr 2011
Location: Hell
Posts: 1,319
Trader Rating: 3 (100%+)
Default

Originally Posted by RC*PHREAK
might just be a bad angle but is the RX8 hanging over the chassis?
Yes its hanging. still fixing things... before.. to lighten, I cut the back of the battery tray off and now I am going to do a rearrange and turn the rx8 and re solder. the longer brace, blocks me from moving it towards the drive shaft. I will get it figured out one of these days,, as soon as they quit selling hop up parts LOL
chucko is offline  
Old 12-10-2011, 09:37 AM
  #25548  
Tech Elite
iTrader: (42)
 
BashemSmashem's Avatar
 
Join Date: Mar 2007
Posts: 4,649
Trader Rating: 42 (100%+)
Default

Originally Posted by lowroad
It isn't. The scte is based off The eight ten, or ten T platform. shrunken down version of the 8ight. Nothing converts from the 8ight to the scte really except turnbuckles.
And the screws ...
BashemSmashem is offline  
Old 12-10-2011, 09:44 AM
  #25549  
Tech Master
iTrader: (3)
 
chucko's Avatar
 
Join Date: Apr 2011
Location: Hell
Posts: 1,319
Trader Rating: 3 (100%+)
Default

Originally Posted by BashemSmashem
And the screws ...
shocks, inner bearings on diffs, speed control, servo, end balls, and a part trige in a pair tree... have a Merry Christmas every one !!!!!!
chucko is offline  
Old 12-10-2011, 09:45 AM
  #25550  
Tech Addict
iTrader: (18)
 
Join Date: Apr 2011
Location: MI
Posts: 645
Trader Rating: 18 (100%+)
Default

Originally Posted by Redux
Hey Guys,
I am new to the forum and tried searching before posting so sorry if this question is redundant. I have been out of RC racing for over 10 years so it is new all over again. I have had a glitching problem with the castle MMP, spektrum DX3c radio, Savox SC-1258 servo. My problems were pretty bad right out of the box. My local hobby shop sold me the castle tuning card to bump up the voltage on the ESC to 6 volts, as well as a capacitor to smooth things out. They said my next steps to solve the problem would be to add and external BEC. I still have a problem when I punch it. I guess I think these are lame fixes for what I see as a flawed design from Castle. My question is, am I being unreasonable? is this how all ESC function? Would it be better to go with an RX8 ESC? Is castle going to fix this? I want to race the truck but don't like the idea of more "junk" in the truck to get it to run right. Thanks from a newb.
It's pretty well documented that the BEC's are weak in the MMP's and it doesn't seem Castle is doing anything to fix it. Personally a glitch buster fixed my issues with my MMP, but some choose to install a $20 BEC, either way it's still cheaper than an RX8.
teknic is offline  
Old 12-10-2011, 09:49 AM
  #25551  
Tech Elite
iTrader: (42)
 
BashemSmashem's Avatar
 
Join Date: Mar 2007
Posts: 4,649
Trader Rating: 42 (100%+)
Default

Originally Posted by teknic
It's pretty well documented that the BEC's are weak in the MMP's and it doesn't seem Castle is doing anything to fix it. Personally a glitch buster fixed my issues with my MMP, but some choose to install a $20 BEC, either way it's still cheaper than an RX8.
But will never work as well , I have 2 MMP's and they are now my backups in my pit box ....
BashemSmashem is offline  
Old 12-10-2011, 09:55 AM
  #25552  
Tech Master
iTrader: (3)
 
chucko's Avatar
 
Join Date: Apr 2011
Location: Hell
Posts: 1,319
Trader Rating: 3 (100%+)
Default

Originally Posted by BashemSmashem
But will never work as well , I have 2 MMP's and they are now my backups in my pit box ....
me 2

MMM in box and running two RX8's and great service to go with it
chucko is offline  
Old 12-10-2011, 10:38 AM
  #25553  
Tech Adept
iTrader: (4)
 
Join Date: Mar 2006
Posts: 138
Trader Rating: 4 (100%+)
Default

Quick question on the Upgrade kit.

I just received mine after 2 months of being on back order and started installing everything last night on the truck. Everything fit perfect except the new aluminum spring adjusters. Every time I tried to thread them on with Lube they would lock up about the time the threads hit the last few threads at the end of the adjuster. I have lube the crap out of them and even taken out the o-ring to see if they would thread onto the bodies but they would not. I even tried threading them on backwards to see if it was a bad threading issue with the shock bodies, stopped at the same area. And when I backed them off the bottoms of all of my shock bodies where the thread grooves are have the blue anodizing rubbed out of them. There is no cross threading on the body side or the adjuster side. I was wondering did anyone else have this issue with the adjusters or not. I put the old ones back on for now, but it is quite irritating.

Had this issue one other time with V1 of the 8ight buggy shock caps and buying a new set after the 8ight 2.0 came out, the threads did the same thing. Also no cross threading just took the hard coat between the threads. Took Losi two packages of caps to get 2 that would work.
Jammin_Xtream49 is offline  
Old 12-10-2011, 10:48 AM
  #25554  
Tech Master
iTrader: (9)
 
ScottKelly911's Avatar
 
Join Date: Jun 2010
Location: Los Angeles
Posts: 1,736
Trader Rating: 9 (100%+)
Default

Originally Posted by Jammin_Xtream49
Quick question on the Upgrade kit.

I just received mine after 2 months of being on back order and started installing everything last night on the truck. Everything fit perfect except the new aluminum spring adjusters. Every time I tried to thread them on with Lube they would lock up about the time the threads hit the last few threads at the end of the adjuster. I have lube the crap out of them and even taken out the o-ring to see if they would thread onto the bodies but they would not. I even tried threading them on backwards to see if it was a bad threading issue with the shock bodies, stopped at the same area. And when I backed them off the bottoms of all of my shock bodies where the thread grooves are have the blue anodizing rubbed out of them. There is no cross threading on the body side or the adjuster side. I was wondering did anyone else have this issue with the adjusters or not. I put the old ones back on for now, but it is quite irritating.

Had this issue one other time with V1 of the 8ight buggy shock caps and buying a new set after the 8ight 2.0 came out, the threads did the same thing. Also no cross threading just took the hard coat between the threads. Took Losi two packages of caps to get 2 that would work.
Mine did the same thing. It's very tough to see, but they ARE cross threading on the shock body side. It's almost undetectable to the naked eye. I used an Xacto knife to straighten out the threads and then they went straight on without any problems. You may want to try that technique. I think once the hardened shock bodies are out, that'll take care of this. Honestly, if I were to do it over again, I'd stick with the plastic stock spring collars, but use the aluminum vented shock caps.
ScottKelly911 is offline  
Old 12-10-2011, 01:49 PM
  #25555  
Tech Master
iTrader: (38)
 
alvinsmith75's Avatar
 
Join Date: Jul 2007
Location: New Orleans Area
Posts: 1,107
Trader Rating: 38 (100%+)
Default

Originally Posted by BashemSmashem
But will never work as well , I have 2 MMP's and they are now my backups in my pit box ....
Thats good, this way when you have to send the rx8 back to Tekin for repair multiple times you will not be dead in the water.
alvinsmith75 is offline  
Old 12-10-2011, 02:32 PM
  #25556  
Tech Rookie
 
Join Date: Dec 2011
Posts: 13
Default

I've been trying to read through a lot of these pages.

Looking at the front page. What would someone recommend for a "bashing" some track use, but probably not competing?

I'm talking about the combos on the front page. Seems that a lot of these might be unreliable from reading a lot of these posts?

Thanks for any help.
c.rod is offline  
Old 12-10-2011, 03:21 PM
  #25557  
Tech Addict
iTrader: (18)
 
Join Date: Apr 2011
Location: MI
Posts: 645
Trader Rating: 18 (100%+)
Default

Originally Posted by c.rod
I've been trying to read through a lot of these pages.

Looking at the front page. What would someone recommend for a "bashing" some track use, but probably not competing?

I'm talking about the combos on the front page. Seems that a lot of these might be unreliable from reading a lot of these posts?

Thanks for any help.
I would probably go with the Cast SCT Pro, Viper Copperhead (not out yet) or Hobbywing setup for bashing
teknic is offline  
Old 12-10-2011, 04:32 PM
  #25558  
Tech Master
iTrader: (24)
 
Feint Motion's Avatar
 
Join Date: Apr 2006
Location: So Cal IE
Posts: 1,346
Trader Rating: 24 (96%+)
Default

Originally Posted by c.rod
I've been trying to read through a lot of these pages.

Looking at the front page. What would someone recommend for a "bashing" some track use, but probably not competing?

I'm talking about the combos on the front page. Seems that a lot of these might be unreliable from reading a lot of these posts?

Thanks for any help.
Hobbywing Ezrun Sc8 is excellent for bashing/racing. Very reliable. I all of castles ESC's and they have gave me nothing but trouble. they are so good, I bought 2
Feint Motion is offline  
Old 12-10-2011, 04:48 PM
  #25559  
Tech Rookie
 
Join Date: Dec 2011
Posts: 13
Default

How come the pages are screwed up on this thread? I can never see the last page for some reason??

Anyway what about the Novak havoc/ballistic combo??
c.rod is offline  
Old 12-10-2011, 05:04 PM
  #25560  
Tech Master
iTrader: (24)
 
Feint Motion's Avatar
 
Join Date: Apr 2006
Location: So Cal IE
Posts: 1,346
Trader Rating: 24 (96%+)
Default

Originally Posted by c.rod
How come the pages are screwed up on this thread? I can never see the last page for some reason??

Anyway what about the Novak havoc/ballistic combo??
Novak ESC's pour out magic smoke, i would personally stay away from Novak ESC's.
Feint Motion is offline  

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Your Privacy Choices -

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.